Yapı olayları Visual C# .NET veya Visual C# 2005 nasıl

Makale çevirileri Makale çevirileri
Makale numarası: 810230 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

ÖNEMLI: Bu makale kayıt defterini değiştirmeyle ilgili bilgiler içermektedir. Kayıt defterini değiştirmeden önce yedeklediğinizden ve bir sorun çıkması durumunda kayıt defterini geri nasıl yükleyeceğinizi anladığınızdan emin olun. Kayıt defterini yedekleme, geri yükleme ve düzenleme ile ilgili bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
256986Microsoft Windows Kayıt Defteri'nin Açıklaması

Özet

Bu adım adım makalede, Visual C# .NET veya Visual C# 2005 yapı olayları uygulamak açıklamaktadır.

Yapı olaylar'ı kullandığınızda, belirli bir süre oluşturma işlemi sırasında oluşan bir eylem belirtebilirsiniz. Örneğin, regsvr32.exe kullanarak bir dosyayı kaydetmeye post-build bir olay belirtebilirsiniz. Ayrıca, görüntüleyebilir ve GAC (Global Assembly Cache) oluşturulmuş bir derlemede Gacutil.exe aracını kullanarak değişiklik.

Visual C# .NET veya Visual C# 2005 pre-build ve post-build olayları belirtmek için doğrudan hiçbir yöntem vardır.


Bir Visual C++ Makefile Project'e gerçekleştir Build olayları kullanın.

Yerleşik bir özelliği Visual C++ .NET proje yapı olaylardır. Bu olaylar, çözümde Visual C++ .NET Makefile proje ekleyerek, bir Visual C# .NET veya Visual C# 2005 projede uygulayabilirsiniz. Pre-Build olayları uygulamak için <a0></a0>, Visual C++ .NET Makefile proje bağımlı Visual C# .NET veya Visual C# 2005 projede yapmanız gerekir. POST-Build olayları uygulamak için <a0></a0>, Visual C++ .NET Makefile projede Visual C# .NET veya Visual C# 2005 proje bağımlı olmanız gerekir.

Bunu yapmak için şu adımları izleyin:
  1. Varolan Visual C# .NET veya Visual C# 2005 çözümünüz açın.
  2. Dosya menüsünde işaret Ekle Project ve sonra da New Project ' i tıklatın.
  3. Altında Project Types, Visual C++ Projects ' ı tıklatın ve MakeFile Projectşablonları altında'ı tıklatın.
    Not Visual Studio 2005'te "Visual C++ için" "Visual C++ Projects" değiştirilmelidir
  4. Çözüm için bir ad yazın, çözüm için bir konum belirtin ve sonra Tamam ' ı tıklatın.
  5. Makefile uygulama Sihirbazı, son ' u tıklatın.
  6. Makefile projenin Proje menüsünde Özellikler ' i tıklatın.
  7. Yapılandırma türü) kutusunda, yardımcı programı seçin ve Tamam ' ı tıklatın.
  8. Proje menüsünde Proje Dependencies… ' ı tıklatın. Pre-build olayları gerçekleştirmek için <a0></a0>, aşağıdaki adımları izleyin:
    1. Bağımlılıklar sekmesinde, projeleriVisual C# .NET uygun projeyi seçin ve Visual C++ Makefile proje üzerinde Depends altında'ı tıklatın.
    2. Değişikliği uygulamak için Tamam ' ı tıklatın. Bu, Visual C# .NET veya Visual C# 2005 proje son yerleşik kesinleştirir.
    3. Visual C++ Makefile proje Solution Explorer'da (Çözüm Gezgini) sağ tıklatın ve sonra da Properties ' i tıklatın.
    4. Olayları oluştur'ı tıklatın ve sonra da pre-build olay komut belirtin.
      Örneğin, bina önce dosya kopyalamak için aşağıdakileri belirtin:
      copy c:\AddinReg.reg $(OutDir)
  9. Post-build kurulumu gerçekleştirmek için <a0></a0>, aşağıdaki adımları izleyin:
    1. Visual C++ Makefile projeyi <a0>Projeler</a0> listesinde tıklatın ve sonra da uygun Visual C# .NET veya Visual C# 2005 proje üzerinde Depends altında seçin.
    2. Değişikliği uygulamak için Tamam ' ı tıklatın. Bu, Visual C++ proje son yerleşik kesinleştirir.
    3. Visual C++ Makefile proje Solution Explorer'da (Çözüm Gezgini) sağ tıklatın, Özellikler ' i tıklatın ve Olayları oluştur post-build olay komut belirtmek için tıklatın.

PrePostBuildRules eklenti gerçekleştir Build olayları için kullanın.

  1. Bu eklenti, çözüm ve proje düzeylerde pre-build ve post-build kurallarını sağlar.
    Eklentiyi karşıdan yüklemek için <a0></a0>, bkz: aşağıdaki Microsoft Web sitesi:

    http://download.microsoft.com/download/VisualStudioNET/Samples/7.0/NT5XP/EN-US/BuildRules.exe

    UYARı: Kayıt Defteri Düzenleyicisi'ni yanlış kullanırsanız, işletim sisteminizi yeniden yüklemenizi gerektirebilecek ciddi sorunlara neden olabilir. Microsoft, Kayıt Defteri Düzenleyicisi yanlış kullanımından kaynaklanan sorunları çözebileceğinizi garanti edemez. Kayıt Defteri Düzenleyicisi'ni kullanmak kendi sorumluluğunuzdadır.
    Bu eklentiyi kullanmak için aşağıdaki adımları izleyin:
    1. Bu kaynağı içeren çözüm dosyasını ve sonra çözüm oluşturun.
    2. Araçlar menüsünden Eklenti Yöneticisi ' ni tıklatın. Eklenti Yöneticisi zaten açıksa kapatın ve yeniden açın.

      Not Yeni eklenti içinde görünüyorsa, Ekle - Yöneticisi liste eklentiler, size başarıyla eklenti zimmetli malları.
    3. Eklenti içinde görüntülenmezse, Ekle - Yöneticisi listesinde, el ile kaydetmek için bu adımları izleyin:
      1. AddinReg.reg dosyayı BuildRules klasöründe bulun.
      2. AddinReg.reg ' ı sağ tıklatın ve sonra da <a2>Birleştir</a2>'i tıklatın. Girişleri kayıt defterine eklemeniz istendiğinde Evet ' i tıklatın.
      3. Yeni kayıt defterine yapılan girişlerin aşağıdaki konumda görülebilir:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\7.0\AddIns
    4. Visual Studio .NET veya Visual Studio 2005'ü başlatın.
    5. Yeni eklenti Araçlar menüsünden'ı tıklatın.
    6. Çözüm ya da proje seçin ve kural eklemek sağlayan BIR iletişim kutusu görüntülenir.
    7. Kural eklediğinizde, program adı çıkış penceresinde ham metni görüntülemek için echo adı belirtebilirsiniz.

Referanslar

Ek bilgi için aşağıdaki Microsoft Web sitesine bakın:

Visual Studio .NET Otomasyon Örnekleri
http://www.microsoft.com/downloads/details.aspx?familyid=3ff9c915-30e5-430e-95b3-621dccd25150&displaylang=en

Özellikler

Makale numarası: 810230 - Last Review: 10 Ocak 2007 Çarşamba - Gözden geçirme: 3.3
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Visual C# .NET 2002 Standard Edition
  • Microsoft Visual C# .NET 2003 Standard Edition
  • Microsoft Visual C++ .NET 2002 Standard Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C# 2005 Express Edition
Anahtar Kelimeler: 
kbmt kbdownload kbhowtomaster kbcompiler kbhowto KB810230 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:810230

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com