如何在 Visual C#.NET 或 Visual C# 2005年中實作建置事件

文章翻譯 文章翻譯
文章編號: 810230 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

重要: 本文包含修改登錄的相關資訊。 修改登錄之前請確定它備份起來,並請確定您瞭解如何在發生問題時還原登錄。如如何備份、 還原,以及編輯登錄有關,按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的發行項:
256986Microsoft Windows 登錄的描述

結論

本文將逐步告訴您,如何在 Visual C#.NET 或 Visual C# 2005年中實作建置事件。

當您使用 [建置事件時,您可以指定在特定的時間,在建置程序期間發生的動作。比方說,您可以指定建置後事件,藉由使用 regsvr32.exe 登錄的檔案。 您也可檢視與使用 Gacutil.exe 工具在 GAC (全域組件快取) 中產生的組件進行變更。

在 Visual C#.NET] 或 [Visual C# 2005年沒有直接的方法來指定建置前和建置後事件。


使用 Visual C++ Makefile 專案實作建置事件

建置事件是內建功能的 Microsoft Visual C++.NET 專案。您可以藉由 Visual C++.NET Makefile 專案包含方案中,Visual C#.NET 或 Visual C# 2005年的專案中實作這些事件。若要實作 建置前 事件,您必須讓 Visual C#.NET 或 Visual C# 2005年專案的 Visual C++.NET Makefile 專案相依。若要實作 建置後 事件,您必須讓 Visual C++.NET Makefile 專案的 Visual C#.NET 或 Visual C# 2005年的專案相依。

要這麼做,請您執行下列步驟:
  1. 開啟您現有的 Visual C#.NET 或 Visual C# 2005年方案。
  2. 在 [檔案] 功能表,移向 [新增專案,然後按一下 [新增專案
  3. 在 [專案類型 下, 按一下 [Visual C++ 專案,],然後在 [範本,按一下 MakeFile 專案]。
    附註在 Visual 的 Studio 2005 中"Visual C++ 專案 」 應該變更"Visual C++"。
  4. 輸入方案的名稱、 指定該方案的位置,然後按一下 [[確定]
  5. Makefile 應用程式精靈 中,按一下 [完成]。
  6. 按一下 [專案] 功能表的 Makefile 專案,內容
  7. 在 [設定類型] 方塊中選取 [公用程式,然後按一下 [[確定]
  8. 按一下 [專案] 功能表 專案 Dependencies…。若要進行建置前事件請依照下列步驟執行:
    1. 在 [相依性] 索引標籤上從 專案] 清單中選取 [適當的 Visual C#.NET 專案,然後再按一下 [相依於],] 下的 [Visual C++ Makefile 專案。
    2. 按一下 [確定] 以套用變更。如此可確保最後建置 Visual C#.NET 或 Visual C# 2005年的專案。
    3. 在 [方案總管] 在 Visual C++ Makefile 專案上按一下滑鼠右鍵,並再按 [內容]。
    4. 按一下 [建置事件,然後再指定建置前事件命令。
      比方說若要複製之前建置檔案,指定下列:
      copy c:\AddinReg.reg $(OutDir)
  9. 若要進行建置後安裝程式,請依照下列步驟執行:
    1. 按一下 [Visual C++ Makefile 專案在 [專案] 清單中的,然後選取適當的 Visual C#.NET 或 Visual C# 2005年專案 相依於] 之下。
    2. 按一下 [確定] 以套用變更。如此可確保最後建置 Visual C++ 專案。
    3. 以滑鼠右鍵按一下 [方案總管] 中的 [Visual C++ Makefile 專案,並按一下 [內容],然後按一下 [建置事件 來指定建置後事件命令。

使用 [PrePostBuildRules 」 增益集來實作建置事件

  1. 這個增益集提供建置前和建置後的規則,在方案和專案層級。
    若要下載增益集,請參閱下列 Microsoft 網站:

    http://download.microsoft.com/download/VisualStudioNET/Samples/7.0/NT5XP/EN-US/BuildRules.exe

    警告: 如果您未正確使用登錄編輯程式可能會導致嚴重的問題,甚至必須重新安裝作業系統。Microsoft 不保證您可以解決因不當使用 「 登錄編輯器 」 的問題。使用 「 登錄編輯程式 」,請自行負擔相關的風險。
    如果要使用此增益集,請依照下列步驟執行:
    1. 載入方案檔與此來源,然後再建置方案。
    2. 工具 功能表上按一下 [增益功能管理員]。如果增益功能管理員已經開啟,關閉,然後重新開啟。

      附註如果新的增益集出現在 新增-在管理員 清單的增益集您已經成功地登錄增益集。
    3. 如果增益集未出現在 新增-在管理員 列出,請依照下列步驟來手動登錄:
      1. 在 [BuildRules] 資料夾中找到 AddinReg.reg 檔案。
      2. AddinReg.reg,] 上按一下滑鼠右鍵,然後按一下 [合併]。按一下 [是] 將項目新增至登錄系統提示時。
      3. 對登錄做新的項目可以看到在下列位置:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\7.0\AddIns
    4. 啟動 Visual Studio.NET 或 Visual Studio 2005 的新執行個體。
    5. 在 [工具] 功能表上按一下 [另新的增益集新檔]。
    6. 此時會出現一個對話方塊,可讓您選取方案或專案,並為其新增規則。
    7. 當您將規則新增您可以指定名稱 回應 做為程式名稱,在 [輸出] 視窗中顯示未經處理的文字。

?考

如需詳細資訊請參閱下列 Microsoft 網站]:

Visual Studio.NET 的自動化範例
http://www.microsoft.com/downloads/details.aspx?familyid=3ff9c915-30e5-430e-95b3-621dccd25150&displaylang=en

屬性

文章編號: 810230 - 上次校閱: 2007年1月10日 - 版次: 3.3
這篇文章中的資訊適用於:
  • Microsoft Visual C# .NET 2002 Standard Edition
  • Microsoft Visual C# .NET 2003 標準版
  • Microsoft Visual C++ .NET 2002 Standard Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C# 2005 Express Edition
關鍵字:?
kbmt kbdownload kbhowtomaster kbcompiler kbhowto KB810230 KbMtzh
機器翻譯
重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。
按一下這裡查看此文章的英文版本:810230
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com