Lsass.exe Memory Usage Increasing Regardless of Server Load

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Article ID: 810585 - View products that this article applies to.
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SYMPTOMS

When you are finishing performance monitoring operations on your Windows 2000 Server computer, you notice that the memory being used by Lsass.exe is consistently increasing, regardless of the load being placed on the server.

CAUSE

This problem occurs when a client's User Datagram Protocol (UDP) request to the Kerberos Key Distribution Center (KDC) fails because the request exceeds the maximum UDP datagram size. The client will then retry the request by using TCP. This process is known as UDP/TCP failover. When this failover occurs, the client does not release the UDP buffers that were used in the original client request, and this causes the Lsass.exe memory leak.

This problem is apparent when clients issue ticket requests for user accounts that belong to a large number of security groups. The Kerberos ticket includes the group membership information. If a user account belongs to a large number of groups, this can cause the ticket size to exceed the UDP limit. When the ticket size exceeds the UDP limit, UDP/TCP failover occurs, which causes the Lsass.exe memory leak.

This problem occurs during both the interactive and logon processes.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date		Time		Version		Size		File name
--------------------------------------------------------------------------
11/18/2002	14:19		5.0.2195.6109	124,688		adsldp.dll
11/18/2002	14:19		5.0.2195.5781	131,34		adsldpc.dll
11/18/2002	14:19		5.0.2195.6109	62,736		dsmsext.dll
11/18/2002	14:19		5.0.2195.6052	358,160		advapi32.dll
11/18/2002	14:19		5.0.2195.6094	49,936		browser.dll
11/18/2002	14:19		5.0.2195.6012	135,952		dnsapi.dll
11/18/2002  	14:19		5.0.2195.6076	96,016 		dnsrslvr.dll
11/15/2001	15:27		n/a		5,149		empty.cat
11/18/2002  	14:19		5.0.2195.6125	45,328		eventlog.dll
11/18/2002	14:19		5.0.2195.6059	146,704		kdcsvc.dll
11/18/2002  	14:16		5.0.2195.6132	203,536		kerberos.dll
08/21/2002	08:27		5.0.2195.6023	71,248		ksecdd.sys
11/06/2002	18:02		5.0.2195.6118	507,664		lsasrv.dll
11/06/2002	18:02		5.0.2195.6118	33,552		lsass.exe
08/27/2002	14:53		5.0.2195.6034	108,816		msv1_0.dll
11/18/2002	14:19		5.0.2195.5979	307,472		netapi32.dll
11/18/2002	14:19		5.0.2195.6075	360,720		netlogon.dll
11/18/2002	14:19		5.0.2195.6127	921,872		ntdsa.dll
11/18/2002	14:19		5.0.2195.6100	389,392		samsrv.dll
11/18/2002	14:19		5.0.2195.6120	130,320		scecli.dll
11/18/2002	14:19		5.0.2195.6120	303,888		scesrv.dll
11/18/2002	12:34		5.0.2195.6126	141,824		sp3res.dll
11/13/2002	15:36		5.3.10.0       	4,096		spmsg.dll
11/13/2002	15:37		5.3.10.0       	87,040		puninst.exe
11/18/2002	14:19		5.0.2195.5859	48,912		w32time.dll
06/04/2002	13:32		5.0.2195.5859	57,104		w32tm.exe
11/18/2002	14:19		5.0.2195.6100	126,224		wldap32.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 810585 - Last Review: February 27, 2014 - Revision: 1.14
APPLIES TO
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbsecurity kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB810585

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