Help and Support

Error in Ikernel.exe When You Install Programs By Using InstallShield

Article ID:810608
Last Review:January 10, 2006
Revision:2.2

SYMPTOMS

When you try to install a program that uses InstallShield, you may receive the following error message:
The install Shield engine "ikernel.exe" could not be launched -Error loading type library /dll

Back to the top

CAUSE

This issue may occur if one or more of the following files are missing from the Windows\System32 folder:
Stdole32.tlb
Stdole2.tlb
Stdole.tlb

Back to the top

RESOLUTION

To resolve this issue, expand the appropriate file from the Windows XP CD:
1.Click Start, click Run, and then type CMD. Click OK.
2.To change to the root folder of drive C, type cd\, and then press ENTER.
3.Insert the Windows XP CD, type Expand cd_drive_letter:\i386\filename.tl_ drive:\Windows\system32\filename.tlb, and then press ENTER, where filename is the name of the file that you want to expand and drive is the letter of the drive where Windows is installed.

For help with the Expand command, type EXPAND /? at a command prompt.

Back to the top


APPLIES TO
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

Back to the top

Keywords: 
kberrmsg kbprb KB810608

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.