La connessione dal client VPN non può essere stabilita dopo l'installazione di un service pack

Traduzione articoli Traduzione articoli
Identificativo articolo: 810839 - Visualizza i prodotti a cui si riferisce l?articolo.
IMPORTANTE: in questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Description of the Microsoft Windows Registry
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di stabilire una connessione sulla rete privata virtuale (VPN) da un client PPTP basato su Windows XP o Windows 2000 alla rete dell'organizzazione, è possibile che la connessione non funzioni e che venga visualizzato il seguente messaggio di errore:
Errore 721: Il computer PPP remoto non risponde.

Cause

Questo problema si verifica quando da parte di un client PPTP basato su Windows XP Service Pack 1 (SP1) o Windows 2000 Service Pack 4 (SP4) viene effettuato il tentativo di stabilire una connessione VPN a un server Windows 2000 appartenente a un cluster nel quale viene utilizzato l'indirizzo IP virtuale del cluster sulla porta TCP 1723. Se per la risposta dal server vengono utilizzati pacchetti GRE (Generic Routing Encapsulation), verrà utilizzato l'indirizzo IP di origine del primo indirizzo IP associato alla scheda di rete. Questo indirizzo è tuttavia diverso dall'indirizzo IP virtuale richiesto dal client Windows XP. I pacchetti di risposta vengono scartati dal client Windows XP in quanto provengono da un indirizzo IP di origine diverso dall'indirizzo al quale è stato effettuato il tentativo di connessione.

Risoluzione

Informazioni sui service pack

Per risolvere questo problema è necessario ottenere la versione più recente del service pack per Microsoft Windows 2000. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
260910 How to Obtain the Latest Windows 2000 Service Pack

Informazioni sulla correzione rapida

È disponibile una correzione supportata da Microsoft, che è tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarla solo nei sistemi in cui si verifica questo problema specifico. È possibile che la correzione venga sottoposta ad altre verifiche allo scopo di migliorare ulteriormente la qualità del prodotto. Se dunque questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows 2000 (Service Pack 4) contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com/default.aspx?scid=fh;IT;CNTACT
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione. La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   
   Data        Ora    Versione       Dimensione  Nome file 
   ---------------------------------------------------------- 
   03/12/2002  11.57  5.0.2195.6150  47.088      Raspptp.sys 
   13/11/2002  15.36  5.3.10.0        4.096      Spmsg.dll 
   13/11/2002  15.37  5.3.10.0       87.040      Spuninst.exe 
   15/11/2001  15.27  n/d             5.149      Empty.cat

   Cartella Update

   Data        Ora    Versione  Dimensione  Nome file 
   ----------------------------------------------------- 
   03/12/2002  15.20  n/d         7.409     Q810839.cat 
   13/11/2002  15.37  5.3.10.0   18.432     Spcustom.dll 
   13/11/2002  15.36  5.3.10.0  409.088     Update.exe
Nota Questa correzione dovrebbe essere applicata al server PPTP Windows 2000.
AVVISO: l'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente.

Se si desidera consentire al client PPTP che esegue Windows XP SP1 o Windows 2000 SP4 o versione successiva di connettersi a un server PPTP dal quale vengono inviate risposte utilizzando un indirizzo IP diverso, disattivare la convalida dell'indirizzo PPTP attenendosi alla seguente procedura:
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella casella Apri digitare regedit, quindi scegliere OK.
  3. Nell'editor del Registro di sistema individuare la seguente sottochiave
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<000x>
    dove <000x> è la scheda di rete per il driver WAN Miniport (PPTP).
  4. Scegliere Nuovo dal menu Modifica, quindi Valore DWORD.
  5. Digitare ValidateAddress, quindi premere INVIO. L'impostazione predefinita per questo valore è 1 (attivata). Impostando pertanto il valore su 0 si disattiverà la convalida.
  6. Chiudere l'editor del Registro di sistema.
  7. Riavviare il computer.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo. Questo problema è stato corretto nel Service Pack 4 per Microsoft Windows 2000.

Informazioni

Per ulteriori informazioni su come ottenere un aggiornamento rapido per Windows 2000 Datacenter Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
271731 Earlier-Version PPTP Clients Cannot Connect to a Windows 2000 Server

Proprietà

Identificativo articolo: 810839 - Ultima modifica: venerdì 31 marzo 2006 - Revisione: 6.3
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 1
Chiavi: 
kbbug kbfix kbwin2000presp4fix kbqfe kbnetwork kbprb kbwin2ksp4fix kbhotfixserver KB810839
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com