Article ID: 810894 - View products that this article applies to.
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Symptoms

When you try to start or stop the Print Spooler service, or when you click Start and then click Printers and Faxes, you may receive the following error message:
Spooler subsystem app has encountered a problem and needs to close.
When you try to print, you receive the following error message:
Operation cannot be completed.

Cause

This issue may occur if a third-party printer driver or service affects the functionality of a newly installed printer.

For example, this issue may occur if the Lexmark custom printer driver (LexBce) is installed on your computer when you add another printer.

Resolution

To resolve this issue, follow the steps presented. You may find it easier to follow the steps if you print this article first.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

Step 1: Start the computer in safe mode

Start the computer in safe mode in order to remove spool files. To do this, follow these steps:
  1. Restart your computer and press the F8 key repeatedly while the computer is starting. On a computer that is configured to run multiple operating systems, press the F8 key when the Boot menu appears.
  2. Select Safe Mode when the Windows Advanced Options menu appears, and then press ENTER.
  3. If the Boot menu appears again and you are prompted to select an operating system, use the arrow keys to select the operating system, and then press ENTER.

    Note For more information about how to start your computer in safe mode, click Start, click Help and Support, type safe mode in the Search box, press ENTER, and then click the Start Windows in safe mode topic.

Step 2: Delete the spool printer and driver files

In safe mode, delete the spool printer and driver files. To do this, start Microsoft Windows Explorer, and then delete all the files and the folders in the following two folders (where C: is the drive where Windows XP is installed):
  • C:\Windows\System32\Spool\Printers
  • C:\Windows\System32\Spool\Drivers\w32x86

Step 3: Edit the registry

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

First, remove the Windows NT subkeys

Remove the potentially problematic registry entries for Windows NT x86 service subkeys. These may have been installed by third-party printer setup programs and may be interfering with the print spool service. Follow these steps to keep the drivers, print spools, and registry entries that were included with Windows and to remove all other drivers, print spools, and registry entries that may be causing issues.
  1. Start Registry Editor. To do this, click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and expand the following registry key to view the list of subkeys (subfolders):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
    In the subkey list, there should only be the following subkeys:
    • Drivers
    • Print Processors
  3. If there are any subkeys other than the subkeys that are listed in step 2, follow these steps:
    1. On the File menu, click Export.
    2. In the File Name box, type the name that you want to use for this key, such as WindowsNTx86regkey, and then click Save.

      You can use this backup of the
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
      registry key to restore the key if you experience any issues after you complete this procedure.
    3. Delete all the subkeys other than the subkeys that are listed in step 2. To do this, right-click each subkey that is not displayed on the list, and then click Delete. Click Yes when you are prompted to confirm the deletion.

Second, remove registry entries for the default print monitors

Remove the potentially problematic print monitor subkeys that may be interfering with the printer that you want to use. These may have been installed by third-party printer setup programs. Follow these steps to keep the print monitors and registry entries that were included with Windows and to remove all other print monitors and registry entries that may be causing issues.
  1. Start Registry Editor if it is not already open. To do this, click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then expand the following registry key to view the list of subkeys:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    In the list of subkeys, there should only be the following subkeys for the default print monitors:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  3. If there are any subkeys other than the subkeys that are listed in step 2, follow these steps:
    1. On the File menu, click Export.
    2. In the File Name box, type the name that you want to use for this key, such as Monitorsx86regkey, and then click Save.
    3. You can use this backup of the
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
      registry key to restore the key if you experience any issues after you complete this procedure.
    4. Delete all the subkeys other than the subkeys that are listed in step 2. To do this, right-click each subkey that is not displayed on the list, and then click Delete. Click Yes when you are prompted to confirm the deletion.
  4. Exit Registry Editor.
  5. If a printer is attached to the computer, disconnect the printer cable from the computer, and then restart the computer.

Step 4: Install the printer and print a test page

Reconnect the printer cable to the computer, install the printer according to the manufacturer’s instructions, and then try to print a test page.

If you still cannot print, or if you are still receiving the spool error, go to the "Next Steps" section.

NEXT STEPS

If these methods did not work for you, you can use the Microsoft Customer Support Services Web site to find other solutions to your problem. Some services that the Microsoft Customer Support Services Web sites provide include the following:
  • Searchable Knowledge Base: Search technical support information and self-help tools for Microsoft products.
  • Solution Centers: View product-specific frequently asked questions and support highlights.
  • Other Support Options: Use the Web to ask a question, contact Microsoft Customer Support Services, or provide feedback.
If you continue to have problems, you might want to contact Support:
http://support.microsoft.com/contactus

More information

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For troubleshooting steps and an automatic fix for common printer problems in Windows, please see the following Microsoft web page:


Troubleshooter: Printer problems in Windows

Properties

Article ID: 810894 - Last Review: May 22, 2013 - Revision: 7.0
Applies to
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kberrmsg kbprb KB810894

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