Spooler da CPU permanece acima de 50 % se uma porta LPR possui um nome DNS que não é válido para o servidor LPD

Traduções deste artigo Traduções deste artigo
ID do artigo: 810908 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Uso da CPU para o serviço de spooler de pode permanecer acima de 50 % se o nome de porta LPR para um servidor de impressão LPD não puder ser resolvido usando DNS. Cada vez que o serviço não pode contatar a impressora remota, evento 2007 está conectado:
IDENTIFICAÇÃO de evento: 2007
Fonte: LPR Print Monitor
Tipo: erro
Categoria: nenhum
O monitor de impressão LPR não pôde abrir a porta chamada port name or IP address.

Causa

O serviço de spooler tenta imprimir o trabalho indefinidamente.

Resolução


Windows Server 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Não pré-requisitos são necessários.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version           Size     File name      Platform
   ----------------------------------------------------------------------
   30-Nov-2004  22:17  5.2.3790.237      312,320  Localspl.dll   x86  
   30-Nov-2004  22:17  5.2.3790.220       81,920  Spoolss.dll    x86
   30-Nov-2004  22:07  5.2.3790.237      860,160  Localspl.dll   IA-64  
   30-Nov-2004  22:07  5.2.3790.220      234,496  Spoolss.dll    IA-64 

Windows 2000

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Windows 2000. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
260910Como obter o Service Pack mais recente do Windows 2000

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para aplicar esse hotfix, você deve ter o Windows 2000 Service Pack 2 instalado no computador.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   27-Nov-2002  09:17  5.0.2195.6109  124,688  Adsldp.dll
   27-Nov-2002  09:17  5.0.2195.5781  131,344  Adsldpc.dll
   27-Nov-2002  09:17  5.0.2195.6109   62,736  Adsmsext.dll
   27-Nov-2002  09:17  5.0.2195.6143  358,672  Advapi32.dll
   27-Nov-2002  09:17  5.0.2195.6094   49,936  Browser.dll
   27-Nov-2002  09:17  5.0.2195.6143  135,952  Dnsapi.dll
   27-Nov-2002  09:17  5.0.2195.6134   96,016  Dnsrslvr.dll
   27-Nov-2002  09:17  5.0.2195.6125   45,328  Eventlog.dll
   27-Nov-2002  09:17  5.0.2195.6137  147,216  Kdcsvc.dll
   22-Nov-2002  07:45  5.0.2195.6137  203,536  Kerberos.dll
   21-Aug-2002  05:27  5.0.2195.6023   71,248  Ksecdd.sys
   21-Nov-2002  06:15  5.0.2195.6136  507,664  Lsasrv.dll
   21-Nov-2002  06:15  5.0.2195.6136   33,552  Lsass.exe
   22-Nov-2002  07:20  5.0.2195.6137  109,328  Msv1_0.dll
   27-Nov-2002  09:17  5.0.2195.5979  307,472  Netapi32.dll
   27-Nov-2002  09:17  5.0.2195.6075  360,720  Netlogon.dll
   27-Nov-2002  09:17  5.0.2195.6136  921,872  Ntdsa.dll
   27-Nov-2002  09:13  5.0.2195.6143   66,832  Regsvc.exe
   27-Nov-2002  09:17  5.0.2195.6100  389,392  Samsrv.dll
   27-Nov-2002  09:17  5.0.2195.6120  130,320  Scecli.dll
   27-Nov-2002  09:17  5.0.2195.6120  303,888  Scesrv.dll
   22-Nov-2002  15:03  5.0.2195.6129  146,432  Sp3res.dll
   27-Nov-2002  09:17  5.0.2195.5859   48,912  W32time.dll
   04-Jun-2002  10:32  5.0.2195.5859   57,104  W32tm.exe
   27-Nov-2002  09:17  5.0.2195.6100  126,224  Wldap32.dll
				

A correção para esse problema cria uma caixa de diálogo no servidor. Esta caixa de diálogo indica que a porta LPR remota não pode ser encontrada e que a fila fará uma pausa. O administrador pode corrigir o problema de resolução de nomes e clique em OK na caixa de diálogo. Para continuar a fila de impressão remotamente, o trabalho deve ser excluído; o spooler do serviço será tentar o próximo trabalho de impressão.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo. Esse problema foi corrigido primeiro no Microsoft Windows 2000 Service Pack 4.

Como Contornar

Exclua impressoras LPR que não possuem nomes DNS válidos ou corrigir as entradas DNS no servidor DNS.

Mais Informações

Para obter informações adicionais sobre como obter um hotfix para Windows 2000 Datacenter Server, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
265173O programa Datacenter e o Windows 2000 Datacenter Server

Suporte técnico para as edições x 64 do Windows

O fabricante do hardware fornece suporte técnico e assistência para as edições x 64 do Microsoft Windows. O fabricante do hardware fornece suporte porque uma edição x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows com componentes exclusivos. Componentes exclusivos podem incluir drivers de dispositivo específico ou podem incluir configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisará de ajuda técnica com sua edição x 64 do Windows. No entanto, talvez você precise entrar em contato com o fabricante diretamente. O fabricante do seu melhor é qualificado para suportar o software que o fabricante do seu instalado no hardware.

Para informações de produto sobre o Microsoft Windows XP Professional x 64 Edition, visite o seguinte site:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Para informações de produto sobre o Microsoft Windows Server 2003 edições x 64, visite o seguinte site:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx

Propriedades

ID do artigo: 810908 - Última revisão: quinta-feira, 27 de fevereiro de 2014 - Revisão: 4.10
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbprint kbwin2ksp4fix kbqfe kbwin2000presp4fix kbfix kbbug KB810908 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 810908

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com