Programme de télécopie n'envoie pas de télécopie si le programme appelle FaxInitializeEventQueue() plusieurs fois par session de télécopie

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Sommaire

Symptômes

La fonction FaxInitializeEventQueue crée file d'attente un événement de télécopie pour le programme client télécopie appelant. La file d'attente permet au programme pour recevoir des notifications d'événements asynchrones de serveur de télécopie. Appel FaxInitializeEventQueue plusieurs fois par session de télécopie peut provoquer le télécopie du programme ne pas envoyer une télécopie. Le code d'état renvoyé est 0xC002000D (RPC_NT_TYPE_ALREADY_REGISTERED) si la file d'attente des événements télécopie est déjà initialisé. Utilisez la fonction GetLastError pour déterminer si votre programme reçoit cet état.

Cause

Le 0xC002000D code de retour (RPC_NT_TYPE_ALREADY_REGISTERED) est prévu, car la file d'attente des événements est déjà initialisé, mais il se n'est pas remappé à la spécification indiquée dans la documentation du Kit de développement Microsoft Platform SDK. La documentation indique que code d'erreur ERROR_INVALID_DATA (0x00000013) doit être retourné lorsqu'un programme appelle la fonction FaxInitializeEventQueue plusieurs fois au cours d'une session de télécopie.

Résolution

Informations sur le Service Pack

Pour résoudre ce problème, procurez-vous le dernier service pack pour Microsoft Windows 2000. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
260910 Comment faire pour obtenir le dernier Service Pack Windows 2000

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, soumettez une demande à Microsoft client service et support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue. La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en coordinated universal temps (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date        Time   Version        Size    File name
   ----------------------------------------------------
   12-13-2002  13:56  5.0.2195.6159  79,632  Winfax.dll	

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés au début de cet article. Ce problème a été corrigé dans Windows 2000 Service Pack 4.

Plus d'informations

Pour plus d'informations sur la façon d'obtenir un correctif pour Windows 2000 Datacenter Server, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
265173 Le programme et le Windows 2000 Datacenter Server produit

Propriétés

Numéro d'article: 810926 - Dernière mise à jour: vendredi 27 octobre 2006 - Version: 3.6
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
Mots-clés : 
kbmt kbautohotfix kbhotfixserver kbqfe kbnetwork kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB810926 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 810926
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