Article ID: 810949 - Last Review: February 21, 2007 - Revision: 3.3

The Explorer Shell Stops Responding When Viewing Recent Documents

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SYMPTOMS

The Explorer shell may stop responding when viewing the recent documents if it contains a document that resides in SharePoint Portal Server.

CAUSE

This problem is caused by a deadlock between two threads. When the Explorer shell is loading the SharePoint library Msonsext.dll file, the .dll file requests a lock that is already in use by another thread in the process. When this occurs, the Explorer shell seems to stop responding.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.

Service pack information

This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
312963  (http://support.microsoft.com/kb/312963/ ) How to obtain the latest SharePoint Portal Server 2001 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   09-Jan-2003  07:43  10.145.6011.3   1,327,104  Msonsext.dll     
 


Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 2 (http://support.microsoft.com/default.aspx?scid=kb;en-us;312963)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

APPLIES TO
  • Microsoft SharePoint Portal Server 2001
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbshareptportalsvr2001sp3fix kbshareptportalsvr2001presp2fix kbfix kbbug KB810949
 

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