ID evento 5722 registrato sul controller di dominio basato su Windows Server

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In questo articolo si applica a Windows 2000. Supporto per Windows 2000 le estremitÓ del 13 luglio 2010. Il Centro soluzioni fine del supporto di Windows 2000 Ŕ un punto di partenza per la pianificazione della strategia di migrazione da Windows 2000. Per ulteriori informazioni vedere il Criteri di ciclo di vita del supporto Microsoft.
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Sommario

Quando si utilizza il Visualizzatore eventi per visualizzare il Registro di sistema in un controller di dominio di Windows, pu˛ risultare evento 5722 registrato. Questo problema pu˛ verificarsi in uno dei due scenari:
  • Quando un computer aggiorna la password dell'account computer con un controller di dominio
  • Quando un computer viene aggiunto a un dominio con un nome giÓ esistente.
In questo articolo viene spiegato come distinguere i due scenari e risolvere il problema.

Sintomi

In un controller di dominio di Microsoft Windows, il seguente evento viene registrato nel Registro di sistema:
Tipo di evento: errore
Origine evento: NETLOGON
Categoria evento: nessuno
ID evento: 5722
Data: Data
Ora: Ora
Utente: n/D
Computer: Nomecomputer
Descrizione: L'impostazione della sessione dal computer Nomecomputer autenticazione non riuscita. ╚ il nome dell'account a cui fa riferimento nel database di protezione Nome account$.
Si Ŕ verificato il seguente errore:
Accesso negato.

Cause

In un dominio Microsoft Windows, a partire da Windows 2000, un canale di comunicazione consente di fornire un percorso di comunicazione pi¨ sicuro tra il controller di dominio e il membro server o workstation. Questo canale Ŕ noto come uncanale protetto. Quando si partecipa a un computer a un dominio, viene creato un account di computer e una password viene condiviso tra il computer e il dominio. Per impostazione predefinita, questa password viene modificata ogni 30 giorni. Password del canale protetto Ŕ memorizzata con l'account del computer nel controller di dominio primario (PDC). La password viene replicata in tutti i controller di dominio di replica.

Evento 5722 registrato nei seguenti scenari:
  • Quando un computer aggiorna la password dell'account computer con un controller di dominio, l'evento viene registrato nel Registro di sistema del controller di dominio di autenticazione.

    In questo scenario, il canale protetto del computer con il controller di dominio Ŕ ancora valido.
  • Quando si aggiunge un computer a un dominio utilizzando un nome che Ŕ giÓ in uso da un altro computer o quando si reimposta un account computer. Un account computer pu˛ essere reimpostato utilizzando Active Directory Users and Computers o utilizzando l'utilitÓ Netdom. exe.

    In questo scenario, password dell'account del computer non corrisponde la password sul controller di dominio e non Ŕ possibile impostare un canale protetto dal computer originale al controller di dominio.

Risoluzione

Messaggio di avviso Se si utilizza lo snap-in ADSI Edit, l'utilitÓ LDP o qualsiasi altro client LDAP versione 3 e si modificano erroneamente gli attributi degli oggetti di Active Directory, Ŕ possibile causare seri problemi. Questi problemi possono richiedere la reinstallazione di Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 o sia di Windows e di Exchange. Microsoft non garantisce che possano essere risolti i problemi che si verificano se si modificano erroneamente gli attributi degli oggetti di Active Directory. Modifica di questi attributi a proprio rischio.

Per risolvere il problema, determinare innanzitutto quale scenario Ŕ la causa del problema. A tale scopo, attenersi alla seguente procedura:
  1. Nota: la data e l'ora in cui Ŕ stato registrato l'evento nel Registro di sistema.
  2. Fare clic su Avviare, scegliere Programmi, scegliere Resource Kit, quindi fare clic su Console di gestione di strumenti.
  3. Nella struttura della console fare clic su Strumenti alla z.
  4. Nel riquadro dei dettagli fare clic su Editor ADSI.

    Nota ADSI Edit Ŕ incluso in strumenti di supporto di Windows. ╚ possibile installare gli strumenti di supporto dalla cartella Support\Tools del CD di Windows 2000 Server.

    Per ulteriori informazioni su come installare strumenti di supporto Windows per Windows 2000, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    301423Come installare gli strumenti di supporto di Windows 2000 su un computer basato su Windows 2000 Server
    Per installare ADSI Edit su computer che eseguono Windows Server « 2003 o sistemi operativi Windows « XP, installare strumenti di supporto di Windows Server 2003 dal CD di Windows Server 2003 o da (l'area Download Microsoftall'indirizzo http://go.microsoft.com/fwlink/?LinkId = 100114). Per ulteriori informazioni su come installare gli strumenti di supporto di Windows dal CD del prodotto, vedere Strumenti di supporto di installazione di Windows (all'indirizzo http://go.microsoft.com/fwlink/?LinkId = 62270).

    Nei server che eseguono Windows Server 2008 o Windows Server 2008 R2, ADSI Edit viene installato quando si installa il ruolo di servizi di dominio Active Directory (AD DS) per rendere un controller di dominio di un server. ╚ inoltre possibile installare Windows Server 2008 Server strumenti (amministrazione remota) su server membri del dominio o server autonomi. Per istruzioni specifiche, vedere installazione o rimozione (il pacchetto di strumenti di amministrazione remota Serverall'indirizzo http://go.microsoft.com/fwlink/?LinkId = 143345).

    Per installare ADSI Edit su computer che eseguono Windows Vista « con Service Pack 1 (SP1) o Windows 7, Ŕ necessario installare RSAT. Per ulteriori informazioni e per scaricare RSAT, vedere l'articolo 941314 nella (articolo della Microsoft Knowledge Baseall'indirizzo http://go.microsoft.com/fwlink/?LinkID = 116179).
  5. In ADSI Edit individuare e quindi fare clic su computer che ha causato il problema.
  6. Fare clic su ProprietÓ.
  7. In Selezionare le proprietÓ da visualizzare, fare clic su Entrambi.
  8. In Selezionare una proprietÓ da visualizzare, fare clic su PwdLastSet.
  9. Copiare il valore visualizzato nel Uno o pi¨ valori casella negli Appunti.
  10. Fare clic su Avviare, scegliere Programmi, scegliere Accessori, quindi fare clic su Calcolatrice.
  11. Nel Visualizzazione menu, fare clic su Scientifico.
  12. Fare clic su DEC Per impostare il sistema di numerazione decimale.
  13. Incollare il valore dagli Appunti nella calcolatrice.
  14. Per modificare il valore da decimale al sistema di numerazione esadecimale decimale, fare clic su Hex.
  15. Nel Modifica menu, fare clic su Copia.
  16. Incollare il numero esadecimale dagli Appunti in un file nel blocco note.
  17. Contare otto caratteri dal carattere a destra la maggior parte di stringa esadecimale e quindi premere BARRA SPAZIATRICE.

    Nota Questa azione divide la stringa esadecimale in due stringhe esadecimali.
  18. Se la stringa esadecimale sul lato sinistro contiene solo sette caratteri, Ŕ possibile aggiungere uno zero all'inizio della stringa.
  19. Al prompt dei comandi, digitare
    Nltest /time:RightSideHexadecimalstringLeftSideHexadecimalString
    VerrÓ visualizzato un output simile al seguente:
    C:\>nltest /time:a25cc370 01c294bc
    a25cc370 01c294bc = 11/25/2002 13:55:41 
    The command completed successfully.
    
  20. Nota decodificato data e ora.
  21. Controllare se la data e ora annotato nel passaggio 1 e decodificato data e ora in cui si Ŕ preso nota nel passaggio 20 corrispondenza.
  22. Se la data e l'ora Ŕ stato quell'evento 5722 registrato e la data decodificato e la corrispondenza del tempo, verificare se nel computer che causa il problema Ŕ un canale protetto stabilito con un controller di dominio digitando il seguente comando al prompt:
    Nltest /server:Nomecomputer /sc_query:NomeDominio
    Se nel computer di problema Ŕ un canale protetto valido stabilito con un controller di dominio, Ŕ possibile che venga visualizzato l'output Ŕ simile al seguente:
    C:\>Nltest /server:computer1 /sc_query:DomainNameFlags: 30
    HAS_IP HAS_TIMESERV
    Trusted DC Name \\homenode1.myhouse.comTrusted DC Connection Status Status = 0 0x0 NERR_SuccessThe command completed successfully.
    Se il computer il problema non Ŕ un canale protetto valido stabilito con un controller di dominio, Ŕ possibile che venga visualizzato l'output Ŕ simile al seguente:
    C:\>nltest /server:machine1 /sc_query:DomainNameFlags: 0 
    Trusted DC Name
    Trusted DC Connection Status Status = 5 0x5 ERROR_ACCESS_DENIEDThe command completed successfully.
Se la data e l'ora dell'evento 5722 e decodificato data e ora non corrispondono, password dell'account del computer il problema potrebbe non corrispondere alla password nel controller di dominio. Ci˛ pu˛ verificarsi in presenza di una delle seguenti circostanze:
  • Un amministratore reimposta un account computer tramite utenti e computer o un altro strumento, ad esempio Netdom. exe.
  • Un nuovo computer viene aggiunto al dominio utilizzando un nome giÓ esistente nel dominio.
Nota Se la registrazione del servizio Accesso rete Ŕ attivata per il controller di dominio, Ŕ possibile verificare questo scenario, verificando una voce di Netlogon. log Ŕ simile al seguente:
05/06 13:35:25 [MISC] NlMainLoop: Notification that trust account added (or changed) TRUSTING_DOMAIN$ 0x#### 4
Questo messaggio non viene registrato se la propria password di account computer viene aggiornato un computer.

Per risolvere i problemi relativi ai nomi di computer duplicati, aggiungere il computer originale al dominio.

╚ possibile ignorare l'evento 5722 se sono vere entrambe le seguenti condizioni:
  • Se la data e ora dell'evento 5722 e decodificato data e ora corrispondenti.
  • Un canale protetto valido viene stabilito tra il problema e un controller di dominio.
Nota Quando entrambe le condizioni sono vere, evento 5722 viene registrato nel controller di dominio quando il computer tenta di eseguire l'autenticazione con un controller di dominio durante il processo di aggiornamento di account computer.

Gli amministratori possono anche query informazioni di Active Directory da qualsiasi computer nel dominio utilizzando Ldp. exe. La versione di Ldp. exe Ŕ incluso in strumenti di supporto di Windows XP Service Pack 2 consente inoltre di decodificare il valore PwdLastSet.

Per ulteriori informazioni su strumenti di supporto di Windows XP Service Pack 2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
838079Strumenti di supporto di Windows XP Service Pack 2
Inoltre, Ŕ possibile utilizzare l'utilitÓ di Windows XP W32tm. exe per decodificare il valore PwdLastSet.

Riferimenti

Per ulteriori informazioni sull'abilitazione della registrazione di debug, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
221833Come attivare la registrazione di debug dell'ambiente utente build di Windows
109626 abilitazione della registrazione di debug per il servizio Accesso rete

ProprietÓ

Identificativo articolo: 810977 - Ultima modifica: giovedý 26 maggio 2011 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
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  • Windows Server 2008 Standard
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Clicca qui per visualizzare la versione originale in inglese dell?articolo: 810977
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