Help and Support
 

powered byLive Search

โปรแกรม Internet Explorer บันทึกรูปภาพเป็นบิตแมพ (ไฟล์ .bmp)

หมายเลขบทความ (Article ID):810978
รีวิวครั้งสุดท้าย:12 เมษายน 2549
Revision:4.2

สรุป

เมื่อคุณบันทึกไฟล์รูปภาพในโปรแกรม Microsoft Internet Explorer ภาพจะได้รับการบันทึกเป็นบิตแมพ (.bmp) โดยค่าดีฟอลต์ โดยไม่มีตัวเลือกเพื่อบันทึกภาพโดยใช้นามสกุลอื่นๆ นอกจาก .bmp โดยคุณจะพบเหตุการณ์นี้แม้ว่าภาพนั้นจะเป็นรูปแบบอื่นๆ ก็ตาม (เช่น .gif หรือ .jpeg)

ตัวอย่างเช่น เมื่อคุณคลิกขวาที่รูปภาพบนเว็บเพจ แล้วคลิก Save Picture As ชื่อไฟล์ที่ปรากฏในบ็อกซ์ File name คือ Untitled และประเภทไฟล์ที่ปรากฏในบ็อกซ์ Save as type คือ Bitmap (*.bmp)

กลับไปด้านบน

สาเหตุ

เหตุการณ์นี้อาจเกิดขึ้นเนื่องจากโปรแกรมไฟล์ชำรุด (เช่น ActiveX หรือ Java object) ที่ดาวน์โหลดมายังโฟลเดอร์ SystemRoot\Downloaded Program Files ในฮาร์ดดิสก์ของคุณ

กลับไปด้านบน

การแก้ไข

การแก้ไขปัญหานี้ ให้ลบเนื้อหาในโฟลเดอร์ Temporary Internet Files และลบไฟล์ต่างๆ ในโฟลเดอร์ Downloaded Program Files ที่แสดงเป็น Unknown หรือ Damaged โดย:
1.เปิดใช้งานโปรแกรม Internet Explorer (หากยังไม่ได้เปิดโปรแกรม)
2.ลบเนื้อหาในโฟลเดอร์ Temporary Internet Files โดย:
a. ที่เมนู Tools ให้คลิก Internet Options
b. คลิกแท็บ General
c. ที่ Temporary Internet files คลิก Delete Files
d. เมื่อระบบพรอมต์ว่าคุณต้องการลบไฟล์ temporary Internet files ทั้งหมดหรือไม่ ให้คลิก OK
3. ในโฟลเดอร์ Downloaded Program Files ในฮาร์ดดิสก์ ให้ลบไฟล์ต่างๆ ที่แสดงเป็น Unknown หรือDamaged โดย:
a. ที่เมนู Tools ให้คลิก Internet Options
b. คลิกแท็บ General
c. ที่ Temporary Internet files คลิก Settings
d. คลิก View Objects

รายการของโปรแกรมไฟล์ต่างๆ ที่ได้รับการดาวน์โหลดมายังโฟลเดอร์ SystemRoot\Downloaded Program Files ในฮาร์ดดิสก์ของคุณจะปรากฏในวินโดว์ Downloaded Program Files
e. ในคอลัมน์ Status ตรวจหาไฟล์ที่แสดงเป็น Unknown หรือ Damaged ลบไฟล์เหล่านั้น โดยให้คลิกขวาที่ไฟล์แล้วคลิกเลือก Remove
f. เมื่อระบบพรอมต์ให้คุณยืนยันการลบ ให้คลิก Yes
g. ปิดวินโดว์ Downloaded Program Files แล้วคลิก OK สองครั้ง
4.บันทึกภาพในโปรแกรม Internet Explorer เพื่อทดสอบและให้แน่ใจว่าได้แก้ไขปัญหานี้แล้ว

หากยังคงเกิดปัญหานี้อยู่หลังจากคุณลบไฟล์โปรแกรมที่ดาวน์โหลดทั้งหมดที่แสดงเป็น Unknown หรือ Damaged แล้ว ให้ลองลบไฟล์โปรแกรมอื่นๆ ที่ดาวน์โหลดมาซึ่งปรากฏในรายการ

หมายเหตุ: ครั้งถัดไปที่คุณต้องการไฟล์ต่างๆ ที่คุณลบจากโฟลเดอร์ Downloaded Program Files แล้ว คุณจะได้รับการพรอมต์ให้ดาวน์โหลดไฟล์นั้นๆ มายังฮาร์ดดิสก์ของคุณในโปรแกรม Internet Explorer
หากคุณทำตามขั้นตอนต่างๆ เหล่านี้แล้ว และยังคงเกิดปัญหานี้ ให้ย้ายไฟล์จากโฟลเดอร์ Temporary Internet Files ไปยังตำแหน่งอื่น การย้ายไฟล์ ให้ทำตามขั้นตอนต่อไปนี้:
1.เปิดโปรแกรม Internet Explorer
2.ที่เมนู Tools ให้คลิก Internet Options
3.ที่แท็บ General คลิก Settings ที่ Temporary Internet files
4.คลิก Move Folder
5.ในไดอะล็อกบ็อกซ์ Browse for Folder เลือกตำแหน่งใหม่สำหรับโฟลเดอร์ แล้วคลิก OK
6.คลิก OK เพื่อปิดไดอะล็อกบ็อกซ์ Settings
7.เมื่อคุณได้รับข้อความเตือนต่อไปนี้ ให้คลิก Yes:
Windows will now log you off to finish moving Temporary Internet Files.
Do you want to continue?
(All other changes have been saved.)
Windows จะล็อกออฟคุณออกจากคอมพิวเตอร์โดยอัตโนมัติ
8.ล็อกอินกลับเข้าสู่เครื่องคอมพิวเตอร์

กลับไปด้านบน

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการแก้ไขเรื่องที่คล้ายกัน ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความต่างๆ ใน Microsoft Knowledge Base:
260650 (http://support.microsoft.com/kb/260650/) Internet Explorer ไม่มีไฟล์กราฟิกในรูปแบบที่เหมาะสม (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
250747 (http://support.microsoft.com/kb/250747/) คลิกขวา การเลือก 'Save Picture As' ไม่บันทึกรูปภาพด้วยนามสกุลที่ถูกต้อง (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)

กลับไปด้านบน


ใช้กับ
•Microsoft Internet Explorer 5.5
•Microsoft Internet Explorer 6.0 เมื่อใช้กับ:
  Microsoft Windows XP Home Edition
  Microsoft Windows XP Professional
  Microsoft Windows XP Media Center Edition
  Microsoft Windows XP Tablet PC Edition
  Microsoft Windows 2000 Advanced Server
  Microsoft Windows 2000 Datacenter Server
  Microsoft Windows 2000 Professional Edition
  Microsoft Windows 2000 Server
  Microsoft Windows NT Server 4.0 Standard Edition
  Microsoft Windows NT Server 4.0, Terminal Server Edition
  Microsoft Windows NT Workstation 4.0 Developer Edition
  Microsoft Windows Millennium Edition
  Microsoft Windows 98 Second Edition
  Microsoft Windows 98 Standard Edition

กลับไปด้านบน

Keywords: 
kbqfe kbhotfixserver KB810978

กลับไปด้านบน

การแปลบทความ

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.