Message Queue Server no puede abrir colas públicas locales a menos que resuelve el nombre de controlador de dominio MQIS o Active Directory

Seleccione idioma Seleccione idioma
Id. de artículo: 811033 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Síntomas

Si Message Queue Server no puede resolver el nombre del controlador de dominio o MQIS (almacén de información de cola de mensajes), se produce un error cuando intenta abrir colas públicas. Message Queue Server no se puede inicializar en modo sin conexión (y no puede abrir colas públicas locales) si no puede resolver el nombre del servidor de controlador de dominio o de MQIS.

Causa

Cada cliente de Message Queue Server mantiene una lista de servidores MQIS en el registro (recolectores de eventos primarios de Microsoft Windows NT 4.0 [PEC], [PSC] de controladores de sitio principal, los controladores de reserva de sitio [BSC] o controladores de dominio de Windows 2000). Cuando uno de los servidores en la lista no responde, MSMQ salta al siguiente servidor. Sin embargo, si no se puede resolver la dirección IP del servidor, Message Queue Server se cerrará y detiene el proceso de resolución de nombres.

Solución

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-Dec-2002  21:15  5.1.0.1035         67,200  Mqac.sys
   04-Dec-2002  21:16  5.1.0.1035         17,408  Mqbkup.exe       
   04-Dec-2002  21:47  5.1.0.1035         44,032  Mqdscli.dll      
   04-Dec-2002  21:46  5.1.0.1035        611,328  Mqqm.dll         
   04-Dec-2002  21:46  5.1.0.1035        164,864  Mqrt.dll         
   04-Dec-2002  21:46  5.1.0.1035         89,088  Mqsec.dll        
   05-Dec-2002  18:33  5.3.10.0        1,018,216  Q811033_wxp_sp2_x86_enu.exe  

				

La información siguiente aparece en el registro de diagnóstico MSMQ cuando se produce este problema:
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/20, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/80, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/130, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/220, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: qmcommnd/20, HR: 0x80072af9

Propiedades

Id. de artículo: 811033 - Última revisión: jueves, 27 de febrero de 2014 - Versión: 4.1
La información de este artículo se refiere a:
  • Microsoft Message Queue Server 3.0
  • Microsoft Windows XP Professional
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe KB811033 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 811033

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com