Powolne lub opóźnione aktualizacje ekranu po ponownym nawiązaniu połączenia z sesją konsoli

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 811080 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został zarchiwizowany. Jest oferowany „taki, jaki jest” i nie będzie już aktualizowany.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Po nawiązaniu połączenia z sesją konsoli na komputerze z systemem Microsoft Windows XP przy użyciu klienta Pulpitu zdalnego aktualizacje ekranu mogą następować z opóźnieniem, a komputer może przestać odpowiadać. Kliknięcie pulpitu prawym przyciskiem myszy może wymusić wprowadzenie opóźnionych aktualizacji.

Przyczyna

Ten problem powinien występować tylko w przypadku wywołania konkretnej funkcji biblioteki Win32 (EnumDisplaySettings) wtedy, gdy poprzednia sesja RDP konsoli jest rozłączona.

Rozwiązanie

Informacje o dodatku Service Pack

W celu rozwiązania tego problemu należy uzyskać najnowszy dodatek Service Pack dla systemu Microsoft Windows XP. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322389 Jak uzyskać najnowszy dodatek Service Pack dla systemu Windows XP

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem. Ta poprawka może być nadal w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka. Wersja angielskojęzyczna tej poprawki ma atrybuty plików wymienione w poniższej tabeli (lub nowsze). Daty i godziny odpowiadające tym plikom zostały podane w formacie uniwersalnego czasu koordynowanego (UTC). Podczas wyświetlania informacji dotyczących plików są one konwertowane na czas lokalny. Aby sprawdzić różnicę między czasem UTC i czasem lokalnym, należy skorzystać z karty Strefa czasowa apletu Data i godzina w Panelu sterowania.
   Data        Godzina  Wersja         Rozmiar  Nazwa pliku  Platforma   Service Pack
   --------------------------------------------------------------------
   18-gru-2002  19:03  5.1.2600.108    87 048  Rdpdd.dll  x86      brak
   20-gru-2002  21:55  5.1.2600.1152   87 304  Rdpdd.dll  x86         1
   18-gru-2002  19:03  5.1.2600.108   259 976  Rdpdd.dll  IA64     brak
   05-gru-2002  01:28  5.1.2600.1148  261 128  Rdpdd.dll  IA64        1

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”. Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 2 dla systemu Microsoft Windows XP.

Więcej informacji

Wystąpienie tego problemu nie jest związane z innymi symptomami na komputerze (na przykład nie zmienia się użycie procesora). Przyczynę problemu można usunąć za pomocą logowania interaktywnego (przy konsoli fizycznej).

Aby sprawdzić, czy ten problem występuje, należy uruchomić wiersz polecenia i wpisać kilka znaków. Jeśli problem występuje, znaki pojawią się dopiero po kliknięciu pulpitu prawym przyciskiem myszy.

Agent ewidencji programu SMS (Systems Management Server) firmy Microsoft korzysta z klas WMI Win32_DisplayControllerConfiguration i Win32_VideoController. Używają one funkcji związanej z omawianym problemem. Ten agent jest regularnie uruchamiany w tle (jako usługa), przez co wywołuje ten problem w przypadku pozostawienia rozłączonej sesji konsoli zdalnej.

Właściwości

Numer ID artykułu: 811080 - Ostatnia weryfikacja: 27 lutego 2014 - Weryfikacja: 5.5
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP 64-Bit Edition SP1
Słowa kluczowe: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbfix kbbug kbwinxppresp2fix KB811080

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com