BizTalk Server použije prvek <prop:identity> namísto prvek <rcpt:identity> pro příjmy

Překlady článku Překlady článku
ID článku: 811092 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

BizTalk Server není kompatibilní s BizTalk Framework. BizTalk Framework 2.0: Dokladu a specifikace zpráv uvedeno, že prvek //deliveryReceipt/identity patří do oboru názvů http://schemas.biztalk.org/btf-2-0/receipts. Prvek //deliveryReceipt/identity však deklaruje obor názvů http://schemas.biztalk.org/btf-2-0/properties.

Pokud odesílání zpráv BizTalk Framework obálky k BizTalk serveru a požadovat potvrzení o doručení, potvrzení o doručení splnit specifikaci BizTalk Framework. Například uvedeny následující řádek v potvrzení o doručení:
<prop:identity xmlns:prop="http://schemas.biztalk.org/btf-2-0/properties">uuid:31C24EF4-EF6C-4DAE-8CE0-ACDE53AAEFC6</prop:identity>
By měl být tento řádek:
<rcpt:identity xmlns:prop="http://schemas.biztalk.org/btf-2-0/properties">uuid:31C24EF4-EF6C-4DAE-8CE0-ACDE53AAEFC6</rcpt:identity>

Příčina

K tomuto problému dochází, protože kód použít <rcpt:identity> prvek. Místo toho kód používá <prop:identity> prvek.

Řešení

Informace o aktualizaci Service Pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro Microsoft BizTalk Server 2002. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
815781Jak získat nejnovější aktualizaci service pack pro BizTalk Server 2002

Informace o opravě hotfix

Kompatibilita mezi úrovněmi aktualizace service Pack a verze BizTalk Server je tato oprava hotfix scénář všechny nebo nic. Měli byste nainstalovat tuto opravu hotfix nebo BizTalk Server 2002 Service Pack 1 na všech serverech se systémem BizTalk Server 2002. Patří mezi partnery. Pokud jsou servery BizTalk Server 2000 se systémem také v prostředí by měl také instalaci této opravy hotfix. Patří mezi partnery.

BizTalk Server 2002

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
Date         Time   Version     Size	  File name		 
------------------------------------------------------
06-Dec-2002  21:58  3.0.1554.0  721,168  Cisparser.dll


BizTalk Server 2000,

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.
Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
Date         Time   Version     Size	  File name		 
------------------------------------------------------
31-Jul-2003  14:29  2.0.2009.0  680,208   Cisparser.dll
31-Jul-2003  14:29  2.0.2009.0  688,400   Ciscore.dll

Další informace

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Po instalaci této aktualizace service pack nebo opravy hotfix musíte vytvořit následující položky registru a nastavte hodnotu položky 1 způsobit BizTalk používat nový formát příjmu (<rcpt:identity…>). Pokud nainstalujete tuto aktualizaci service pack nebo opravy hotfix, problémy s kompatibilitou může dojít při výměně příjmy mezi dvěma systémy BizTalk Server, pokud aktualizace service pack nebo opravy hotfix není nainstalován v obou systémech a pokud oba systémy není generování příjmy pomocí nového formátu.
Zmenšit tuto tabulkuRozšířit tuto tabulku
NÁZEV KLÍČETYPEUmístění
UseFixedReceiptFormatREG_DWORDHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSvc
Chcete-li vytvořit tuto hodnotu v registru, postupujte takto:
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedit.
  2. Vyhledejte položku registru a pak vytvořte novou hodnotu DWORD pomocí informací v tabulce.

    Hodnota 1 označuje, že nový formát příjmu (<rcpt:identity…>) je generován, a hodnota 0 označuje, že původní příjmu formátovat (<prop:identity…>) je generován.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Tento problém byl poprvé opraven v Microsoft BizTalk Server 2002 Service Pack 1.

Vlastnosti

ID článku: 811092 - Poslední aktualizace: 15. listopadu 2007 - Revize: 3.10
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft BizTalk Server 2002 Standard Edition
  • Microsoft BizTalk Server 2000 Standard Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbiztalk2002sp1fix kbfix KB811092 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:811092

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com