Article ID: 811117 - Last Review: October 26, 2006 - Revision: 3.6

SMTP addresses of messages that are sent through a GroupWise Internet Agent are not displayed correctly

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SYMPTOMS

When a Novell GroupWise user sends a message to a user with a mailbox on Microsoft Exchange 2000 Server, you may find that the sender's Simple Mail Transfer Protocol (SMTP) address appears incorrectly when the Exchange 2000 recipient opens and views the message. If the recipient replies to the message, the reply is not delivered.

When the recipient opens and views the message in Microsoft Outlook, you expect the GroupWise address of the sender to appear similar to the following address:
  • UserName@Domain.com
However, the GroupWise address of the sender may appear similar to one of the following addresses:
  • UserName.[Domain.com]WPD=Internet, WPU=UserName, ARI=Domain.com
  • WPD=Internet, WPU=UserName, ARI=[Domain.com]
  • WPD=domain, WPPO=gwia, WPU=UserName, ARI=Domain.com
  • WPD=firsthopdom, WPPO=firsthoppo, WPU=UserName, ARI=Domain

CAUSE

This problem may occur if the message is received by the GroupWise Internet Agent and then passed to the Exchange 2000 computer through the GroupWise API gateway. In this situation, the method that Exchange 2000 uses to generate the SMTP address is incorrect.

RESOLUTION

Cumulative rollup information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282  (http://support.microsoft.com/kb/824282/ ) September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Component: GroupWise Mail Connector

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time     Version        Size        File name
   ------------------------------------------------------------
   31-Jan-2003  21:04      6.0.6410.0     40,960   Gw2mex.exe
   31-Jan-2003  21:03      6.0.6410.0    110,592   Gwhc.dll
   31-Jan-2003  21:07      6.0.6410.0    868,352   Lsadmin.exe
   31-Jan-2003  20:59      6.0.6410.0    163,840   Lscms.dll
   31-Jan-2003  20:59      6.0.6410.0     73,728   Lslde.dll
   31-Jan-2003  20:59      6.0.6410.0     28,672   Lsldew.dll
   31-Jan-2003  20:59      6.0.6410.0    139,264   Lsmexhc.dll
   31-Jan-2003  20:59      6.0.6410.0    237,568   Lsmexif.dll
   31-Jan-2003  21:02      6.0.6410.0     20,480   Lsmexin.exe
   31-Jan-2003  21:02      6.0.6410.0     40,960   Lsmexnts.exe
   31-Jan-2003  21:02      6.0.6410.0     20,480   Lsmexout.exe
   31-Jan-2003  20:59      6.0.6410.0    118,784   Lsmmdodb.dll
   31-Jan-2003  20:59      6.0.6410.0    200,704   Lsntshc.dll
   31-Jan-2003  21:03      6.0.6410.0     49,152   Lsntsmex.exe
   31-Jan-2003  21:03      6.0.6410.0     49,152   Lsxfm.dll
   31-Jan-2003  21:04      6.0.6410.0     32,768   Mex2gw.exe
				
Note Because of file dependencies, this update requires Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191914  (http://support.microsoft.com/kb/191914/ ) How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply this hotfix, you must also make sure that the values of the following registry subkeys are set correctly:
  • Make sure that the value of the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LME-GWISE\Parameters\AssumeARIisInternetDomain subkey is set to 1.
  • Make sure that the value of the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LME-GWISE\Parameters\ListofGWIAs is set to domain.gwia,domain2.gwia,domain3.gwia.
Note Both these registry entries are String values.

The AssumeARIisInternetDomain=1 entry forces the new address code to treat all additional routing information in addresses as the domain part of an SMTP address. If you cannot determine whether the additional routing information in addresses is always the domain part of an SMTP address, you can create a list of the GroupWise Internet Agents that are in the GroupWise organization. To do so, replace Domain.gwia with the actual address of the GroupWise Internet Agents that are in the GroupWise organization. This entry permits the new addressing code to determine if a message was sent through a GroupWise Internet Agent. If a message was not sent through a GroupWise Internet Agent, Exchange 2000 performs additional work to extract an SMTP address.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbfix kbbug KB811117
 

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