Artigo: 811150 - Última revisão: sexta-feira, 13 de Abril de 2007 - Revisão: 3.0

O programa de configuração pára e reinicia repetidamente no Windows XP

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta instalar o Microsoft Windows XP, poderá detectar uma cadeia de eventos repetidos que incluem alguns dos seguintes:
  • Recebe a seguinte mensagem de erro quando tenta formatar o disco rígido durante a configuração:
    O programa de configuração levou a cabo a manutenção do disco rígido. Tem de reiniciar o computador para continuar o programa de configuração.
  • Recebe a seguinte mensagem durante a configuração:
    O programa de configuração não consegue efectuar a operação pedida na partição seleccionada. Esta partição contém ficheiros temporários do programa de configuração necessários para concluir a instalação.
  • O computador deixa de responder (não reage ou bloqueia) e, em seguida, recebe a seguinte mensagem de erro fatal:
    Foi encontrado um erro que impede o programa de configuração de continuar. Não foi possível instalar um dos componentes de que o Windows necessita para continuar a configuração. Erro de dados (erro por redundância cíclica)
Quando reinicia o computador depois de receber estas mensagens, o programa de configuração é iniciado novamente e o processo poderá repetir-se.

Causa

Este problema poderá ocorrer se o disco rígido estiver danificado. Recebe as mensagens de erro devido ao programa de configuração estar a tentar reparar o problema no disco rígido.

Resolução

Para resolver este problema, utilize os seguintes métodos, pela ordem em que são apresentados até o problema estar resolvido.

Método 1: Deixar o programa de configuração reparar o disco rígido

Repita o ciclo de execução do programa de configuração, reiniciando o computador quando tal lhe for solicitado e permitindo ao programa de configuração reparar o disco. O programa de configuração poderá ser concluído com êxito após várias repetições. Se o ciclo continuar após várias repetições, avance para o método 2.

Método 2: Executar "chkdsk /r" a partir da consola de recuperação

Para executar chkdsk /r a partir da consola de recuperação, siga estes passos:
  1. Reinicie o computador.
  2. Quando o ecrã "Bem-vindo ao programa de configuração" for apresentado, prima R para iniciar a consola de recuperação.
  3. Se tiver um computador com arranque duplo ou arranque múltiplo, seleccione a instalação a que tem de aceder a partir da consola de recuperação.
  4. Quando tal lhe for solicitado, escreva a palavra-passe de administrador. Se a palavra-passe de administrador for em branco, prima ENTER.
  5. Na linha de comandos, escreva chkdsk /r e prima ENTER.
  6. Quando a execução do Chkdsk for concluída, leia os resultados e execute os passos necessários para concluir o processo. Por exemplo, o utilizador poderá ser solicitado a executar chkdsk /f para corrigir determinados problemas.
  7. Reinicie o computador e tente executar o programa de configuração novamente.

Método 3: Substituir a unidade de disco rígido

Se a unidade de disco rígido estiver danificada e não puder ser reparada, poderá ser necessário substituí-la. Contacte o fabricante do computador, o revendedor onde comprou o computador ou um técnico qualificado para obter informações sobre como substituir o disco rígido.

Mais Informação

Para obter informações adicionais sobre a consola de recuperação, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
307654  (http://support.microsoft.com/kb/307654/ ) Como instalar e utilizar a 'Consola de recuperação' no Windows XP
314058  (http://support.microsoft.com/kb/314058/ ) Descrição da consola de recuperação do Windows XP

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kberrmsg kbprb KB811150