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Your multiprocessor Microsoft Windows 2000 Server-based computer or multiprocessor Windows Server 2003-based computer may stop responding, and the keyboard may not work correctly

Article ID:811211
Last Review:October 11, 2007
Revision:3.5

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SYMPTOMS

On a multiprocessor Microsoft Windows 2000 Server-based computer or on a multiprocessor Microsoft Windows 2003-based computer, your computer may stop responding, and the keyboard may not work correctly.

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CAUSE

This problem may occur if an incorrectly synchronized call is made to the IOCancelIrp function.

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RESOLUTION

Service pack information

Windows Server 2003

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 (http://support.microsoft.com/kb/889100/) How to obtain the latest service pack for Windows Server 2003

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Hotfix information

Windows 2000 Server

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
File information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   21-Mar-2003  20:43  5.0.2195.6692      12,664  Tdasync.sys
   21-Mar-2003  20:43  5.0.2195.6692      20,760  Tdipx.sys
   29-Mar-2003  20:29  5.0.2195.6697      18,392  Tdnetb.sys
   21-Mar-2003  20:43  5.0.2195.6692      10,552  Tdpipe.sys
   21-Mar-2003  20:43  5.0.2195.6692      18,264  Tdspx.sys
   21-Mar-2003  20:43  5.0.2195.6692      19,032  Tdtcp.sys
   21-Mar-2003  20:43  5.0.2195.6692      35,832  Termdd.sys

Windows Server 2003

File information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Termdd.sys5.2.3790.43138,53625-Oct-200501:49x86NoneRTMQFE
Termdd.sys5.2.3790.255541,60825-Oct-200502:10x86SP1SP1QFE

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 (http://support.microsoft.com/kb/265173/) The Datacenter Program and Windows 2000 Datacenter Server product

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition
Microsoft Windows Server 2003, 64-Bit Datacenter Edition
Microsoft Windows Server 2003, Enterprise x64 Edition
Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Microsoft Windows Server 2003, Datacenter x64 Edition
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Server 2003, Standard x64 Edition
Microsoft Windows Server 2003, Web Edition

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Keywords: 
kbautohotfix kbwinserv2003sp2fix kbhotfixserver kbqfe kbfix kbbug KB811211

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