REVISIÓN: Se produce el error 1308 al intentar instalar un programa desde una ubicación de Internet

Seleccione idioma Seleccione idioma
Id. de artículo: 811364 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Al intentar instalar un programa utilizando una ubicación de origen de Internet, puede recibir el siguiente mensaje de error 1308:
No se encuentra el archivo de origen: http://theserver/theshare/c/temp/DOTLOC~1/test.~~~. Compruebe que el archivo existe y que tiene acceso a él.
Este problema se produce cuando se dan las condiciones siguientes:
  • Utiliza una línea de comandos similar a la siguiente:
    msiexec /i "http://theserver/theshare/test.msi" /l*v c:\thelog.log
    y
  • El archivo Test.msi tiene las entradas de la tabla IsolatedComponent.
Aparece un mensaje de error similar al siguiente en el registro detallado (thelog.log):

MSI (s) (E8:0C): La ruta de acceso del paquete es una dirección URL. Descargando paquete.
MSI (s) (E8:0C): Nota: 1: 1308 2: http://theserver/theshare/c/temp/DOTLOC~1/test.~~~

Causa

Este problema se produce debido a un error en el servicio de instalación Windows Installer. La instalación desde una ubicación de origen de Internet es compatible y funciona como se esperaba, sin tener en cuenta los archivos de la tabla IsolatedComponents del archivo .msi de instalación.

Solución

Información sobre el Service Pack de Windows XP

Para resolver este problema, obtenga el Service Pack más reciente para Microsoft Windows XP. Para obtener información adicional al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 Cómo obtener el Service Pack más reciente para Windows XP

Información de la revisión

Windows XP

Ahora hay disponible una revisión para la que Microsoft proporciona soporte técnico, pero sólo se diseñó para corregir el problema descrito en este artículo. Únicamente debe aplicarse a equipos que experimenten este problema específico. Se efectuarán pruebas adicionales de esta revisión. Por tanto, si no se ve muy afectado por este problema, Microsoft recomienda que espere al próximo Service Pack de Windows XP que contenga esta revisión.

Para resolver este problema inmediatamente, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
NOTA: En casos especiales, los costos derivados de las llamadas al soporte técnico pueden cancelarse si un profesional del soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Se aplicarán los costos habituales de soporte a las consultas y temas de soporte técnico adicionales que no guarden relación con la actualización en cuestión.

La versión en inglés de esta revisión contiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). Cuando vea la información de archivo, se convertirá a la hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
20-feb-200316:042.0.2600.11682.012.160Msi.dll

Información de Service Packs de Windows 2000

Para resolver este problema, obtenga el Service Pack más reciente para Microsoft Windows 2000. Para obtener información adicional al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910 Cómo obtener el Service Pack más reciente para Windows 2000

Información de la revisión

Windows 2000

Ahora hay disponible una revisión para la que Microsoft proporciona soporte técnico, pero sólo se diseñó para corregir el problema descrito en este artículo. Únicamente debe aplicarse a equipos que experimenten este problema específico. Se efectuarán pruebas adicionales de esta revisión. Por tanto, si no se ve muy afectado por el problema en cuestión, Microsoft recomienda que espere al próximo Service Pack de Windows 2000 que contenga esta revisión.

Para resolver este problema inmediatamente, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
NOTA: En casos especiales, los costos derivados de las llamadas al soporte técnico pueden cancelarse si un profesional del soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Se aplicarán los costos habituales de soporte a las consultas y temas de soporte técnico adicionales que no guarden relación con la actualización en cuestión.

La versión en inglés de esta revisión contiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). Cuando vea la información de archivo, se convertirá a la hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
03-marzo-200311:542.0.2600.11092.014.720Msi.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:. Este problema se corrigió por primera vez en el Service Pack 4 de Microsoft Windows 2000. Este problema se corrigió por primera vez en Microsoft Windows XP Service Pack 2.

Más información

El mensaje de error 1308 que aparece en la sección "Síntomas" de este artículo no se produce en Windows 2000 Service Pack 1 o Windows Service Pack 2 porque estas versiones del sistema operativo utilizan Windows Installer 1.1. Este problema es específico de Windows Installer 2.0 y se produce en Windows 2000 Service Pack 3, Windows XP y Windows XP Service Pack 1.Para obtener información adicional acerca de cómo obtener una revisión para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173 El programa Datacenter y el producto Windows 2000 Datacenter Server

Propiedades

Id. de artículo: 811364 - Última revisión: jueves, 24 de mayo de 2007 - Versión: 2.3
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Service Pack 3 de Microsoft Windows 2000
  • Service Pack 3 de Microsoft Windows 2000
Palabras clave: 
kberrmsg kbbug kbfix kbwin2000presp4fix kbqfe kbsysadmin kbsetup kbwinxpsp2fix kbdeployment kbwinxppresp2fix kbsxs kbwin2ksp4fix atdownload kbhotfixserver KB811364

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com