Zainstalowanie Internetowych usług informacyjnych może być przyczyną problemów z systemem Windows XP

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 811412 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Po zainstalowaniu w systemie Windows XP usługi FTP lub dodaniu składnika Internetowe usługi informacyjne (IIS) firmy Microsoft przed zalogowaniem się może zostać wyświetlony niebieski ekran z komunikatem o błędzie „C000021A”.

Przyczyna

Ten problem może wystąpić, jeśli nazwa komputera zawiera wyraz „system” (na przykład „MójSystem” lub „System 32”). Instalator usług IIS usuwa uprawnienia konta IUSER dotyczące krytycznych plików systemowych podczas procesu instalacji składnika usług IIS. Z powodu problemu z porównywaniem ciągów znaków instalator niepotrzebnie usuwa listę kontroli dostępu konta systemowego dotyczącą plików systemowych, w wyniku czego uruchomienie komputera jest niemożliwe.

Rozwiązanie

Informacje o dodatku Service Pack

W celu rozwiązania tego problemu należy uzyskać najnowszy dodatek Service Pack dla systemu Microsoft Windows XP. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322389 Jak uzyskać najnowszy dodatek Service Pack dla systemu Windows XP

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem. Ta poprawka może być nadal w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.

Wersja angielskojęzyczna tej poprawki ma atrybuty plików wymienione w poniższej tabeli (lub nowsze). Daty i godziny odpowiadające tym plikom zostały podane zgodnie z uniwersalnym czasem koordynowanym (UTC). Podczas wyświetlania informacji dotyczących plików są one konwertowane na czas lokalny. Aby sprawdzić różnicę między czasem UTC i czasem lokalnym, należy skorzystać z karty Strefa czasowa apletu Data i godzina w Panelu sterowania.
   Nazwa pliku
   ---------
   Iis.dll

Plik Iis.dll rozwiązuje problem aktywnie. Jeśli jednak jest wyświetlany komunikat o błędzie „C000021A” i nie można ponownie uruchomić komputera, należy zainstalować dysk w innym systemie operacyjnym używającym systemu plików NTFS, ponownie przypisać ten system operacyjny (udzielając uprawnienia Pełna kontrola do plików znajdujących się w folderze system32), a następnie uruchomić ponownie oryginalny system operacyjny Windows XP.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”. Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 2 dla systemu Microsoft Windows XP.

Obejście problemu

Aby obejść ten problem, należy zmienić nazwę komputera.

Właściwości

Numer ID artykułu: 811412 - Ostatnia weryfikacja: 31 grudnia 2008 - Weryfikacja: 5.5
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB811412

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com