Stratus ftServer-Based Computer Stops Responding (Hangs) After a Surprise Removal of OpenHCI USB Host Controller

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Article ID: 811421 - View products that this article applies to.
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SYMPTOMS

After you remove an Open Host Controller Interface (OpenHCI) Universal Serial Bus (USB) host controller on a Stratus ftServer-based computer without notifying Windows, the computer may stop responding (hang). This type of device removal is known as a surprise removal.

CAUSE

This problem occurs because of an incompatibility that exists between the Windows USB driver, Usbd.sys, and the Stratus OpenHCI driver.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version             Size   File name
   --------------------------------------------------------------
   22-Jan-2003  09:05  5.0.2195.6658      20,688  Usbd.sys

				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 811421 - Last Review: October 26, 2013 - Revision: 1.7
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kboswin2000fix kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB811421

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