Aplikace může přestat reagovat, pokud používá vzdálené volání procedur se serverem UNIX (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 811576 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Klientský program, který používá vzdálené volání procedur (RPC) a se systémem Microsoft Windows XP náhodně zaznamenat porušení přístupu při komunikaci programu s RPC serveru je spuštěna na serveru UNIX.

Příčina

Tento problém je způsoben nesprávnými vyrovnávací paměť v RPC runtime DLL (Rpcrt4.dll). Přetečení vyrovnávací paměti dojde, pouze pokud klient provede odchozí volání RPC k serveru UNIX po nečinnosti mezi 40 a 60 sekund pro klienta a volání RPC očekává velké odpověď. Přetečení vyrovnávací paměti poškodí blok paměti, která následuje vyrovnávací paměti, která používá RPC a může způsobit porušení přístupu náhodné v klientském programu.

Řešení

Informace o aktualizaci Service Pack

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Microsoft Windows XP. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389získání nejnovější aktualizace Service Pack pro systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.Anglická verze této opravy má následující atributy souborů (nebo novější). Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   23-Dec-2002  09:31  5.1.2600.1154  505,856  Rpcrt4.dll

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt. Tento problém byl poprvé opraven aktualizací Microsoft Windows XP Service Pack 2.

Další informace

Některé servery RPC může požadovat klientský program ukončit jeho nečinnosti připojení snížení využití prostředků. To provést odesláním datové jednotky protokolu (PDU) vypnutí klienta. U klienta zkontroluje RPC jeho vyrovnávací paměti pro příjem pouze při je vytváření odchozí volání na server RPC. Některé servery UNIX odeslat vypnutí jednotek PDU, které po každých 20 sekund doby nečinnosti. Pokud je klient nečinnosti dostatečně dlouhý pro server odeslat 2 jednotek PDU, které po sobě jdoucí vypnutí, RPC klienta coalesces jednotek PDU, které v jeho vyrovnávací paměti pro příjem. Pokud klient se rozhodne odchozí volání v tomto okamžiku, pokusí se nejprve zpracovat jednotek PDU, dva coalesced které jeho vyrovnávací paměti pro příjem. Během zpracování, způsobí coalescing vyrovnávací paměti příjem být reallocated. Informace o velikosti vyrovnávací paměti není však sledována správně. Výsledkem může být vyrovnávací paměti, který je hlášen být větší, než skutečně je. Potom je provedeno odchozí volání. Pokud odpověď je větší než (není oznámenou) reálné velikost vyrovnávací paměti reallocated příjem narušení přístupu dochází.

Pokud je klient nečinnosti dostatečně dlouhý pro server odeslat tři jednotek PDU, které vypnutí, zavře připojení RPC. Nové připojení je potom vytvořen spustit odchozí volání. V tomto případě problém nenastane. Problém je tedy pravděpodobné nastat po nečinnosti klientský program pro více než 40 sekund, ale menší než 60 sekund. Však to závisí na jak dlouho UNIX server čeká před odesláním vypnutí PDU.

Vlastnosti

ID článku: 811576 - Poslední aktualizace: 29. srpna 2007 - Revize: 3.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbenv kberrmsg kbqfe kbwinxppresp2fix kbfix kbbug KB811576 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:811576

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com