STOP 0 x 00000050 en el mensaje de Error en Atmfd.dll cuando utiliza fuentes Type 1

Seleccione idioma Seleccione idioma
Id. de artículo: 811769 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Durante la representación de un documento de Adobe PDF, es posible recibir el siguiente mensaje de error en Atmfd.dll:
0 x 00000050 (0xf0009ed5, 0 x 00000000, 0xbee02ab3, 0 x 00000002)
PAGE_FAULT_IN_NO_PAGED_AREA

Causa

Este comportamiento se produce porque cuando se devuelve un puntero nulo Utilice una fuente Type 1 de Adobe que contiene una estructura de datos que no es válida. Devuelve un puntero nulo puede ser con fuentes válidas, pero en estos casos el equipo es bajo una carga elevada. Las condiciones de carga elevada provoca un problema de sincronización entre la memoria caché de transferencia asíncrono (ATM) de modo fuente y el subproceso actual que se encuentra intentando obtener acceso a una fuente que se ha quitado de la memoria caché.

Después de instalar la actualización, el Administrador de fuentes de Adobe no se puede cargar una fuente que sea dañado o tiene una estructura de datos que no es válida. Cuando se utiliza el integrado Administrador de fuentes para obtener una vista previa de una fuente que usted piensa que puede estar dañado, puede que reciba el siguiente mensaje de error al intentar obtener una vista previa de la fuente:
Error: El c:\winnt\Fonts\ archivo solicitadoFuente Nombre. PFM|c:\winnt\Fonts\Nombre de la fuente. PFB no era un archivo de fuente válido.

Solución

Información del Service Pack

Para resolver este problema, obtenga el service pack más reciente para Microsoft Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910 Cómo obtener el Service Pack más reciente de Windows 2000

Información de la revisión

Hay un hotfix soportado por Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplicar esta revisión sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de la revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, enviar una solicitud de servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de números de teléfono de servicio al cliente de Microsoft y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma. La versión inglesa de Esta revisión tiene los atributos de archivo (o posterior) que figuran en el siguiente tabla. Las fechas y horas de estos archivos se muestran en universal coordinada hora (UTC). Cuando vea la información de archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora en el Panel de Control.
      Date         Time     Version        Size        File name
   ------------------------------------------------------------
   29-Mar-2003  17:26       5.0.2.225    291,888   Atmfd.dll
29-Mar-2003  17:26       5.0.2.225     31,504   Atmlib.dll
29-Mar-2003  17:26   5.0.2195.6688     42,256   Basesrv.dll
14-Feb-2003  18:49   5.0.2195.6660    222,992   Gdi32.dll
29-Mar-2003  17:26   5.0.2195.6688    710,928   Kernel32.dll
04-Feb-2003  18:15   5.0.2195.6661     29,264   Mountmgr.sys
29-Mar-2003  17:26   5.0.2195.6669    333,072   Msgina.dll
29-Mar-2003  17:26   5.0.2195.6685    476,944   Ntdll.dll
28-Mar-2003  17:19   5.0.2195.6696  1,694,912   Ntkrnlmp.exe
28-Mar-2003  17:19   5.0.2195.6696  1,693,952   Ntkrnlpa.exe
28-Mar-2003  17:19   5.0.2195.6696  1,714,944   Ntkrpamp.exe
28-Mar-2003  17:19   5.0.2195.6696  1,672,448   Ntoskrnl.exe
21-Mar-2003  19:43   5.0.2195.6692     90,232   Rdpwd.sys
29-Mar-2003  17:26   5.0.2195.6688    380,176   User32.dll
29-Mar-2003  17:26   5.0.2195.6685    385,296   Userenv.dll
28-Mar-2003  17:17   5.0.2195.6696  1,628,688   Win32k.sys
11-Mar-2003  13:15   5.0.2195.6682    181,008   Winlogon.exe
14-Feb-2003  18:49   5.0.2195.6655    243,472   Winsrv.dll
29-Mar-2003  17:26   5.0.2195.6688    710,928   Uniproc\Kernel32.dll
29-Mar-2003  17:26   5.0.2195.6685    476,944   Uniproc\Ntdll.dll
29-Mar-2003  17:26   5.0.2195.6696  1,628,688   Uniproc\Win32k.sys
14-Feb-2003  18:49   5.0.2195.6655    243,472   Uniproc\Winsrv.dll
21-Mar-2003  19:43   5.0.2195.6692     90,200   56bit\Rdpwd.sys
				

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran al principio de este artículo. Este problema se corrigió por primera vez en Microsoft Windows 2000 Service Pack 4.

Más información

Esta revisión restringe algunas fuentes Adobe tipo 1 con una estructura de datos incorrectos. Sin embargo, todavía puede experimentar el problema al utilizar fuentes Adobe tipo 1 después de aplicar esta revisión o después de instalar Windows 2000 Service Pack 4. Si el problema persiste, póngase en contacto con Adobe para actualizar estas fuentes Type 1.

Los productos de otros fabricantes que analiza este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.

Referencias

Para obtener información adicional acerca de cómo Para obtener una revisión para Windows 2000 Datacenter Server, haga clic en el número de artículo a continuación para verlo en Microsoft Knowledge Base:
265173 El programa de centros de datos y el producto de Windows 2000 Datacenter Server
Para obtener información adicional acerca de cómo instalar múltiples revisiones con sólo un reinicio, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
296861 Utilizar QChain.exe para instalar varias revisiones con un reinicio

Propiedades

Id. de artículo: 811769 - Última revisión: sábado, 08 de junio de 2013 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palabras clave: 
kbautohotfix kbhotfixserver kbqfe kbshell kbwin2ksp4fix kbwin2000sp3fix kbwin2000presp4fix kbwin2000presp3fix kbfix kbbug kbmt KB811769 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 811769

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com