STOP 0 x 00000050 nel messaggio di errore in Atmfd.dll quando si utilizzano caratteri Type 1

Traduzione articoli Traduzione articoli
Identificativo articolo: 811769 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Durante il rendering di un documento PDF di Adobe, si potrebbe essere visualizzato il seguente messaggio di errore in Atmfd.dll:
0 x 00000050 (0xf0009ed5, 0 x 00000000, 0xbee02ab3, 0 x 00000002)
PAGE_FAULT_IN_NO_PAGED_AREA

Cause

Ciò avviene perché venga restituito un puntatore null quando si utilizza un Adobe Type 1 tipo di carattere che contiene una struttura dati che non è valida. Un puntatore null può essere restituito con tipi di carattere validi, ma in questi casi il computer è intenso. Il carico elevato comporta un problema di sincronizzazione tra la cache di tipo di carattere asynchronous transfer mode (ATM) e il thread corrente sta tentando di accedere a un tipo di carattere che è stato rimosso dalla cache.

Dopo aver installato l'aggiornamento il, è possibile che Gestione tipi di carattere Adobe non può essere caricata un tipo di carattere è danneggiato o ha una struttura dati che non è valida. Quando si utilizza il gestore del tipo di carattere incorporato per l'anteprima di un tipo di carattere che ritieni potrebbero essere danneggiati, viene potrebbe essere visualizzato il seguente messaggio di errore quando si tenta di visualizzare in anteprima il tipo di carattere:
Errore: Il file richiesto c:\winnt\Fonts\ Font Name. PFM|c:\winnt\Fonts\ di Font Name. PFB non è un file di carattere valida.

Risoluzione

Informazioni sul Service Pack

Per risolvere il problema, ottenere il service pack più recente per Microsoft Windows 2000. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
260910Come ottenere Windows 2000 Service Pack più recente

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o successivi). Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
      Date         Time     Version        Size        File name
   ------------------------------------------------------------
   29-Mar-2003  17:26       5.0.2.225    291,888   Atmfd.dll
29-Mar-2003  17:26       5.0.2.225     31,504   Atmlib.dll
29-Mar-2003  17:26   5.0.2195.6688     42,256   Basesrv.dll
14-Feb-2003  18:49   5.0.2195.6660    222,992   Gdi32.dll
29-Mar-2003  17:26   5.0.2195.6688    710,928   Kernel32.dll
04-Feb-2003  18:15   5.0.2195.6661     29,264   Mountmgr.sys
29-Mar-2003  17:26   5.0.2195.6669    333,072   Msgina.dll
29-Mar-2003  17:26   5.0.2195.6685    476,944   Ntdll.dll
28-Mar-2003  17:19   5.0.2195.6696  1,694,912   Ntkrnlmp.exe
28-Mar-2003  17:19   5.0.2195.6696  1,693,952   Ntkrnlpa.exe
28-Mar-2003  17:19   5.0.2195.6696  1,714,944   Ntkrpamp.exe
28-Mar-2003  17:19   5.0.2195.6696  1,672,448   Ntoskrnl.exe
21-Mar-2003  19:43   5.0.2195.6692     90,232   Rdpwd.sys
29-Mar-2003  17:26   5.0.2195.6688    380,176   User32.dll
29-Mar-2003  17:26   5.0.2195.6685    385,296   Userenv.dll
28-Mar-2003  17:17   5.0.2195.6696  1,628,688   Win32k.sys
11-Mar-2003  13:15   5.0.2195.6682    181,008   Winlogon.exe
14-Feb-2003  18:49   5.0.2195.6655    243,472   Winsrv.dll
29-Mar-2003  17:26   5.0.2195.6688    710,928   Uniproc\Kernel32.dll
29-Mar-2003  17:26   5.0.2195.6685    476,944   Uniproc\Ntdll.dll
29-Mar-2003  17:26   5.0.2195.6696  1,628,688   Uniproc\Win32k.sys
14-Feb-2003  18:49   5.0.2195.6655    243,472   Uniproc\Winsrv.dll
21-Mar-2003  19:43   5.0.2195.6692     90,200   56bit\Rdpwd.sys
				

Status

Microsoft ha confermato che questo problema riguarda i prodotti Microsoft elencati all'inizio di questo articolo. Questo problema è stato innanzitutto corretto in Microsoft Windows 2000 Service Pack 4.

Informazioni

Questo aggiornamento rapido (hotfix) consente di limitare alcuni tipi di carattere Adobe Type 1 con una struttura di dati non corretti. Tuttavia, potrebbe verificarsi ancora il problema quando si utilizzano i tipi di carattere Adobe Type 1 dopo avere applicato questo aggiornamento rapido (hotfix) o dopo aver installato Windows 2000 Service Pack 4. Se il problema persiste, contattare Adobe per aggiornare questi tipi di carattere Type 1.

I prodotti di terze parti che in questo articolo viene descritto sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia, implicita o di altra natura, relativa alle prestazioni o all'affidabilità di questi prodotti.

Riferimenti

Per ulteriori informazioni su come ottenere la correzione rapida per Windows 2000 Datacenter Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
265173Il programma Datacenter e il prodotto di Windows 2000 Datacenter Server
Per ulteriori informazioni su come installare più aggiornamenti rapidi con un solo riavvio, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
296861Utilizzare QChain.exe per installare numerose correzioni rapide con un solo riavvio

Proprietà

Identificativo articolo: 811769 - Ultima modifica: venerdì 27 ottobre 2006 - Revisione: 2.5
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Chiavi: 
kbmt kbautohotfix kbhotfixserver kbqfe kbshell kbwin2ksp4fix kbwin2000sp3fix kbwin2000presp4fix kbwin2000presp3fix kbfix kbbug KB811769 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 811769
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com