Type 1 フォントを使用すると Atmfd.dll で STOP 0x00000050 エラーが発生する

文書翻訳 文書翻訳
文書番号: 811769 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Adobe PDF ドキュメントの表示中に、Atmfd.dll で次のエラー メッセージが表示されることがあります。
0x00000050 (0xf0009ed5, 0x00000000, 0xbee02ab3, 0x00000002)
PAGE_FAULT_IN_NO_PAGED_AREA

原因

この現象は、無効なデータ構造体が含まれている Adobe Type 1 フォントを使用した場合に NULL ポインタが返されるために発生します。コンピュータの負荷が高い場合に、有効なフォントでも NULL ポインタが返されることがあります。高い負荷が原因で、非同期転送モード (ATM) フォント キャッシュとキャッシュから削除済みのフォントにアクセスしようとしている現在のスレッドとの間で、同期の問題が発生します。

この修正プログラムをインストールすると、Adobe Font Manager は破損しているか無効なデータ構造体が含まれているフォントを読み込まなくなります。組み込みのフォント マネージャを使用して破損している可能性のあるフォントをプレビュー表示すると、次のエラー メッセージが表示されることがあります。
エラー : 指定されたファイル c:\winnt\Fonts\Font Name. PFM|c:\winnt\Fonts\Font Name. PFB は有効なフォント ファイルではありませんでした。

解決方法

Service Pack の情報

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows 2000 Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。


   日付           時刻    バージョン         サイズ     ファイル名
   ------------------------------------------------------------------
   2003/03/29  11:26  5.0.2.225        291,888  atmfd.dll       
   2003/03/30  09:25  5.0.2.225         31,504  atmlib.dll      
   2003/03/30  09:25  5.0.2195.6688     42,256  basesrv.dll     
   2003/02/14  12:49  5.0.2195.6660    222,992  gdi32.dll       
   2003/03/30  09:25  5.0.2195.6688    904,976  kernel32.dll    
   2003/02/04  12:15  5.0.2195.6661     29,264  mountmgr.sys    
   2003/03/30  09:25  5.0.2195.6669    333,072  msgina.dll      
   2003/03/30  09:25  5.0.2195.6685    476,944  ntdll.dll       
   2003/03/30  09:25  5.0.2195.6696  1,694,912  ntkrnlmp.exe    
   2003/03/30  09:25  5.0.2195.6696  1,693,952  ntkrnlpa.exe    
   2003/03/30  09:25  5.0.2195.6696  1,714,944  ntkrpamp.exe    
   2003/03/30  09:25  5.0.2195.6696  1,672,448  ntoskrnl.exe    
   2003/03/30  09:25  5.0.2195.6692     90,232  rdpwd.sys       
   2003/03/30  09:25  5.0.2195.6688    380,176  user32.dll      
   2003/03/30  09:25  5.0.2195.6685    385,296  userenv.dll     
   2003/03/30  09:25  5.0.2195.6696  1,628,688  win32k.sys      
   2003/03/30  09:25  5.0.2195.6682    181,008  winlogon.exe    
   2003/03/30  09:25  5.0.2195.6655    258,832  winsrv.dll      
   2003/03/30  09:25  5.0.2195.6688    904,976  Uniproc\kernel32.dll    
   2003/03/30  09:25  5.0.2195.6685    476,944  Uniproc\ntdll.dll       
   2003/03/30  09:25  5.0.2195.6696  1,628,688  Uniproc\win32k.sys      
   2003/03/30  09:25  5.0.2195.6655    258,832  Uniproc\winsrv.dll      
   2003/03/21  13:43  5.0.2195.6692     90,200  56bit\rdpwd.sys       


状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Microsoft Windows 2000 Service Pack 4 で最初に修正されました。

詳細

この修正プログラムによって、データ構造の正しくない一部の Adobe Type 1 フォントが制限されます。しかし、この修正プログラムの適用後、または Windows 2000 Service Pack 4 のインストール後に Adobe Type 1 フォントを使用すると、依然として問題が発生することがあります。引き続き問題が発生する場合は、Adobe に問い合わせて、それらの Type 1 フォントを更新してください。

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

関連情報

Windows 2000 Datacenter Server 用の修正プログラムを入手する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Datacenter Program と Windows 2000 Datacenter Server
複数の修正プログラムのインストールを 1 回の再起動のみで行う方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296861 複数の Windows 更新プログラムまたは修正プログラムを同時にインストールし、再起動を 1 回で済ませる方法

プロパティ

文書番号: 811769 - 最終更新日: 2006年5月15日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
キーワード:?
kbhotfixserver kbqfe kbshell kbwin2ksp4fix kbwin2000sp3fix kbwin2000presp4fix kbwin2000presp3fix kbfix kbbug KB811769
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com