Resolve Bluetooth mouse or keyboard failure to function

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Article ID: 811798 - View products that this article applies to.
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SYMPTOMS

When you try to use one of the Microsoft pointing devices or keyboards that are listed in the "Applies to" section, the device may not function at all. Or, the device may not be detected by Microsoft Windows.

CAUSE

This issue may occur because of any of the following reasons:
  • If your computer’s BIOS does not recognize Bluetooth keyboards, you receive an error that resembles the following when you start your computer:
    Keyboard Error or No Keyboard Present Press F1 to continue, DEL to enter setup
  • The Bluetooth receiver in the portable computer is incompatible with the Microsoft Bluetooth stack.
  • The device signal is not detected by the signal transceiver.
  • There is insufficient power to the device or to the receiver.
  • There is a radio frequency conflict.
  • You are running Windows XP, but you have not updated to Service Pack 2 (SP2) or a later service pack.
  • You have defective hardware.

RESOLUTION

If you receive the Keyboard error that is mentioned in the "Cause" section when you start your computer, see the steps in the "Workaround" section in this article.

To resolve this issue, use one of the following methods.

Method 1: Resolve the incompatible Bluetooth stack

To resolve this behavior, contact the manufacturer of the portable computer to see whether their transceiver works with the Microsoft Bluetooth stack. Additionally, ask the manufacturer how to add devices by using the Microsoft Bluetooth stack. If the Microsoft device included its own transceiver, you may have to use the Microsoft transceiver to resolve this behavior.

If the portable computer that you are using is running Windows XP with Service Pack 2 (SP2) or a newer version of Windows, Windows will detect the transceiver before it will install the Microsoft Bluetooth stack. This process helps prevent unauthorized access to your computer through a Bluetooth connection. Windows will also initiate this process to use the Microsoft Bluetooth stack after a third-party stack is removed.

Method 2: Verify power levels

To make sure that there is sufficient power for the Bluetooth device, disconnect any unnecessary USB devices, and then test the device when there are no other USB devices connected. Make sure that the device is plugged into the root hub or to a powered USB hub (But not to a "bus-powered" USB hub. This kind of hub is actually not powered).

Method 3: Install the latest updates (service packs) for your operating system

Verify that you have the latest updates installed for your operating system. For Windows, visit the following Microsoft Web site:
http://update.microsoft.com
If you are running Windows XP, reference the following Microsoft Knowledge Base article:
883258 How to troubleshoot Bluetooth detection and connectivity problems in Windows XP Service Pack 2

Method 4: Locate the Wireless Link icon in Control Panel, and then reestablish the link with the wireless device


Windows Vista or Windows 7
  1. Click Start
    Collapse this imageExpand this image
    the Start button
    , click Hardware and Sound, and then click Bluetooth Devices.
  2. If your device does appear in the list of devices, click Add, and then follow the instructions to add the device.

    If the device does appear in the list of devices, check the status. The following possible states exist:
    • Authenticated
    • Connected
    • Last Seen

      If the device state is listed as Last Seen, try to use the device.

      If the status flickers between Authenticated and Connected, communication exists between the device and the computer. You can also try to Remove the device and Add it back in.
  3. Click Properties, and then click Services.
  4. Click to select the Drivers for Device check box.
  5. If the device has a check box next to it that is selected, click to clear it.

    Note If you use the wireless link to add the device, the device is not set as the default device.
  6. Click OK.
  7. Click Properties, and then click Services.
  8. Click to select the Drivers for Device check box.
  9. Click to select the check box on the wireless link properties.
  10. If the link is not reestablished, use Control Panel to remove the device, and then try to add the device again.

    To troubleshoot problems with Bluetooth-enabled devices in Windows Vista, follow the instructions in the "Troubleshoot problems with Bluetooth-enabled devices" topic in Windows Vista Help and Support. To view the topic, follow these steps:
    1. Click Start
      Collapse this imageExpand this image
      Start button
      , and then click Help and Support.
    2. In the Search Help box, type Troubleshoot problems with Bluetooth-enabled devices, and then click Search Help.
    3. Click the appropriate topic.
Windows XP
  1. Click Start, and then click Control Panel.
  2. Click Printers and Other Hardware.
  3. Click Wireless Link.

    Note If there is no picture of a Bluetooth device on the first tab, the software is installed incorrectly. Remove the software, and then continue with this procedure.
  4. Click the Bluetooth tab.
  5. If the device does not appear in the list of devices, click Add, and then follow the instructions to add the device.
  6. If the device does appear in the list of devices, check the status. The following possible states exist:
    • Authenticated
    • Connected
    • Last Seen

      If the device state is listed as Last Seen, try to use the device.

      If the status flickers between Authenticated and Connected, communication exists between the device and the computer. You can also try to Remove the device and Add it back in.
  7. Click to select the Drivers for Device check box.
  8. If the device has a check box next to it that is selected, click to clear it.

    Note If you use the wireless link to add the device, the device is not set as the default device.
  9. Click OK.
  10. Click Properties, and then click Services. Click to select the Drivers for Device check box.
  11. Click to select the check box on the wireless link properties.
  12. If the link is not reestablished, use Control Panel to remove the device, and then try to add the device again.

Method 5: Make sure that the device is not being interrupted by something in the area on the same frequency

Determine whether the following items are in your environment:
  • Cordless telephones that use the 2.4 gigahertz (GHz) range
  • Microwave ovens
  • X10 devices, such as controllers for lights or universal remotes
  • Wireless fidelity (Wi-Fi) networks

Method 6: Test the device on another computer

If the earlier methods fail, try to use the devices on another computer. The hardware may be defective. If the issue still persists, and if the devices work on another computer, there may be a problem with the operating system. If the device does not work on any system, contact Microsoft to see about replacing the device. For information about how to do this, see the "How to contact Microsoft Supplemental Parts" section in the "References" section.

WORKAROUND

To work around this problem if you receive the "Keyboard Error or No Keyboard Present" error that is mentioned in the "Cause" section when you start your computer, disable the Halt on error function in the BIOS. To determine how to access the BIOS and disable this function, see the manual that was supplied with your computer, or contact the computer manufacturer.

If you disable the Halt on error function in the BIOS, you still receive the error message. However, the computer continues to start. After Microsoft Windows has started, the Bluetooth devices work as expected.

If you cannot disable the Halt on error function, you can attach a PS/2 keyboard to the computer to avoid receiving this error message.

For information about how to contact your hardware manufacturer, view the following hardware and software third-party vendor contact information. To do this, visit the following Microsoft Web site:
http://support.microsoft.com/gp/vendors/en-us

REFERENCES

To learn more about how to set up a Bluetooth-enabled device in Windows Vista or Windows 7, follow the instructions in the "Set up a Bluetooth-enabled device" topic in Windows Help and Support. To view the topic, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , and then click Help and Support.
  2. In the Search Help box, type Set up a Bluetooth-enabled device, and then click Search Help.
  3. Click the appropriate topic.

How to contact Microsoft Supplemental Parts

In the United States and in Canada, you can contact the Microsoft Supplemental Parts team at the following telephone numbers:
  • United States: (800) 360-7561, Monday through Friday, 5:00 A.M. to 7:00 P.M. Pacific Time
  • Canada: (800) 933-4750, Monday through Friday, 5:00 A.M. to 7:00 P.M. Pacific Time
  • TTY customers: (800) 718-1599, Monday through Friday, 5:00 A.M. to 7:00 P.M. Pacific Time
For more information about how to replace or upgrade Microsoft software, hardware, and manuals, click the following article number to view the article in the Microsoft Knowledge Base:
326246 How to replace Microsoft software or hardware, order service packs and product upgrades, and replace product manuals
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 811798 - Last Review: September 29, 2011 - Revision: 16.0
APPLIES TO
  • Microsoft Optical Desktop Elite for Bluetooth
  • Microsoft Wireless IntelliMouse Explorer for Bluetooth
  • Microsoft Wireless Optical Desktop for Bluetooth
  • Microsoft Bluetooth Notebook Mouse 5000
  • Microsoft Wireless Notebook Presenter Mouse 8000
  • Microsoft Wireless Entertainment Desktop 7000
  • Microsoft Wireless Entertainment Desktop 8000
Keywords: 
dftsdahomeportal kbprb KB811798

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