複数の ATA ドライブを搭載したコンピュータが S1 電源状態に入る際の問題

文書翻訳 文書翻訳
文書番号: 812415 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

複数の ATA ドライブを搭載した Windows 2000 ベースまたは Windows XP ベース コンピュータが S1 電源状態に入る場合、以下の現象のいずれかが発生することがあります。
  • コンピュータをスリープまたはスタンバイから再開する際、Windows が ATA ドライブを認識しません。
  • 次のエラー メッセージが表示されることがあります。
    デバイスの取り外しの警告

    デバイスを停止させないで取り外しました。デバイスを停止させないまま取り外すと、コンピュータがクラッシュして貴重なデータが失われることがあります。
  • コンピュータが応答を停止 (ハング) します。

原因

この問題が発生する原因の一部は、IDE 記憶装置のドライバ スタックがソフトウェア リセットに必要なレジスタに誤ったアクセスをすることです。これにより、ホスト コントローラまたはデバイスがハング状態になります。この問題は、レガシ モードで動作するように構成された ATA ホスト コントローラを使用しているコンピュータには、影響しません。この問題は、Intel ICH5 ベース チップ セットで確認されていますが、このハードウェアに限定されるわけではありません。

解決方法

Windows XP

Service Pack の情報

この問題を解決するには、Microsoft Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法

修正プログラムの情報

下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。
Windows XP
元に戻す画像を拡大する
ダウンロード
812415 パッケージ
Windows XP 64-Bit Edition
元に戻す画像を拡大する
ダウンロード
812415 パッケージ
リリース日 : 2003 年 5 月 9 日

マイクロソフトのサポート ファイルのダウンロード方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。 修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻     バージョン      サイズ    ファイル名
   ------------------------------------------------------
   31-JAN-2003  15:43  5.1.2600.1164  87,040  Atapi.sys
   31-JAN-2003  15:43  5.1.2600.1164  23,680  Pciidex.sys
   14-NOV-2002  10:01  5.3.10.0        4,608  Spmsg.dll

Windows 2000

Service Pack の情報

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムの情報

下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。
すべての言語 (NEC PC-9800 シリーズを除く)
元に戻す画像を拡大する
ダウンロード
812415 パッケージ
NEC PC-9800 シリーズ
元に戻す画像を拡大する
ダウンロード
812415 パッケージ
リリース日 : 2003 年 5 月 9 日

マイクロソフトのサポート ファイルのダウンロード方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。 修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻     バージョン      サイズ    ファイル名
   ------------------------------------------------------
   25-FEB-2003  10:30  5.0.2195.6672  86,704  Atapi.sys
   25-FEB-2003  10:31  5.0.2195.6672  22,064  Pciidex.sys
   12-FEB-2003  15:43  5.3.16.3        6,656  Spmsg.dll

詳細

Windows の ATA および ATAPI ドライバでこれらの現象が発生し、ネイティブ IDE モードで動作するすべてのドライバ コントローラ チップ セットにも影響する場合があります。

ネイティブ モードの ATA コントローラは一般的ではなく、通常、複数の ATA コントローラを搭載した新しいシステムでのみ使用されます。たとえば、それらはパラレル ATA およびシリアル ATA (SATA) コントローラの組み合わせで使用されることがあります。

コンピュータが ATA ネイティブ モードで動作しているかどうかを確認するには、次の手順を実行します。
  1. [マイ コンピュータ] を右クリックし、[プロパティ] をクリックします。
  2. [ハードウェア] タブをクリックし、[デバイス マネージャ] をクリックします。
  3. [表示] メニューの [リソース (種類別)] をクリックします。
  4. [割り込み要求 (IRQ)] を展開します。
[デバイス マネージャ] で、IRQ 14 がプライマリ IDE チャネルに割り当てられ、IRQ 15 がセカンダリ IDE チャネルに割り当てられている場合、そのコンピュータは互換モードです。

IRQ (14、15) のどちらかだけが IDE チャネルに割り当てられていて、コンピュータの BIOS で両方のチャネルが有効になっている場合、そのコンピュータはネイティブ モードです。

ネイティブ モードの ATA コントローラを搭載した多くのコンピュータでは、BIOS にネイティブ モードを有効または無効にする設定もあります。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Microsoft Windows XP Service Pack 2 で最初に修正されました。 この問題は、Microsoft Windows 2000 Service Pack 4 で最初に修正されました。

プロパティ

文書番号: 812415 - 最終更新日: 2007年12月1日 - リビジョン: 3.4
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Professional
  • Microsoft Windows XP Professional x64 Edition
キーワード:?
kbbug kbfix kbwin2000presp4fix kbqfe kbenv kbprb kbdriver kbwinxpsp2fix kbwinxppresp2fix kbwin2ksp4fix atdownload kbhotfixserver KB812415
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com