ID d'événement 7000 et message d'erreur « %1 n'est pas une application Win32 valide » lors du démarrage d'un service

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Symptômes

Un ou plusieurs des services installés sur votre ordinateur ne démarre pas et l'un des problèmes suivants se produit :
  • Le message d'erreur suivant s'affiche :
    Erreur 193 : %1 n'est pas une application Win32 valide.
    - et -
  • L'événement suivant est consigné dans le journal des événements système pour chaque service qui ne démarre pas :

    ID de l'événement : 7000
    Source : Gestionnaire de contrôle des services
    Type : Erreur
    Description :
    Le service nom_service n'a pas pu démarrer à cause de l'erreur suivante : %1 n'est pas une application Win32 valide.

Cause

Ce problème peut se produire si le chemin d'accès du fichier exécutable d'un service contient des espaces.

Lorsque Windows démarre un service, il analyse le chemin d'accès du service de gauche à droite. Si les deux conditions suivantes sont remplies, il peut arriver que Windows localise et essaie d'exécuter le fichier ou le dossier avant de localiser et d'exécuter le fichier exécutable du service :
  • Le chemin d'accès du fichier exécutable d'un service contient des espaces.
  • Il existe sur le disque dur de votre ordinateur un fichier ou un dossier qui porte le même nom qu'un fichier ou un dossier du chemin d'accès au fichier exécutable du service.
Par exemple, si le chemin d'accès du fichier exécutable d'un service est C:\Program Files\MyProgram\MyService.exe, et si un dossier nommé C:\Program existe également sur votre disque dur, Windows localise le dossier C:\Program sur votre disque dur avant le fichier C:\Program Files\MyProgram\My Service.exe, puis essaie de l'exécuter.

Résolution

Important Cette section, méthode ou tâche explique la procédure de modification du Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows


Pour résoudre ce problème, ajoutez des guillemets autour de la valeur suivante dans le Registre Windows, où <ServiceName< est le nom du service :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>\ImagePath
La valeur ImagePath contient le chemin d'accès au fichier exécutable du service. Pour ajouter des guillemets autour de la valeur ImagePath du service, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  3. Rechercez l'entrée du Registre suivante, puis cliquez dessus, où <ServiceName> représente le nom du service :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>
    .
    Par exemple, si le service se nomme MyService, recherchez la clé
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MyService
    .
  4. Dans le volet droit, double-cliquez sur
    ImagePath
    .
  5. Dans la zone Données de la valeur, ajoutez des guillemets autour du chemin d'accès complet au fichier exécutable du service.

    Par exemple, si le chemin d'accès du service MyService est C:\Program Files\MyProgram\MyService.exe, remplacez l'entrée de la zone Données de la valeur pour le service MyService par les éléments suivants :
    « C:\Program Files\MyProgram\MyService.exe »
  6. Cliquez sur OK, puis quittez l'Éditeur du Registre.
Remarque Il s'agit d'un article de « PUBLICATION RAPIDE » rédigé directement au sein du service de support technique Microsoft. Les informations qui y sont contenues sont fournies en l'état, en réponse à des problèmes émergents. En raison du délai rapide de mise à disposition, les informations peuvent contenir des erreurs typographiques et, à tout moment et sans préavis, faire l'objet de révisions. Pour d'autres considérations, consultez les Conditions d'utilisation.

Propriétés

Numéro d'article: 812486 - Dernière mise à jour: mercredi 8 janvier 2014 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionnel
Mots-clés : 
kbprb KB812486
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