ID evento 7000 e messaggio di errore "%1 non è un'applicazione di Win32 valida" all'avvio di un servizio

Traduzione articoli Traduzione articoli
Identificativo articolo: 812486 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Uno o più servizi installati nel computer non si avviano e si verifica uno dei problemi seguenti:
  • Viene visualizzato il messaggio di errore seguente:
    Errore 193: %1 non è un'applicazione di Win32 valida.
    e
  • Nel registro eventi di sistema viene registrato il seguente evento per ciascun servizio che non si avvia:

    ID evento: 7000
    Origine: Gestione controllo servizi
    Tipo: Errore
    Descrizione:
    Il servizio NomeServizio non è stato avviato per il seguente errore: %1 non è un'applicazione di Win32 valida.

Cause

Questo problema può verificarsi se il percorso del file eseguibile del servizio contiene spazi.

Quando in Windows viene avviato un servizio, ne viene analizzato il percorso da sinistra a destra. Se entrambe le condizioni elencate di seguito sono presenti, Windows può trovare e tentare di eseguire il file o la cartella prima che venga individuato ed eseguito il file eseguibile del servizio:
  • Il percorso del file eseguibile del servizio contiene spazi.
  • Nel disco rigido del computer è presente un file o una cartella con lo stesso nome di un file o di una cartella del percorso del file eseguibile del servizio.
Se ad esempio il percorso del file eseguibile di un servizio è C:\Programmi\Programma\Servizio.exe e nel disco rigido esiste una cartella denominata C:\Programma, quest'ultima viene individuata prima del file C:\Programmi\Programma\Servizio.exe, per cui Windows tenta di eseguirla.

Risoluzione

Importante In questa sezione, metodo o attività viene illustrato come modificare il Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per maggiore sicurezza, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo è possibile effettuare il ripristino in caso di problemi. Per ulteriori informazioni su come eseguire il backup del Registro di sistema e su come ripristinarlo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows


Per risolvere questo problema, racchiudere tra virgolette la seguente voce nel Registro di sistema di Windows, dove <ServiceName> sta per il nome del servizio:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>\ImagePath
La voce dell'ImagePath contiene il percorso del file eseguibile del servizio. Per racchiudere tra virgolette la voce dell'ImagePath relativa a un servizio:
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella casella Apri digitare regedit, quindi scegliere OK.
  3. Individuare e fare clic sulla seguente voce del Registro di sistema, dove <ServiceName> sta per il nome del servizio:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>
    .
    Se ad esempio il servizio si chiama MyService, individuare la chiave
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MyService
    .
  4. Nel riquadro destro fare doppio clic su
    ImagePath
    .
  5. Nella casella Dati valore racchiudere tra virgolette l'intero percorso del file eseguibile del servizio.

    Se ad esempio il percorso del servizio Servizio è C:\Programmi\Programma\Servizio.exe, cambiare la voce della casella Dati valore del servizio nel modo seguente
    "C:\Program Files\MyProgram\MyService.exe"
  6. Scegliere OK e chiudere l'editor del Registro di sistema.
Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo.

Proprietà

Identificativo articolo: 812486 - Ultima modifica: martedì 2 luglio 2013 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Chiavi: 
kbprb KB812486
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com