Identificação do evento 7000 e mensagem de erro "%1 não é um aplicativo Win32 válido" ao iniciar um serviço

Traduções deste artigo Traduções deste artigo
ID do artigo: 812486 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Pelo menos um dos serviços instalados no computador não inicia e ocorre um dos seguintes problemas:
  • A seguinte mensagem de erro é exibida:
    Erro 193: %1 não é um aplicativo Win32 válido.
    -e-
  • Se o seguinte evento estiver conectado ao log de eventos do Sistema para cada serviço que não pode ser iniciado.

    Identificação do evento: 7000
    Origem: Gerenciador de Controle de Serviços
    Tipo: Erro
    Descrição:
    O serviço ServiceName falhou ao iniciar devido ao seguinte erro: %1 não é um aplicativo Win32 válido.

Causa

Este problema pode ocorrer se o caminho do arquivo executável para o serviço tiver espaços.

Ao iniciar um serviço, o Windows analisa o caminho do serviço da esquerda para direita. Se as seguintes condições forem verdadeiras, o Windows pode localizar e executar o arquivo ou pasta antes de localizar o arquivo executável para o serviço:
  • O caminho de um arquivo executável do serviço contém espaços.
  • Há um arquivo ou pasta no disco rígido do computador com o mesmo nome de um arquivo ou pasta no caminho para o arquivo executável do serviço.
Por exemplo, se o caminho do arquivo executável de um serviço for C:\Arquivos de programas\MyProgram\MyService.exe e se uma pasta chamada C:\Programa também existir no disco rígido, o Windows localizará a pasta C:\Programa no disco rígido antes do arquivo C:\Arquivos de programas\MyProgram\MyService.exe e tenta executá-la.

Resolução

Importante Esta seção, este método ou esta tarefa contém etapas que descrevem como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga estas etapas cuidadosamente. Para obter mais proteção, faça um backup do Registro antes de modificá-lo. Dessa forma, você poderá restaurar o Registro se ocorrer algum problema. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
322756 Como fazer backup e restaurar o Registro no Windows


Para resolver este problema, adicione aspas em volta da seguinte entrada no Registro do Windows, onde <ServiceName> é o nome do serviço:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>\ImagePath
A entrada ImagePath contém o caminho do arquivo executável para o serviço. Para adicionar aspas em volta da entrada ImagePath para um serviço:
  1. Clique em Iniciar e em Executar.
  2. Na caixa Abrir, digite regedit e clique em OK.
  3. Localize e clique na seguinte entrada do Registro, onde <ServiceName> é o nome do serviço:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>
    .
    Por exemplo, se o serviço é denominado MeuServiço, localize a chave
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MyService
    .
  4. No painel à direita, clique duas vezes em
    ImagePath
    .
  5. Na caixa Dados do valor, adicione as aspas no caminho completo do arquivo executável para o serviço.

    Por exemplo, se o caminho do serviço \meu_serviço for C:\Arquivos de programa\MyProgram\MyService.exe altere a entrada na caixa Dados do valor para o serviço MeuServiço para o seguinte
    "C:\Arquivos de programas\MyService.exe"
  6. Clique em OK e encerre o Editor do Registro.
Observação: este é um artigo de ?PUBLICAÇÃO RÁPIDA? criado diretamente pela organização de suporte da Microsoft. As informações aqui contidas são fornecidas no presente estado, em resposta a questões emergentes. Como resultado da velocidade de disponibilização, os materiais podem incluir erros tipográficos e poderão ser revisados a qualquer momento, sem aviso prévio. Consulte os Termos de Uso para ver outras informações.

Propriedades

ID do artigo: 812486 - Última revisão: terça-feira, 2 de julho de 2013 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbprb KB812486

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com