ID do artigo: 812511 - Última revisão: sábado, 5 de março de 2011 - Revisão: 5.0

Age of Mythology: Ponteiro do Mouse Não é Exibido Conforme o Esperado

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao jogar o Age of Mythology, poderá ocorrer a corrupção gráfica do ponteiro do mouse, como uma caixa preta ao redor do ponteiro, um ponteiro piscante, um movimento desordenado ou o ponteiro poderá não ser exibido.

Causa

Esse problema pode ocorrer se alguma das seguintes condições for verdadeira:
  • O adaptador de vídeo não tem memória suficiente.
  • A configuração de resolução do jogo é muito alta.
  • Os drivers do mouse ou do adapatador de vídeo estão ultrapassados.

Resolução

Para resolver esse problema, use um ou mais dos seguintes métodos, na ordem em que aparecem.

Método 1: Verificar Se Há Pelo Menos 16 MB de Memória de Vídeo

Utilize a Feramenta de Diagnóstico do DirectX para determinar quanta memória de vídeo está instalada no adaptador. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar e, em seguida, em Executar.
  2. Na caixa Abrir, digite dxdiag e clique em OK.
  3. Clique nas guias Exibir ou Exibir 1.
  4. Em Dispositivo, observe a quantidade de memória de vídeo mencionada para Memória Total Aproximada, e então clique em Sair.

    Caso exista menos do que 16 MB de memória de vídeo instalada no adaptador de vídeo, você deve instalar memória de vídeo adicional ou um adaptador de vídeo que tenha mais memória de vídeo.
Se este método não resolver o problema, continue até o próximo.

Método 2: Diminuir a Resolução do Jogo

  1. Inicie o Age of Mythology e clique em Oções.
  2. Na lista Tamanho da Tela, clique em 800 X 600X16 e clique em OK.
Se este método não resolver o problema, continue até o próximo.

Método 3: Alternar para o Modo Janela

Para alternar entre o modo de tela cheia e o janela, pressione ALT+ENTER.

Se este método não resolver o problema, continue até o próximo.

Método 4: Fazer Download e Instalar os Drivers de Vídeo e Mouse Mais Recentes

  1. Entre em contato com o fabricante do seu hardware de vídeo e instale a versão mais recente do driver do adaptador de vídeo.
  2. Entre em contato com o fabricande do seu hardware de mouse e instale a versáo mais recente do driver do mouse.
Para obter informações sobre como entrar em contato com o fabricante do seu adaptador de vídeo ou da placa de som, consulte a seção "Referências" deste artigo.
Você pode também visitar o seguinte site da Web do Microsoft Windows Update para ver se atualizações aplicáveis do driver estão disponíveis:
http://update.microsoft.com (http://update.microsoft.com)
Se você estiver utilizando um mouse Logitech , faça download e instale os drivers mais recentes de mouses da Logitech a partir do seguinte site da empresa na Web:
http://www.logitech.com (http://www.logitech.com)
Se este método não resolver o problema, continue até o próximo.

Método 5: Editar o Arquivo de Configuração de Vídeo do Age of Mythology

  1. Clique em Iniciar e, em seguida, em Executar.
  2. Na caixa Abrir, digite Unidade:\Program Files\Microsoft Games\Age of Mythology\gfxconfig ondeUnidade é a letra da unidade do disco rígido no qual o Age of Mythology foi instalado.
  3. Clique duas vezes emVideoCardName.gfx, onde VideoCardName é a placa de vídeo instalada no computador. Por exemplo, se o seu computador tiver uma placa de vídeo Radeon, clique duas vezes em radeon.gfx.

    Nota Se lhe for solicitado para usar um aplicativo para abrir o arquivo, clique em selecionar a partir de uma lista e, em seguida, selecione Bloco de Notas.
  4. No menu Pesquisar ou Editar, clique em Localizar.
  5. Na caixa Localizar, digite features e clique em Localizar Próximo.
  6. Defina o valor de win32Cursor como 0.

    Certifique-se de que a entrada aparece da seguinte maneira:
    win32Cursor=1 // DWORD. 0 == d3d cursor. 1 == win32 cursor 
  7. No menu Arquivo, clique em Sair. Quando for solicitado a salvar as alterações, clique em Sim.
  8. Reinicie o Age of Mythology.

Referências

Para obter mais informações sobre como entrar em contato com o fabricante do seu hardware, clique no número apropriado na seguinte relação para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
65416  (http://support.microsoft.com/kb/65416/ ) Lista de Informações para Contato de Fornecedores de Hardware e Software de Terceiros, de A a K.

60781  (http://support.microsoft.com/kb/60781/ ) Lista de Informações para Contato de Fornecedores de Hardware e Software de Terceiros, de L a P.

60782  (http://support.microsoft.com/kb/60782/ ) Lista de Informações para Contato de Fornecedores de Hardware e Software de Terceiros, de Q a Z
A Microsoft fornece informações para o contato com terceiros para ajudá-lo a encontrar suporte técnico. Essas informações para contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações para contato com terceiros.
Palavras-chave: 
kbprb KB812511