Artikel-ID: 812877 - Geändert am: Montag, 27. Oktober 2003 - Version: 4.1

Clusterdienst wird nach Aktualisierung auf Windows Server 2003 Enterprise Edition nicht mehr gestartet

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
812877  (http://support.microsoft.com/kb/812877/EN-US/ ) Cluster Service Does Not Start After You Upgrade to Windows Server 2003, Enterprise Edition
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie in folgendem Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/DE/ ) Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

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Problembeschreibung

Nach einer Aktualisierung eines Serverclusters von Microsoft Windows 2000 Service Pack 3 (SP3) auf Windows Server 2003 Enterprise Edition wird der Clusterdienst nicht mehr gestartet und im Anwendungsprotokoll wird möglicherweise dieses oder ein ähnliches Ereignis aufgeführt:

Typ: Fehler
Quelle: VSS
Kategorie: Keine
Ereignis-ID: 8213
Datum: 3/18/2003
Uhrzeit: 17:01:51
Benutzer: NV
Computer: Computername
Beschreibung: Volumeschattenkopie-Dienstfehler (Volume Shadow Copy Service error): Ein Prozess, der als Host des so genannten "Cluster Service Writer" mit Kennung {41e12264-35d8-479b-8e5c-9b23d1dad37e} fungiert, wird unter einem Benutzerkonto mit ungenügend Berechtigungen ausgeführt. Führen Sie diesen Prozess mit einem der folgenden lokalen Konten aus: Lokales System, Administrator oder Sicherungs-Operatoren. Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

Wert:

0000: 57 52 54 57 52 54 49 43 WRTWRTIC

0008: 33 39 39 00 00 00 00 00 399.....

0010: 57 52 54 57 52 54 49 43 WRTWRTIC

0018: 33 36 34 00 00 00 00 00 364.....

Ursache

Dieses Problem tritt möglicherweise auf, wenn das Clusterdienstkonto nicht explizit Mitglied der lokalen Administratorgruppe ist. In Windows Server 2003 verwendet der Clusterdienst den Volumeschattenkopie-Dienst, um sicherzustellen, dass die Sicherungskopie der Clusterkonfigurationsinformationen für die verwendeten Sicherungsprodukte konsistent bleibt. Der vom Volumeschattenkopie-Dienst verwendete Cluster Backup Writer kann nicht gestartet werden, wenn dem Clusterdienstkonto nicht explizit Administratorrechte zugewiesen wurden. Es ist nicht ausreichend, wenn sich das Clusterdienstkonto in einer der Gruppen befindet, die der lokalen Administratorgruppe hinzugefügt wurden.

In früheren Versionen von Windows war es nicht notwendig, das Clusterdienstkonto explizit der lokalen Administratorgruppe hinzuzufügen. Wenn der Benutzer Mitglied einer Domänengruppe ist, die wiederum Mitglied der lokalen Administratorgruppe ist, startet der Clusterdienst von Windows 2000 problemlos. Bei einer Aktualisierung auf Windows Server 2003 ändert sich dieses Verhalten nicht.

Hinweis: Wenn auf einem Windows 2003-Computer ein Servercluster konfiguriert wurde, fügt der Assistent zum Erstellen eines neuen Serverclusters das Clusterdienstkonto auf dem Clusterknoten der lokalen Administratorgruppe hinzu. Das Konto wird auch dann hinzugefügt, wenn es indirekt Mitglied der lokalen Administratorgruppe ist (d. h. Mitglied einer Gruppe, die wiederum Mitglied der lokalen Administratorgruppe ist). Wenn auf dem Computer also nicht eine frühere Version von Windows aktualisiert wurde, startet der Clusterdienst erfolgreich, es sei denn, das Clusterdienstkonto wurde manuell aus der lokalen Administratorgruppe entfernt.

Lösung

Stellen Sie fest, welches Konto vom Clusterdienst verwendet wird, und verfahren Sie dann wie folgt, um dieses Problem zu lösen.

So stellen Sie fest, welches Konto der Clusterdienst verwendet:
  1. Klicken Sie auf Start und auf Ausführen. Geben Sie services.msc ein, und klicken Sie auf OK.
  2. Doppelklicken Sie in der Liste auf Clusterdienst.
  3. Klicken Sie auf die Registerkarte Anmelden, und überprüfen Sie, welches Domänenkonto im Feld Dieses Konto aufgeführt ist.

Methode 1: Das Clusterdienstkonto zu einem Mitglied der lokalen Administratorgruppe machen

Fügen Sie das Clusterdienstkonto explizit der lokalen Administratorgruppe auf dem lokalen Computer hinzu. Wenn Sie der lokalen Administratorgruppe des Knotens lediglich eine Gruppe hinzufügen, von der das Clusterdienstkonto ein Mitglied ist, lösen Sie dieses Problem nicht.

Methode 2: Ändern des Registrierungseintragseintrags für Zugriffskontrolle des Volumeschattenkopie-Dienstes

Warnung: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie regedit ein, und klicken Sie anschließend auf OK.
  2. Gehen Sie zum folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\VssAccessControl
    Hinweis: Erstellen Sie den Schlüssel VssAccessControl, falls er nicht vorhanden ist. Klicken Sie hierzu mit der rechten Maustaste auf VSS, zeigen Sie auf Neu, und klicken Sie auf Schlüssel. Geben Sie in das Feld Neuer Schlüssel #1 die Zeichenfolge VssAccessControl, und drücken Sie die [Eingabetaste].
  3. Klicken Sie mit der rechten Maustaste auf VssAccessControl, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.
  4. Geben Sie im Feld Neuer Wert #1 die Zeichenfolge beispiel.com\Clusterdienstkonto ein, wobei beispiel.com für den Namen der Domäne steht, in der sich das Clusterdienstkonto befindet und Clusterdienstkonto für den Namen des Clusterdienstkontos. Drücken Sie danach die [Eingabetaste].
  5. Klicken Sie mit der rechten Maustaste auf den erstellten Registrierungswert, und klicken Sie dann auf Ändern.
  6. Geben Sie im Feld Wert den Wert 1 ein, und klicken Sie anschließend auf OK.
  7. Beenden Sie den Registrierungseditor.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
Keywords: 
kbbug kbclustering kbpending KB812877
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