Při uložení v síti je soubor uzamčen nebo se zobrazí chybová zpráva s informacemi o odepření přístupu

Překlady článku Překlady článku
ID článku: 812937 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Pokud se pokusíte uložit soubor, například sešit aplikace Microsoft Excel, který jste otevřeli pomocí cesty UNC (Universal Naming Convention), může se zobrazit chybová zpráva podobná některé z následujících:
Soubor nelze číst. Soubor je zamčen.
Přístup byl odepřen.
Chyba uzamčení
Prohlížeč událostí může obsahovat následující událost:

Typ události: Informace
Zdroj události: Místní nabídka aplikace
Kategorie události: Žádná
ID události: 26
Uživatel: Není k dispozici
Popis: Místní nabídka aplikace: Windows - neúspěšný odložený zápis: Systému se nepodařilo uložit data souboru název_souboru_který_chcete_uložit. Data byla ztracena. Důvodem chyby je pravděpodobně selhání hardwaru počítače nebo síťového připojení. Pokuste se tento soubor uložit na jiné místo. Další informace získáte v Centru pro nápovědu a pomoc na http://support.microsoft.com.

Příčina

K tomuto problému dojde, pokud přesměrovač vyprázdní obsah souboru a zapíše jej místo do popisovače souboru s přístupem pro zápis do popisovače souboru s přístupem jen ke čtení. Jakmile přesměrovač přijal přerušení příležitostného zamykání, vyprázdnil mezipaměť pro soubor, ale nezrušil inicializaci mezipaměti u souboru. Přesměrovač musel také provést vyprázdnění a zrušení inicializace, pokud narazil na nastavený konec souboru, protože přerušení příležitostného zamykání je nesynchronní. Protože nezrušil inicializaci mezipaměti pro soubor, zapsal jej do nesprávného popisovače souboru.

Řešení

Informace o aktualizaci Service Pack

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Microsoft Windows XP. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389 Jak získat nejnovější aktualizaci Service Pack pro systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix dodávaná společností Microsoft. Tato oprava hotfix je však určená pouze k odstranění problému popsaného v tomto článku. Instalujte ji pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud vás tedy uvedené potíže příliš neobtěžují, doporučujeme, abyste počkali na další aktualizaci softwaru, která bude tuto opravu obsahovat.

Pokud je k dispozici oprava hotfix ke stažení, na začátku tohoto článku znalostní báze Knowledge Base naleznete oddíl Hotfix download available (Oprava hotfix ke stažení). Pokud zde tento oddíl není uveden, požádejte o poskytnutí opravy hotfix středisko technické podpory a péče o zákazníky společnosti Microsoft.

Poznámka: Máte-li jakékoli další dotazy nebo je-li třeba vyřešit nějaké potíže, je možné, že pro ně bude nutné vytvořit samostatný požadavek na služby. Další dotazy a žádosti o podporu, které se netýkají této konkrétní opravy hotfix, podléhají běžným sazbám za poskytnutí podpory. Úplný seznam telefonních čísel služeb technické podpory a péče o zákazníky společnosti Microsoft a možnost vytvoření samostatného požadavku na služby naleznete na tomto webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Ve formuláři Hotfix download available (Oprava hotfix ke stažení) jsou uvedeny jazyky, v nichž je oprava hotfix k dispozici. Pokud seznam neobsahuje váš jazyk, znamená to, že daná oprava hotfix v tomto jazyku není k dispozici. Anglická verze této opravy má následující atributy souborů (nebo novější). Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Při zobrazení informací o souboru jsou data a čas převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na panelu Datum a čas v okně Ovládací panely.

Windows XP SP1, Windows XP Tablet PC Edition

Datum         Čas   Verze            Velikost    Název souboru 
-------------------------------------------------------------- 
30. ledna 2003 21:41 5.1.2600.1164 400 896   Mrxsmb.sys 
30. ledna 2003 21:41 5.1.2600.1164 154 880   Rdbss.sys

Windows XP 64-Bit Edition

Datum         Čas   Verze            Velikost    Název souboru 
------------------------------------------------------------- 
30. ledna 2003 21:41 5.1.2600.1164 1 259 392   Mrxsmb.sys 
30. 1. 2003  21:41 5.1.2600.1164 489 216   Rdbss.sys

Jak potíže obejít

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zazálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Zálohování, úpravy a obnovení registru v systémech Windows XP a Windows Server 2003
Chcete-li tento problém obejít, zakažte na serveru příležitostné zamykání:
  1. Klikněte na tlačítko Start a potom na příkaz Spustit.
  2. Do pole Otevřít zadejte příkaz regedit a stiskněte klávesu ENTER.
  3. V Editoru registru vyhledejte následující podklíč registru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\LanmanServer\Parameters
  4. V pravém podokně klikněte na položku EnableOplocks a pak stiskněte klávesu ENTER.
  5. Do pole Údaj hodnoty zadejte hodnotu 0 a pak stiskněte klávesu ENTER.
  6. Ukončete Editor registru.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku. Tento problém byl poprvé opraven aktualizací Microsoft Windows XP Service Pack 2.

Další informace

Další informace o příležitostném zamykání naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
296264 Konfigurace příležitostného zamykání v systému Windows
Trasování tohoto problému ukazuje, že soubor je otevřen nejméně dvakrát a že systém nesprávně zapisuje do popisovače souboru jen ke čtení. Trasování zobrazující tento problém je podobné následujícímu:
96  CLIENT SMB: C NT create & X, File = \newshare.xls SMB: Desired Access = 0x00020089 (Read Data,Read EA,Read Attributes) 97  SERVER SMB: R NT create & X, FID = 0x5 SMB: Oplock Level = Batch

<content removed that displays the client program reading and locking the file, but the file is not closed>

450 CLIENT SMB: C NT create &amp; X, File = \newshare.xls SMB: Desired Access = 0x0002019F (Read/Write Data, Read/Write EA, Read/Write Attributes)

451 SERVER SMB: R NT create &amp; X, FID = 0xc007 SMB: Oplock Level = NONE

<content removed that displays the client program reading, locking,  writing and flushing data on this file handle>

585 CLIENT SMB: C write &amp; X, FID = 0x5, Write 0xc00 at 0x00005000 PID = 0xFEFF TID = 0x1002 MID = 0x4400 UID = 0x0801 586 SERVER SMB: R write &amp; X - NT error, System, Error, Code = (34) STATUS_ACCESS_DENIED
Poznámka: Identifikátor procesu (PID) 0xFEFF v rámci 585 představuje proces systému klienta, který využívá popisovač souboru jen ke čtení. Nezobrazuje program klienta zapisující data na disk.

Vlastnosti

ID článku: 812937 - Poslední aktualizace: 1. prosince 2008 - Revize: 5.5
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
Klíčová slova: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbenv kbqfe kberrmsg kbwinxppresp2fix kbfix kbbug KB812937

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com