Dosyaları Ağ Üzerinden Kaydettiğinizde Dosya Kilitli veya Erişim Engellendi Hata İletisi

Makale çevirileri Makale çevirileri
Makale numarası: 812937 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Evrensel adlandırma kuralı (UNC) yolu kullanarak açtığınız Microsoft Excel çalışma kitabı gibi bir dosyayı kaydetmeye çalıştığınızda, aşağıdakilerden birine benzer bir hata iletisi alabilirsiniz:
Dosya okunamıyor. Dosya kilitli
Erişim Engellendi
Kilit Hatası
Olay Görüntüleyicisi aşağıdaki olayı içerebilir:

Olay Türü: Bilgi
Olay Kaynağı: Uygulama Açılan Menüsü
Olay Kategorisi: Yok
Olay Kimliği: 26
Kullanıcı: Yok
Açıklama: Açılan pencere uygulaması: Windows - Gecikmeli Yazma Başarısız Oldu : Windows kaydetmek_istediğiniz_dosyanın_adı dosyasının tüm verilerini kaydedemedi. Veri kaybı oldu. Bu hataya bilgisayarınızın donanımındaki veya ağ bağlantınızdaki bir arıza neden olmuş olabilir. Lütfen bu dosyayı başka bir yere kaydetmeye çalışın. Daha fazla bilgi için, http://support.microsoft.com adresindeki Yardım ve Destek Merkezi'ne bakın.

Neden

Bu sorun, yeniden yönlendirici dosyanın içeriğini boşaltır ve yazma erişimi olan bir dosya tanıtıcısı yerine salt okunur erişimi olan bir dosya tanıtıcısına yazarsa oluşur. Yeniden yönlendirici, fırsatçı kilitleme sonunu hiçbiri olarak aldığında, dosyanın önbelleğini temizlemiş ancak kapatmamıştır. Ayrıca fırsatçı kilit sonu eşzamanlı olmadığı için, dosyanın ayarlanan sonuna erişildiğinde yeniden yönlendiricinin temizlemesi ve kapatması gerekmiştir. Dosya önbelleğini kapatmadığı için, yanlış dosya tanıtıcısını yazmıştır.

Çözüm

Hizmet paketi bilgileri

Bu sorunu gidermek için, en son Microsoft Windows XP hizmet paketini edinin. Ek bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
322389 En son Windows XP hizmet paketi nasıl elde edilir

Düzeltme bilgileri

Desteklenen bir düzeltme Microsoft'tan edinilebilir. Ancak bu düzeltmenin, yalnızca bu makalede anlatılan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşan sistemlere uygulayın. Bu düzeltmeye ek sınama uygulanabilir. Bu nedenle, sorundan ciddi olarak etkilenmiyorsanız, bu düzeltmeyi içeren bir sonraki yazılım güncelleştirmesini beklemeniz önerilir.

Karşıdan yüklenebilecek bir düzeltme varsa, bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan yüklenebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek ekibine başvurun.

Not Ek sorunlar oluşursa veya sorun giderme işlemleri gerekirse, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi veya ayrı bir hizmet isteği oluşturmak için, aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/contactus/?ws=support
Not "Düzeltme karşıdan yüklenebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bunun nedeni bu dil için kullanılabilir bir düzeltme bulunmamasıdır. Bu düzeltmenin İngilizce sürümü, aşağıdaki tabloda listelenen dosya özniteliklerine (veya daha yenisi) sahiptir. Bu dosyalarla ilgili tarihler ve saatler UTC (eşgüdümlü evrensel saat) kullanılarak listelenmiştir. Dosya bilgilerini görüntülediğinizde yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için, Denetim Masası'ndaki Tarih ve Saat aracında Saat Dilimi sekmesini kullanın.

Windows XP SP1, Windows XP Tablet PC Edition

Tarih       Saat  Sürüm         Boyut     Dosya adı 
-------------------------------------------------------------- 
30 Oca 2003 21:41 5.1.2600.1164 400.896   Mrxsmb.sys 
30 Oca 2003 21:41 5.1.2600.1164 154.880   Rdbss.sys

Windows XP 64-Bit Edition

Tarih        Saat  Sürüm         Boyut     Dosya adı 
------------------------------------------------------------- 
30 Oca 2003  21:41 5.1.2600.1164 1.259.392 Mrxsmb.sys 
30 Oca 2003  21:41 5.1.2600.1164 489.216   Rdbss.sys

Pratik Çözüm

Önemli Bu bölüm, yöntem veya görev kayıt defterini nasıl değiştireceğinizin anlatıldığı adımları içermektedir. Ancak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle, bu adımları dikkatlice uyguladığınızdan emin olun. Ek koruma için, kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
322756 Windows XP ve Windows Server 2003'te kayıt defteri nasıl yedeklenir, düzenlenir ve geri yüklenir
Bu soruna geçici bir çözüm için, dosya sunucusunda fırsatçı kilitlemeyi devre dışı bırakın:
  1. Başlat'ı ve ardından Çalıştır'ı tıklatın.
  2. kutusuna regedit yazın ve ENTER tuşuna basın.
  3. Kayıt Defteri Düzenleyicisi'nde, aşağıdaki kayıt defteri alt anahtarını bulun:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\LanmanServer\Parameters
  4. Sağ bölmede, EnableOplocks öğesini tıklatın ve ENTER tuşuna basın.
  5. Değer verisi kutusuna 0 yazıp ENTER tuşuna basın.
  6. Kayıt Defteri Düzenleyicisi'nden çıkın.

Durum

Microsoft, bu makalenin başında listelenen Microsoft ürünlerinde bir sorun olduğunu onaylamıştır. Bu sorun ilk olarak Microsoft Windows XP Service Pack 2'de giderilmiştir.

Daha fazla bilgi

Fırsatçı kilitleme hakkında ek bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
296264 Windows'da fırsatçı kilitlemeyi yapılandırma
Bu sorun izlendiğinde, dosyanın en az iki kez açıldığı ve sistemin hatalı şekilde salt okunur dosya tanıtıcısına yazdığı görülmüştür. Bu sorunu gösteren izleme aşağıdakine benzer:
96  CLIENT SMB: C NT create & X, File = \newshare.xls SMB: Desired Access = 0x00020089 (Read Data,Read EA,Read Attributes) 97  SERVER SMB: R NT create & X, FID = 0x5 SMB: Oplock Level = Batch

<istemci programının dosyayı okumasını ve kilitlemesini görüntüleyen içerik kaldırıldı, ancak dosya kapatılmadı>

450 CLIENT SMB: C NT create &amp; X, File = \newshare.xls SMB: Desired Access = 0x0002019F (Read/Write Data, Read/Write EA, Read/Write Attributes)

451 SERVER SMB: R NT create &amp; X, FID = 0xc007 SMB: Oplock Level = NONE

<istemci programının bu dosya tanıtıcısındaki verileri okumasını, kilitlemesini, yazmasını ve temizlemesini görüntüleyen içerik kaldırıldı>

585 CLIENT SMB: C write &amp; X, FID = 0x5, Write 0xc00 at 0x00005000 PID = 0xFEFF TID = 0x1002 MID = 0x4400 UID = 0x0801 586 SERVER SMB: R write &amp; X - NT error, System, Error, Code = (34) STATUS_ACCESS_DENIED
Not Çerçeve 585'teki 0xFEFF öğesinin işlem tanımlayıcısı (PID), salt okunur dosya tanıtıcısını kullanan istemci sistem işlemini gösterir. İstemci programının verileri diske yazmasını göstermez.

Özellikler

Makale numarası: 812937 - Last Review: 31 Aralık 2008 Çarşamba - Gözden geçirme: 5.5
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Tablet PC Edition
Anahtar Kelimeler: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbenv kbqfe kberrmsg kbwinxppresp2fix kbfix kbbug KB812937

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com