Použití programu Sledování sítě zachytit provoz sítě

Překlady článku Překlady článku
ID článku: 812953 - Produkty, které se vztahují k tomuto článku.
Poznámka
Tento článek se vztahuje na systém Windows 2000. Podpora pro systém Windows 2000 končí dne 13. července 2010. Na Centrum ukončení odborné pomoci řešení v systému Windows 2000 je výchozí bod pro plánování strategie přenesení ze systému Windows 2000. Další informace naleznete Zásady poskytování technické podpory společnosti Microsoft.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek popisuje několik doporučených postupů při Používáte návštěvnost sítě Microsoft Network Monitor (Netmon.exe).

Trasování v síti, který má některou z těchto vlastností může zabránit úspěšné analýzu sebraných síťového provozu:
  • Trasování v síti neobsahuje všechny nezbytné síťový provoz.
  • Obsahuje příliš mnoho zbytečné síťové provoz.
  • To není doprovázen název počítače a adresa informace o ohrožených počítačů.

Definice

V tomto článku se používají tyto definice:
  • Sběr dat (nebo Trasování): Přenos v síti shromážděny a uloženy pomocí aplikace Microsoft Sledování sítě (Netmon.exe).
  • Monitor počítače.: Počítač, který spouští program Sledování sítě.
  • Cílový počítač: Zachycuje do počítače, jehož síťový provoz Netmon.exe.
  • Cílová adresa: Určitý protokol adresa cílového počítače.

Zpřístupnění provoz cílové počítače do monitoru počítače

Pokud nepoužíváte program Sledování sítě v cílovém počítači. Ujistěte se, že je k dispozici pro všechny síťové přenosy z cílového počítače síťový adaptér monitoru počítače. V Ethernet prostředí, připojte monitor počítače a cílové počítače síťový rozbočovač. Pokud jsou monitor a cílové počítače na komutované síti ( například jsou připojeny k přepínač sítě Ethernet), všechny síťové přenosy do a z cílového počítače nemusí být k dispozici na monitoru počítače.

Poznámka: Obvykle rozbočovač představuje všechny síťové pakety všech síťové rozhraní (nebo porty) a přepínač představuje všechny pakety určený port. Složitější přepínače mohou povolit možnosti paketů vícesměrového vysílání filtrování a Upřesnit přemostění na portu pro zachytávání dat v síti a sledování.

Adresové databáze

Chcete-li najít a cílovém počítači uložit adresy:

Kolekce post-Capture adresa

  1. Pokud není zobrazen sběru síťových (například pokud jste Klepněte na tlačítko Zastavit v Sběr dat nabídka a nikoliZastavit a zobrazitnebo je-li aktivace sběru byla v platnosti), klepněte na tlačítkoZobrazí sebraná Data. v Sběr dat nabídky nebo stiskněte klávesu F12 Zobrazit zachycená data.
  2. V Zobrazení nabídky, klepněte na tlačítko Najít Všechny názvy.
  3. Zprávu uvádějící, že počet jmen byly v sebraných datech nalezen, klepněte na tlačítko OK.
  4. Uložit databázi adres, jak je popsáno vUložení databáze adres oddíl tohoto článku.

Uložení databáze adres

Soubory databáze adres, mohou být nepřesné Pokud cíl změny adresy počítače. Tato situace může nastat Dynamic Host Configuration Vyprší platnost zapůjčení (DHCP Protocol) nebo nahraďte síťový adaptér. Proto Společnost Microsoft doporučuje uložit databázích adres, které jsou specifické pro síť Sebere program Sledování.

Uložit adresu v paměti programu Sledování sítě databáze do souboru .adr:
  1. V programu Sledování sítě klepněte na tlačítko Adresy vSběr dat nabídka.

    Poznámka: Pokud Sběr dat: n(Souhrn) je-li otevřít dialogové okno Sběr dat nabídka nezobrazí.
  2. Klepněte na tlačítko Uložit, zadejte popisný název vNázev souboru pole a pak klepněte na tlačítkoUložit.

Kolekce pre-Capture adresa: Je cílový počítač v síti

  1. V programu Sledování sítě klepněte na tlačítko Adresy z Název v Nástroje nabídka.

    Poznámka: Tento příkaz je k dispozici ve verzi programu Sledování sítě součástí serveru Microsoft Systems Management Server (SMS).
  2. Zadejte název cílového počítače vNázev seznam a potom klepněte na tlačítkoVyřešit.

    V závislosti na sítě a cílový počítač Možnosti rozlišení k dispozici název a konfigurace mohou program Sledování sítě seznam typické adresy, například Ethernet, Tokenring, IP a IPX/XNS, které jsou přidružené k cílovému počítači.
    • Pokud je název rozpoznán, klepněte na tlačítko Uložit Adresa Přidání adresy na adresu v paměti v programu Sledování sítě databáze.
    • Pokud název není vyřešen a zobrazí "Adresa nebyla nalezena" zprávu uložte mimo síť jako cílový počítač popsané v Pre-Capture adresa Kolekce: Je cílový počítač od sítě Tato část článek.
  3. Klepněte na tlačítko Zavříta potom uložte adresu databáze.

Kolekce pre-Capture adresa: Je cílový počítač od sítě

Chcete-li použít následující postup, musíte znát cílovou adresu. Společnost Microsoft doporučuje používat adresu media access control (MAC) cílový počítač. Zachytávání pro specifické protokoly, jako je například IP, může Program Sledování sítě Ignorovat jiné přenosy protokolu, jako je například IPX/XNS způsobit.
  1. V Sběr dat nabídky, klepněte na tlačítkoAdresya klepněte na tlačítko Přidat.
  2. V Název Zadejte název cílový počítač.
  3. Zadejte adresu cílového počítače vAdresa pole, například zadejte adresu IP192.247.26.40.
  4. V Typ Klepněte na položku Typ adresa, kterou jste použili v Adresa pole. Klepněte například na položkuIP.
  5. Klepněte na tlačítko OK přidejte adresu v síti Sledování databáze adres v paměti.
  6. Uložte databázi adres.

Sběrné filtry

Následující příklady ukazují, jak lze konfigurovat několik společných sběrné filtry. Společnost Microsoft doporučuje nastavit filtr pro MAC Adresa cílového počítače (například adresu ETHERNET), pokud je to možné. Zachytit sadu filtrů pro specifické protokoly, jako je například IP, způsobí sítě Sledování Ignorovat jiné přenosy protokolu, jako je například IPX/XNS.

Zachytit všechny přenosy z cílového počítače a

  1. V Sběr dat nabídky, klepněte na tlačítkoFiltr.
  2. Poklepejte AND (dvojice adres)uzel.
  3. V Název seznamu Stanice 1, klepněte na název cílového počítače, jehož data chcete Shromažďujte.
  4. Ve skupinovém rámečku Směr, klepněte na tlačítko<--></-->a klepněte na tlačítko OK.

Zachytit všechny přenosy mezi dvěma cílových počítačů

  1. V Sběr dat nabídky, klepněte na tlačítkoFiltr.
  2. Poklepejte AND (dvojice adres)uzel.
  3. V Název seznamu Stanice 1, klepněte na název cílového počítače, jehož data chcete Shromažďujte.
  4. Ve skupinovém rámečku Směr, klepněte na tlačítko<--></-->.
  5. V Název seznamu Stanice 2, klepněte na název jiné cílové počítače jehož data chcete Shromažďujte.
  6. Klepněte na tlačítko OKa klepněte na tlačítkoOK.

Uložení filtru pro sběr dat

Uložit sběrný filtr programu Sledování sítě do souboru .cf:
  1. V Sběr dat nabídky, klepněte na tlačítkoFiltr.
  2. Klepněte na tlačítko Uložit, zadejte popisný název vNázev souboru pole a pak klepněte na tlačítko Uložit.

Vyrovnávací paměti pro sběr

Ve výchozím programu Sledování sítě můžete uložit až 1 gigabajt výstřižky (GB). Chcete-li změnit výchozí nastavení 1 MB, klepněte na tlačítko Vyrovnávací paměť Nastavení v programu Sledování sítě Sběr dat nabídka.
  • Ověřte, zda je dostatečná k zachycení velikost vyrovnávací paměti dostatečné síťové přenosy. Chcete-li určit typickou směrný plán, nastavte vhodného sběrný filtr proti klientovi pracovní a proveďte test sběr. Pokud uložené zachycení se stejnou velikost jako nastavení vyrovnávací paměti, je nutné provést větší vyrovnávací paměť. Obecně je zvýšit vyrovnávací koeficient dva.
  • Ověřte, zda nastavení virtuální paměti (stránkovací soubor) monitor počítače může zpracovávat maximální velikost, kterou chcete uložte.

Aktivace sběru

Zachycení aktivační události jsou obvykle nastaveny pro situace, kdy je obtížné udržet přetečení vyrovnávací paměti pro sběr. To často dochází Pokud platí některá z následujících podmínek:
  • Nelze spolehlivě reprodukovat problém se zkoumá pomocí zvláštní postup.
  • Nelze účinně koordinovat akce na monitoru a cílových počítačů.
  • Je nutné zachytit všechny přenosy do a z silně server načten. Například je to nutné k diagnostice uzamčení souboru porušení.
Chcete-li naplánovat aktivaci sběru, obvykle musíte odvodit bajt vzorek zejména posun od vzorku paket. Například posun 'Status Code System Error' SMB je u rozhraní NBT (rozhraní NetBIOS doprava přes IP) a přímo hostující SMB (TCP/UDP port 445). Následující příklad ukazuje jak nastavit aktivaci sběru, sběr se zastaví při pokusu o připojení k neexistující podíl na existující server. Příklad neobsahuje žádné Zachyťte podrobnosti filtru.

Například chybová zpráva Chyba WIN32 je kód 0xC00000CC. Kód chyby se zobrazí ve sběru dat v SMB "kód stavu Chyba systému "pole jako"status_bad_network_name". Tato chyba je definována v ntstatus.h. Microsoft Software Development Kit (SDK) obsahuje tato definice. Další informace navštivte následující Web společnosti Microsoft:
http://www.microsoft.com/msdownload/platformsdk/sdkupdate/
Další informace získáte následující článek znalostní báze Microsoft Knowledge Base:
113996INFO: Mapování NT stav chybové kódy ke kódům chyb prostředí Win32
  1. Na monitoru počítače:
    1. Spusťte program Sledování sítě.
    2. V Sběr dat nabídky, klepněte na tlačítko Aktivační události.
    3. Ve skupinovém rámečku Zapnout aktivaci, klepněte na tlačítko Porovnávací vzorek.
    4. Ve skupinovém rámečku Vzorek, klepněte na tlačítko Z Začátku rámcea klepněte na tlačítko Hex.
    5. V Offset (šestnáctkový) Typ pole 3f.
    6. V Vzorek Typ pole cc0000c0

      Poznámka:: Je ekvivalentní k chybě DWORD vzorek bytů little-endian 0xC00000CC.
    7. Ve skupinovém rámečku Akce aktivace, klepněte na tlačítko Zastavit sběra klepněte na tlačítko OK.
    8. V Sběr dat nabídky, klepněte na tlačítko Spustit.
  2. V cílovém počítači:
    1. Klepněte na tlačítko Spustita klepněte na tlačítko Spustit.
    2. V Otevřít Typ pole \\název_serveru\Neplatný název_sdílené_položky, kde název_serveru je platný název serveru a kde Neplatný název_sdílené_položky je název neexistující Sdílejte.
    3. Klepněte na tlačítko OK. Zprávu, která uvádí že síťový název nelze nalézt, klepněte na tlačítko OK
  3. Na monitoru počítače:
    1. Sběr automaticky zastaví. V Soubor nabídky, klepněte na tlačítko Uložit jako.
    2. Zadejte popisný název pro sběr dat v Název souboru pole a pak klepněte na tlačítko Uložit.

Poradce při potížích

  • Uložíte-li zachycená data sítě používejte popisné názvy..

    Uložíte-li sběr programu Sledování sítě, je užitečné Pomocí popisného názvu souboru. Například:
    Computer1_connect_failure_05_dec_2002.adr
    Přestože sběrný soubor obsahuje čas, datum nesmí být zřejmé nebo ověřitelné, zejména v případě, že je soubor změněn. Možná budete muset Upravte sběrné soubory během analýzy. Například párování Server Message Block (SMB) klient nebo server pakety závisí na MAC adresu. A směrovač mezi klienta a serveru může překrývat adresu MAC. Program Sledování sítě může analyzovat plně některé odpovědi v této situaci pro Příklad distribuovaný soubor systému souborů DFS odkaz odpovědi. Některé verze Program Sledování sítě umožňují upravit sběr. Výsledkem je můžete nahradit Adresa MAC směrovač s cílového serveru. To umožňuje SMB Analyzátor zadaný paket rozdělit na více čitelné.
  • Ujistěte se, zda jsou hodiny synchronizovány mezi počítači..

    Pro mnoho diagnostické postupy musí mít událost nebo součásti ladění a trasování programu Sledování sítě problému. K úspěšně křížový odkaz Další soubory protokolu s trasování programu Sledování sítě můžete musí být hodiny synchronizovány mezi počítači.
  • Uložte informace o adrese IP..

    Protože platnosti zapůjčené adresy DHCP může způsobit, že adresa IP změny v klientských počítačích, musíte zaznamenat nebo uložit příslušnou adresu IP shromažďuje informace o průběhu programu Sledování sítě.
  • Došlo k pokusu o spuštění sběru, než dojde k problému..

    Návštěvnost, která je nutná a dostatečná k dokument problém. Provedete to tak, je nutné spustit sběr dat před provedením první připojení mezi dvěma cílový počítač a pak jej po ukončení problém chování. Například soubor s protokolem SMB, operace působit proti úchyty. Chcete-li znát název souboru, je nutné zachytit soubor otevřít. (nebo vytvořit) operace.
  • Pokuste se zachytit stopy "úspěch" a "Chyba"..

    Pokud můžete zachytit stopy, kde dojde k problému a kde nedochází. Je vhodné zaznamenat tyto stopy na stejné cílový počítač. Pokud nelze provést, pokuste se jej zachytit nejbližšího možné konfigurace a síťového prostředí, které můžete vytvořit. Pro například obou cílových počítačů měli komunikovat stejném serveru, nebo stejném klientském počítači by měl komunikovat s podobně nakonfigurován. servery.
  • Akce dokumentu, které generují významné síťové přenosy..

    Akce, které provedete v cílovém dokumentu počítače ke generování významné síťové přenosy. Například v protokolu IP prostředí můžete zjednodušit Křížové odkazování sběr uživateli aktivitu, program činnosti nebo dávkového souboru. Chcete-li tak učinit, provést jednorázové ping příkazy pro jedinečné adresy IP před činnosti, a potom po činnosti.


Odkazy

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
810156Po instalaci programu Sledování sítě se zobrazí chybová zpráva, že nebyly nalezeny žádné síťové ovladače
261327 Jak přidat další samostatný analyzátor jazyka do programu Sledování sítě
164961 Instalace programu Sledování sítě nevyhledá instalace předchozí verze
Další informace o síti Sledování nástroj pro zachycení součástí systému Windows XP, klepněte na následující článek znalostní báze Microsoft Knowledge Base:
310875Popis, sběr dat nástroje Sledování sítě


Vlastnosti

ID článku: 812953 - Poslední aktualizace: 20. května 2011 - Revize: 4.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Klíčová slova: 
kbhowtomaster kbmt KB812953 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:812953

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com