UPDATE: Selective Suspend funktioniert nicht bei Videoaufnahmegeräten, die den Stream-Klassentreiber verwenden

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Artikel-ID: 813348 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
813348 FIX: Selective Suspend Does Not Work on Video Capture Devices That Use the Stream Class Driver
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn sich ein USB-Videoaufnahmegerät (USB = Universal Serial Bus), das den Stream-Klassentreiber stream.sys verwendet, im Leerlauf befindet und das System das Gerät später abschaltet, kann das Gerät nicht wieder gestartet werden, wenn seine Dienste benötigt werden. Deshalb kann es vorkommen, dass das Programm, das versucht, das Videoaufnahmegerät zu benutzen, nicht mehr reagiert.

Ursache

Dieses Problem entstand in Microsoft Windows XP Service Pack 1 (SP1) und ist auf eine Modifikation des Stream-Klassentreibers zurückzuführen. Eine Änderung wurde in SP1 vorgenommen, um Anfragen an Geräte im Leerlauf zu verhindern. Diese Änderung blockiert die IRP-Verarbeitung (IRP = I/O Request Packet). Bei der SP1-Implementierung wurde jedoch die Selective-Suspend-Funktionalität nicht berücksichtigt. Selective-Suspend-IRPs dürfen nicht auf diese Weise blockiert werden.

Lösung

Dieser Hotfix enthält Änderungen des Stream-Klassentreibers, die es dem Treiber ermöglichen, die Selective-Suspend-IRPs korrekt zu verarbeiten, damit das Gerät gestartet werden kann, wenn ein Programm dies erfordert.

Hotfix-Informationen

Ein Hotfix zur Behebung des Problems ist jetzt bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Eine vollständige Liste mit Telefonnummern des technischen Supports sowie die Möglichkeit zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix-Anfrage" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix.

Voraussetzungen

Keine

Neustart

Sie müssen den Computer neu starten, nachdem Sie den Hotfix angewendet haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie im Systemsteuerungsprogramm Datum/Uhrzeit mithilfe der Registerkarte Zeitzone ermitteln.
   Datum       Uhrzeit Größe    Dateiname
   ----------------------------------------------------
   19.09.2003  19:46   291.328  40708_enu_i386_zip.exe

Abhilfe

Es gibt keine Möglichkeit, dieses Problem zu umgehen.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen zu Hotfix-Paketen und deren Bezeichnungen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
816915 Neues Schema für die Dateibenennung in Microsoft Windows-Softwareupdate-Paketen

Eigenschaften

Artikel-ID: 813348 - Geändert am: Mittwoch, 26. Februar 2014 - Version: 2.6
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe KB813348
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