REVISIÓN: La opción de suspensión selectiva no funciona con dispositivos de captura de vídeo que utilizan el controlador de clase transmisión

Seleccione idioma Seleccione idioma
Id. de artículo: 813348 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Si un dispositivo de captura de vídeo bus serie universal (USB) que utiliza el control de clase transmisión (stream.sys) está inactivo, y si el sistema desactiva posteriormente el dispositivo, éste no se puede iniciar de nuevo cuando se requieren sus servicios. En consecuencia, el programa que intenta utilizar el dispositivo de captura de vídeo deja de responder.

Causa

El problema tiene su origen en Microsoft Windows XP Service Pack 1 (SP1) como consecuencia de una modificación que se hizo en el controlador de clase transmisión. Se ha incluido un cambio en SP1 para evitar las comunicaciones a los dispositivos que están inactivos. Este cambio bloquea el procesado del paquete de petición de entrada/salida (IRP). Sin embargo, la implementación de SP1 no tuvo en cuenta la funcionalidad de suspensión selectiva. Los IRP de suspensión selectiva no se deben bloquear de esta manera.

Solución

Esta revisión contiene cambios en el controlador de clase transmisión para procesar correctamente los IRP de suspensión selectiva, de manera que el dispositivo se pueda iniciar cuando un programa lo requiera.

Información de la revisión

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo en sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve gravemente afectado por este problema, recomendamos que espere a la próxima actualización del software que contenga esta revisión.

Si la revisión se puede descargar, hay una sección de descarga de revisión disponible en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los Servicios de soporte técnico y de asistencia al cliente de Microsoft con el fin de obtener la revisión.

Nota: si se producen más problemas o si hay que solucionarlos, es posible que tenga que crear una solicitud de servicio independiente. Se aplicarán los costos de soporte habituales a las preguntas y problemas de soporte técnico adicionales que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico y de asistencia al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota: el formulario relativo a la revisión que se puede descargar muestra los idiomas en los que está disponible la revisión. Si no ve su idioma, quizá sea debido a que la revisión no esté disponible para dicho idioma.

Requisitos previos

No existen requisitos previos.

Requisitos de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de sustitución de revisión

Esta revisión no sustituye a ninguna otra.

Información del archivo

La versión en inglés de esta revisión (hotfix) tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
   Fecha         Hora   Tamaño   Nombre de archivo
   ----------------------------------------------------
   19-Sep-2003  19:46  291.328  40708_enu_i386_zip.exe  

Solución

No se conoce ninguna solución temporal para este problema.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Más información

Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915 Nuevo esquema de nomenclatura para los paquetes de revisión de Microsoft Windows

Propiedades

Id. de artículo: 813348 - Última revisión: miércoles, 26 de febrero de 2014 - Versión: 2.6
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
Palabras clave: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe KB813348

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com