Numer ID artykułu: 813442 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Na komputerze z systemem Microsoft Windows XP mogą występować następujące problemy z podpisami cyfrowymi:
  • Podczas korzystania z narzędzia Informacje o systemie do przeglądania podpisanych sterowników zainstalowanych na komputerze (w narzędziu Informacje o systemie należy kliknąć węzeł Środowisko oprogramowania, a następnie kliknąć pozycję Podpisane sterowniki), żadne z urządzeń na liście nie jest określone jako podpisane. Przy każdym urządzeniu w kolumnie Podpisane jest napisane Nie lub Niedostępne.
  • Gdy witryna sieci Web rozszerzenia Microsoft Windows Update Web (http://www.windowsupdate.com) zostaje otwarta w programie Microsoft Internet Explorer, może zostać wyświetlony jeden z następujących komunikatów o błędzie:
    Aktualizacja oprogramowania nie została zakończona

    Program Windows Update nie wykonał pomyślnie aktualizacji.

    Send error number to Microsoft (0x800B0004)

    Aktualizacja oprogramowania nie została zakończona

    Program Windows Update nie wykonał pomyślnie aktualizacji.

    Wyślij numer błędu do firmy Microsoft (0x800b0001)
  • Nie można łączyć się z bezpiecznymi witrynami sieci Web. Podczas próby połączenia się z taką witryną w oknie przeglądarki jest wyświetlany następujący komunikat:
    Nie można wyświetlić strony
  • NazwaPliku
    Zostanie zainstalowany plik NazwaPliku.
    (Zasady=Ignoruj). Błąd 0x800b0003: Formularz podany dla tego tematu nie jest obsługiwany lub znany przez określonego dostawcę zaufania.
  • Gdy komputer zostanie uruchomiony po ponownym zainstalowaniu programu Microsoft Internet Explorer 6 za pomocą procedury opisanej w następującym artykule bazy wiedzy Microsoft Knowledge Base, jest wyświetlany komunikat, że program Internet Explorer nie został podpisany cyfrowo:
    318378 Jak zainstalować lub naprawić programy Internet Explorer i Outlook Express w systemie Windows XP
  • Podczas pobierania wiadomości e-mail może nie być możliwe zarejestrowanie się w programie Windows Messenger lub MSN Explorer albo może zostać przekroczony limit czasowy programu MSN Explorer.
  • W polu Uwagi na kartach Dźwięk i Ekran Narzędzia diagnostycznego DirectX mogą znajdować się wpisy podobne do następujących:
    Plik NazwaPliku nie jest podpisany cyfrowo. Oznacza to, że nie został przetestowany przez Laboratoria jakości sprzętu Microsoft Windows. Możesz uzyskać podpisany sterownik od producenta urządzenia sprzętowego.
  • Podczas próby zainstalowania dodatku Service Pack 1 (SP1) dla systemu Windows XP lub nowszego może zostać wyświetlony następujący komunikat o błędzie:
    Instalator dodatku Service Pack 1 nie może zweryfikować integralności pliku Update.inf. Sprawdź, czy na komputerze uruchomiono usługę kryptograficzną.
  • Podczas próby uaktywnienia pakietu Plus! DME (Digital Media Edition) przez Internet może zostać wyświetlony następujący komunikat o błędzie:
    Microsoft Plus! Activation was not able to activate Microsoft Plus! Digital Media Edition for the following reason:

    Microsoft Plus! Digital Media Edition cannot be activated at this time because the Microsoft Plus! Activation Wizard is unable to transmit information to the Microsoft product activation service. Verify that your computer is connected to the internet, and then try again.

Przyczyna

Problemy te mogą wskazywać, że składnik systemu Windows XP, który przetwarza podpisy cyfrowe, jest uszkodzony.

Rozwiązanie

W celu rozwiązania tego problemu należy ponownie zarejestrować pliki Softpub.dll, Wintrust.dll, Initpki.dll, Dssenh.dll, Rsaenh.dll, Gpkcsp.dll, Sccbase.dll, Slbcsp.dll, Mssip32.dll i Cryptdlg.dll. Aby to zrobić, wykonaj następujące czynności:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W polu Otwórz wpisz polecenie cmd, a następnie kliknij przycisk OK.
  3. W wierszu polecenia wpisz regsvr32 softpub.dll, a następnie naciśnij klawisz ENTER.
  4. Gdy zostanie wyświetlony komunikat, że operacja DllRegisterServer w pliku Softpub.dll powiodła się, kliknij przycisk OK.
  5. Powtórz kroki od 1 do 4 dla następujących plików: Wintrust.dll, Initpki.dll, Dssenh.dll, Rsaenh.dll, Gpkcsp.dll, Sccbase.dll, Slbcsp.dll, Mssip32.dll i Cryptdlg.dll.
  6. Wpisz polecenie exit, a następnie naciśnij klawisz ENTER, aby zamknąć wiersz polecenia.

Właściwości

Numer ID artykułu: 813442 - Ostatnia weryfikacja: 24 stycznia 2006 - Weryfikacja: 6.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Słowa kluczowe: 
kbprb KB813442

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com