Nie można połączyć się z serwerem terminali z terminalu z systemem Windows

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 813508 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Próba połączenia klienta usług terminalowych z serwerem terminali może się nie powieść. Po odczekaniu kilku godzin (w niektórych przypadkach do 24 godzin) połączenie może być nawiązane, ale symptom ten może wystąpić później.

W dzienniku aplikacji może się znaleźć również następujące zdarzenie:

Identyfikator zdarzenia 1004
Źródło: TermService
Opis: Serwer terminali nie może wystawić licencji klienta.

Przyczyna

Problem ten może wystąpić, gdy połączenie z serwerem terminali jest nawiązywane z urządzenia terminalowego opartego na systemie Windows (WBT, Windows-based terminal), takiego jak terminal WBT z systemem Windows CE lub dowolnego innego terminalu WBT, którego system operacyjny jest rozpoznawany przez usługi terminalowe systemu Windows jako „inny”. Problem ten występuje, jeśli są spełnione następujące warunki:
  • Klient WBT wystawił licencję trwałą, ale licencja ta wygasła.
  • Wątek licencjonowania usług terminalowych odpowiedzialnych za czyszczenie wygasłych licencji i zwracanie ich do puli licencji nie został jeszcze uruchomiony.

Rozwiązanie

Informacje o dodatku Service Pack

Aby rozwiązać ten problem, uzyskaj najnowszy dodatek Service Pack do systemu Microsoft Windows 2000. Aby uzyskać dodatkowe informacje, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
260910 Jak uzyskać najnowszy dodatek Service Pack dla systemu Windows 2000

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka. Globalna wersja tej poprawki ma atrybuty pliku pokazane w poniższej tabeli lub nowsze. Daty i godziny ostatniej modyfikacji plików podano zgodnie z czasem UTC (Coordinated Universal Time). Są one zamieniane na czas lokalny po wyświetleniu informacji o pliku. Aby sprawdzić różnicę między czasem UTC i czasem lokalnym, należy skorzystać z karty Strefa czasowa apletu Data i godzina w Panelu sterowania.
   Data         Godzina   Wersja        Rozmiar     Nazwa pliku -------------------------------------------------------- 24-sty-2003  19:28  5.0.2195.6654  125 712  Icaapi.dll 07-paź-2002  22:29  5.0.2195.6609   93 456  Licmgr.exe 15-sty-2003  15:59  5.0.2195.6654  329 488  Lserver.exe 24-sty-2003  19:28  5.0.2195.6654   26 384  Mstlsapi.dll 27-sty-2003  22:40  5.0.2195.6614  100 248  Rdpwsx.dll 14-sty-2003  23:06  5.0.2195.6654  142 608  Termsrv.exe 24-sty-2003  19:28  5.0.2195.6658   23 312  Tls236.dll 24-sty-2003  19:28  5.0.2195.6623   37 648  Winsta.dll

Obejście problemu

Aby obejść ten problem, ponownie uruchom usługę licencjonowania w usługach terminalowych, co spowoduje powrót wygasłej licencji do puli licencji.

Uwaga: Po ponownym uruchomieniu usługi licencjonowania może być konieczne odczekanie przez 15 minut na zwrócenie wygasłej licencji do puli licencji, aby klient mógł zalogować się do serwera terminali.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych na początku tego artykułu. Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 4 do systemu Microsoft Windows 2000.

Więcej informacji

Usługa licencjonowania usług terminalowych ma wątek wykonywany po uruchomieniu tej usługi. Wątek ten pozostaje w uśpieniu przez 15 minut po uruchomieniu usługi licencjonowania usług terminalowych, a następnie wykonuje operację czyszczenia, podczas której zwraca wygasłe licencje do puli licencji. Po zakończeniu tej operacji wątek ten pozostaje w uśpieniu przez 24 godziny, po czym ponownie wykonuje operację czyszczenia licencji. Operacja ta jest powtarzana co 24 godziny do momentu zatrzymania usługi licencjonowania usług terminalowych.

Aby uzyskać dodatkowe informacje dotyczące sposobu otrzymania poprawki dla systemu Windows 2000 Datacenter Server, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
265173 Program Datacenter i produkt Windows 2000 Datacenter Server (j. ang.)

Właściwości

Numer ID artykułu: 813508 - Ostatnia weryfikacja: 31 grudnia 2008 - Weryfikacja: 4.6
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbqfe kbtermserv kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB813508

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com