Não é possível ligar a um servidor de terminais a partir de um terminal baseado no Windows

Traduções de Artigos Traduções de Artigos
Artigo: 813508 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando tenta utilizar um cliente dos serviços de terminal para ligar a um servidor de terminais, não poderá fazê-lo. Se esperar durante várias horas (até à 24, em alguns casos), pode novamente ser possível estabelecer a ligação, mas poderá detectar novamente este sintoma mais tarde.

Também poderá ver o seguinte evento no registo de aplicações:

ID de evento 1004
Origem: ' Serviço de terminal '
Descrição: O servidor de terminais não pode emitir uma licença de cliente.

Causa

Este problema poderá ocorrer se ligar ao servidor de terminais baseado no Windows terminal (WBT) dispositivo, tal como um WBT baseado no Microsoft Windows CE ou outro WBT cujo sistema operativo é reconhecido pelos serviços de terminal do Windows como "outro". Este problema ocorre se existirem as seguintes condições:
  • O cliente WBT tiver sido emitido uma licença permanente, mas essa licença expirou.
  • Os serviços de terminal licenciamento thread que é responsável pela limpeza licenças expiradas e devolvê-los para o conjunto de licenças ainda não foi executada.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente para o Microsoft Windows 2000. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
260910Como obter o Service Pack mais recente do Windows 2000

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentada, submeta um pedido para o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.A versão global desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   24-Jan-2003  19:28  5.0.2195.6654  125,712  Icaapi.dll 
   07-Oct-2002  22:29  5.0.2195.6609   93,456  Licmgr.exe
   15-Jan-2003  15:59  5.0.2195.6654  329,488  Lserver.exe  
   24-Jan-2003  19:28  5.0.2195.6654   26,384  Mstlsapi.dll
   27-Jan-2003  22:40  5.0.2195.6614  100,248  Rdpwsx.dll
   14-Jan-2003  23:06  5.0.2195.6654  142,608  Termsrv.exe
   24-Jan-2003  19:28  5.0.2195.6658   23,312  Tls236.dll
   24-Jan-2003  19:28  5.0.2195.6623   37,648  Winsta.dll

Como contornar

Para contornar este problema, reinicie o serviço de licenciamento para a licença expirada possa voltar para o conjunto de licenciamento de serviços de terminal.

Nota Tem de aguardar 15 minutos depois de reiniciar o serviço de licenciamento antes da licença expirada é devolvida ao conjunto de licenciamento e o cliente novamente pode iniciar sessão no servidor de terminais.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo. Este problema foi corrigido pela primeira vez no Microsoft Windows 2000 Service Pack 4.

Mais Informação

Licenciamento dos serviços de terminais tem um thread é executado quando inicia o serviço de licenciamento de serviços de terminal. Este thread está suspenso durante 15 minutos quando os serviços de terminal licenciamento serviço é iniciado e, em seguida, efectua uma operação de limpeza onde devolve licenças expiradas ao conjunto de licenciamento. Depois de concluir esta operação, este módulo estiver suspenso durante 24 horas e, em seguida, execute novamente a operação de limpeza. -Repete esta operação de limpeza de licença em 24 horas até que o serviço de licenciamento de serviços de terminal está parado.

Para obter informações adicionais sobre como obter uma correcção para o Windows 2000 Datacenter Server, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
265173O programa Datacenter e o produto do Windows 2000 Datacenter Server

Propriedades

Artigo: 813508 - Última revisão: 22 de fevereiro de 2007 - Revisão: 4.6
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbtermserv kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB813508 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 813508

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com