Only One Function Is Enumerated and a Code 10 Error Occurs in Device Manager When You Insert a Multifunction PC Card into a PCMCIA Slot

Article translations Article translations
Article ID: 813707 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you insert a multifunction PC Card into the PCMCIA slot, only one function is enumerated and initialized, the other functions do not work. When this problem occurs, a code 10 error occurs in Device Manager. This problem occurs in certain scenarios, and it depends on how the function drivers connect to the interrupt request (IRQ). If the drivers use the translated resources (as expected), they connect to an IRQ as "exclusive." This means that the drivers shut out the other function. However, if the drivers explicitly specify "shared," this problem does not occur. Some drivers may incorrectly specify "shared."

CAUSE

This problem occurs because when Mf.sys generates resource lists, it does not handle the allocation of device exclusive resources when more than one child device requests a resource that is marked device exclusive on the parent device. Interrupt resource on a multifunction PC Card is an example of a resource that is marked device exclusive on the parent device that must be shared on more than one child device. When a child device requests a device exclusive resource, it does not receive one, and a code 10 error occurs in Device Manager.

RESOLUTION

Service pack information

Windows XP

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Windows 2000

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP
   Date         Time   Version            Size    File name   Platform
   -------------------------------------------------------------------
   06-Feb-2003  01:07  5.1.2600.1167      62,208  Mf.sys      x86
   06-Feb-2003  01:07  5.1.2600.1167     132,096  Mf.sys      IA64
Windows 2000
   Date         Time   Version            Size    File name   Platform
   -------------------------------------------------------------------
   24-Feb-2003  19:41  5.0.2195.6668      57,264  Mf.sys      x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Windows XP

This problem was first corrected in Microsoft Windows XP Service Pack 2.

Windows 2000

This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

Properties

Article ID: 813707 - Last Review: October 27, 2006 - Revision: 4.3
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kboswin2000fix kbwin2ksp4fix kbddk kbprb KB813707

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com