多機能 PC カードを PCMCIA スロットに装着した場合、1 つの機能だけが検出され、デバイス マネージャでコード 10 エラーが発生する

文書翻訳 文書翻訳
文書番号: 813707 - 対象製品
すべて展開する | すべて折りたたむ

現象

多機能 PC カードを PCMCIA スロットに装着した場合、1 つの機能だけが検出、初期化され、他の機能が動作しないことがあります。この問題が発生した場合、デバイス マネージャでコード 10 エラーが発生します。この問題は特定の状況で発生し、機能ドライバが割り込み要求 (IRQ) へ接続する方法に依存します。ドライバが (予定どおり) 変換されたリソースを使用すると、そのドライバは IRQ に "排他" として接続します。つまり、ドライバは、他の機能を締め出します。しかし、ドライバが、明示的に "共有" を指定すると、この問題は発生しません。一部のドライバは、誤って "共有" を指定している可能性があります。

原因

この問題は、1つ以上の子デバイスが、親デバイスに対してデバイス専用としてマークされたリソースを要求しても、Mf.sys は、リソース一覧の作成時、デバイス専用になっているリソースを割り当てられないことが原因で発生します。1つ以上の子デバイスで共有しなければならない多機能 PC カードの割り込みリソースは親デバイスに対してデバイス専用としてマークされるリソースの例です。子デバイスがデバイス専用リソースを要求しても、リソースが割り当てられず、デバイス マネージャでコード 10 エラーが発生します。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

この問題を解決するためのモジュールは、Windows 2000 日本語版 Service Pack 4 以降に含まれております。
Windows 2000 日本語版の最新 Service Pack については、以下の Web サイトから入手できます。
http://www.microsoft.com/japan/windows2000/downloads/servicepacks/sp4/default.asp

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 813707 (最終更新日 2003-03-20) をもとに作成したものです。

プロパティ

文書番号: 813707 - 最終更新日: 2006年3月24日 - リビジョン: 4.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
キーワード:?
kbhotfixserver kbqfe kbwinxpsp2fix kbddk kbprb KB813707
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com