Article ID: 813711 - Last Review: July 15, 2009 - Revision: 5.0

My view settings or customizations for a folder are lost or incorrect

On This Page

Expand all | Collapse all

Problem description

Your view settings or customizations for a folder may be lost or incorrect. For example, you may experience one or more of the following symptoms:
  • Microsoft Windows does not remember your view settings for a folder when you reopen it.

    Note The view settings include Thumbnails, Tiles, Icons, List, and Details.
  • Windows does not remember the size or position of a folder window when you reopen it.
  • The wrong thumbnail image appears for a folder, or no thumbnail image appears.
Note This problem may occur even if you have selected the Remember each folder's view settings check box under Advanced Settings on the View tab of Folder Options in Control Panel.

This article helps you fix this problem. You can either update to the latest Windows XP service pack, as described in the "Resolution" section, or you can perform one of the solutions that are described in the "Workaround" section.

Resolution

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack
Note If there is a reason that you do not want to install the latest service pack, see the other resolution choices in the "Workaround" section.

Now go to the "Did this fix the problem?" section.

WORKAROUND

To have us fix this problem for you, go to the “Fix it for me” section. If you would rather fix this problem yourself, go to the “Let me fix it myself” section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.

Fix this problem
Microsoft Fix it 50146


Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

Now go to the "Did this fix the problem?" section.

Let me fix it myself

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

To work around this problem, create a BagMRU Size DWORD value in both of the following registry keys, and then set the value data for both values to the number of folders that you want Windows to remember the settings for. For example, for Windows to remember the settings for 5,000 local folders and 5,000 network folders, set both values to 5000.

You must create the new value for the following registry keys:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell

HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
Important You may have to adjust the BagMRU Size values for your specific situation. If you increase the BagMRU Size values, the information that is stored in the registry increases. When you use roaming user profiles, registry information is copied to a server when you log off and copied to your local computer when you log on. Therefore, you may have performance issues if you increase the BagMRU Size values for roaming user profiles.

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type BagMRU Size, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 5000, and then click OK.
Follow these steps:
  1. Locate and then click the following key in the registry:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
  2. On the Edit menu, point to New, and then click DWORD Value.
  3. Type BagMRU Size, and then press ENTER.
  4. On the Edit menu, click Modify.
  5. Type 5000, and then click OK.
Now go to the "Did this fix the problem?" section.

Did this fix the problem?

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .

Cause

This problem occurs because Windows stores each folder's view settings and customizations in the registry. By default, this data is limited to 200 local folders and to 200 network folders, for a total of 400 folders. The data for folder view settings and for customizations is stored in the following registry keys:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags

HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags

STATUS

This problem was first corrected in Windows XP Service Pack Service Pack 2.

MORE INFORMATION

Windows can remember the folder settings for view state, window position, sort order, column information, folder type, status bar setting, toolbar toggles, and search results.

REFERENCES

For more information about how to modify your folder view settings or to customize a folder, click the following article number to view the article in the Microsoft Knowledge Base:
812003  (http://support.microsoft.com/kb/812003/ ) How to modify your folder view settings or to customize a folder

APPLIES TO
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbmsifixme kbfixme kbtshoot kbbug KB813711
 

Article Translations