Identificativo articolo: 813711 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Le modifiche alla dimensione, visualizzazione, icona o la posizione di una cartella vengono persi in un computer che esegue Windows XP, Windows Vista o Windows 7.

Ad esempio, si verifichi uno o pi¨ dei seguenti problemi:
  • Microsoft Windows non memorizza le impostazioni di visualizzazione per una cartella quando si riapre la cartella.

    Nota. Le impostazioni di visualizzazione includono anteprime, titoli, icone, elenco, dettagli e cosý via.
  • Non Ŕ possibile mantenere le dimensioni o la posizione della finestra di una cartella quando si riapre la cartella.
  • Per una cartella viene visualizzata un'immagine di anteprima non corretta.
  • Per una cartella non viene visualizzata l'immagine di anteprima.


Nota. Questo problema pu˛ verificarsi in Windows XP o in Windows Vista, anche se si seleziona il Memorizza le impostazioni di visualizzazione di ogni cartella casella di controllo il Impostazioni avanzate dal menu di Visualizzazione scheda di Opzioni cartella in Pannello di controllo.

Cause

Questo problema si verifica perchÚ le impostazioni del Registro di sistema per Opzioni cartella non sono corrette.

Risoluzione

Diagnosticare e risolvere il problema automaticamente

Il diagnosticare e risolvere i problemi di cartelle e File di Windows automaticamente risoluzione dei problemi pu˛ correggere automaticamente il problema descritto in questo articolo.
La risoluzione dei problemi consente di risolvere molti problemi.Ulteriori informazioniEsegui ora

Correggere il problema manualmente

Importante. Questa sezione, metodo o attivitÓ contiene la procedura per modificare il Registro di sistema. Tuttavia, potrebbero verificarsi seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo, Ŕ possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
322756 Backup e ripristino del Registro di sistema in Windows
Per risolvere il problema, ripristinare le impostazioni del Registro di sistema per le cartelle. A tale scopo, attenersi alla procedura appropriata per il sistema operativo:

Windows XP

  1. Eliminare le seguenti sottochiavi del Registro di sistema:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\BagMRU
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags
  2. Ricreare le sottochiavi del Registro di sistema seguente:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
  3. Creare e impostare il BagMRU Size valore del Registro di sistema da 5000 nelle sottochiavi del Registro di sistema creato nel passaggio 2.

Windows Vista o Windows 7

  1. Eliminare le seguenti sottochiavi del Registro di sistema:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags


    Per le versioni x64 di Windows Vista o Windows 7, eliminare le seguenti sottochiavi del Registro di sistema:
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
  2. Ricreare le sottochiavi del Registro di sistema seguente:
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags


    Per le versioni x64 di Windows Vista o Windows 7, ricreare le sottochiavi del Registro di sistema seguente:
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
  3. Creare e impostare il BagMRU Size valore del Registro di sistema da 5000 nelle sottochiavi del Registro di sistema creato nel passaggio 2.

Informazioni

Funzionamento del pacchetto MATS per risolvere il problema

  1. Il pacchetto MATS analizza il computer e rileva se il computer Ŕ in esecuzione Windows XP, Windows Vista o Windows 7.

    Se il computer Ŕ in esecuzione Windows XP, il pacchetto MATS verifica che una delle seguenti condizioni Ŕ vera:
    • Il BagMRU Size valore del Registro di sistema nella seguente sottochiave del Registro di sistema non esiste o Ŕ minore di 5000:
      HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
    • Il numero pi¨ alto di sottochiave nella seguente sottochiave del Registro di sistema Ŕ supera al 20% del BagMRU Size valore del Registro di sistema:
      HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags


      Nota. Durante questo processo, viene visualizzata una finestra di dialogo. Questa finestra di dialogo offre la possibilitÓ di risolvere il problema automaticamente (questo Ŕ l'opzione consigliata) o di selezionare manualmente i singoli problemi da risolvere. Se si selezionano manualmente singoli problemi da correggere, Ŕ necessario selezionare il Personalizzazioni di icone e cartelle o il Gli altri utenti o I non conosce opzione nella finestra di dialogo.


    Se il computer Ŕ in esecuzione Windows Vista o Windows 7, il pacchetto MATS verifica che una delle seguenti condizioni Ŕ vera:
    • Il NoSaveSettings valore del Registro di sistema nella seguente sottochiave del Registro di sistema non Ŕ uguale a 1:
      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
      Inoltre, il BagMRU Size valore del Registro di sistema nella seguente sottochiave del Registro di sistema non esiste o Ŕ minore di 5000:
      HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
    • Il numero pi¨ alto di sottochiave nella seguente sottochiave del Registro di sistema Ŕ supera al 20% del BagMRU Size valore del Registro di sistema:
      HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags


      Nota. Durante questo processo, viene visualizzata una finestra di dialogo. Questa finestra di dialogo offre la possibilitÓ di risolvere il problema automaticamente (questo Ŕ l'opzione consigliata) o di selezionare manualmente i singoli problemi da risolvere. Se si selezionano manualmente singoli problemi da risolvere, yot essere necessario selezionare il Personalizzazioni di icone e cartelle o il Gli altri utenti o I non conosce opzione nella finestra di dialogo.
  2. Il pacchetto MATS verifica che le impostazioni del Registro di sistema e le personalizzazioni per le cartelle vengono ripristinate correttamente.

Altri elementi che le correzioni di pacchetto passe-PARTOUT

2394521 Impossibile svuotare il Cestino in Windows XP o in Windows Vista
949109 Errore "il file o la cartella non esiste" in Windows Vista
934160 "Autorizzazione di rete o il file" o "non esiste" errore
2394740 Non Ŕ possibile selezionare pi¨ elementi dopo l'aggiornamento da Windows XP a Windows Vista
2396571 Modifica di icone in modo non corretto in Windows

ProprietÓ

Identificativo articolo: 813711 - Ultima modifica: giovedý 21 marzo 2013 - Revisione: 13.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Chiavi:á
kbtshoot kbprb kbexpertisebeginner kbexpertiseinter kbsurveynew kbmatsfixme kbmt KB813711 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 813711
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com