Article ID: 813745 - Last Review: January 9, 2006 - Revision: 1.4

"Either there is no default mail client or the current mail client cannot fulfill the messaging request" error message when you send e-mail from third-party program in Outlook

Expand all | Collapse all

SYMPTOMS

When you try to send an e-mail message from a third-party program, such as a Usenet newsreader, you may receive the following error message:
Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client.

CAUSE

This issue may occur if the Outlook registry key is corrupted. When other programs try to use the Outlook Simple MAPI interface, they cannot retrieve the required information from the registry.

RESOLUTION

To resolve this issue, you must first remove the corrupted Outlook registry key, and then perform a Detect and Repair operation to have Outlook rebuild the key. To do this, follow these steps.Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then press ENTER.
  3. In Registry Editor, locate the following subkey in the registry: HKEY_LOCAL_MACHINE\Software\Clients\Mail\Microsoft Outlook
  4. Select the subkey, and then press DELETE.
  5. Click Yes.
  6. Quit Registry Editor.
  7. Start Outlook.
  8. On the Help menu, click Detect and Repair.
  9. Follow the instructions on the screen to complete the repair.

APPLIES TO
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
Keywords: 
kbcorrupt kbrepair kbregistry kbprb KB813745
 

Article Translations

 

Related Support Centers