El controlador PCMCIA no inicializa la tarjeta PC Card serie multifunción Elan

Seleccione idioma Seleccione idioma
Id. de artículo: 813820 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

El puerto serie multifunción PC Card de LAN emulada SL332 utiliza dos chips de unidad (VPU) procesamiento visual (una compatible con 16550 receptor asincrónico universal [UART transmitter] que está diseñado para las tarjetas PCMCIA). Sin embargo, cuando se enumeran los puertos COM, el equipo intenta iniciar el dispositivo, pero se deshabilita el puerto serie porque la capacidad para el puerto está desactivada.

Causa

El registro de límite de E/s es un registro de configuración de la función opcional en la ficha. PCMCIA.sys inadvertidamente intenta escribir este registro aunque la tarjeta ha indicado que no admite este registro. Durante esta escritura intento, se escribe un registro de 0 x 05 al registro de configuración y estado. Bit 2 de este registro (0 x 04) se interpreta el dispositivo para desactivar la función, según la especificación PCMCIA. El problema que se describe en la sección "Síntomas" de este artículo se produce porque el puerto serie multifunción PC Card de LAN emulada SL332 implementa exactamente 8 bytes de registros de configuración y descodifica los 3 bits inferiores de dirección sólo.

Solución

Windows XP

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Microsoft Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name   Platform
   -------------------------------------------------------------------
   06-Feb-2003  17:05  5.1.2600.1167     115,840  Pcmcia.sys  x86
   06-Feb-2003  17:05  5.1.2600.1167     308,864  Pcmcia.sys  IA64

Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Una vez aplicado este hotfix, debe reiniciar el equipo.

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version         Size    File name 
   --------------------------------------------------------
   12-Dec-2003  09:28                  34,724  Ntdetect.com 
   23-Dec-2003  11:50  5.0.2195.6887   59,024  Pci.sys 
   10-Mar-2004  14:48  5.0.2195.6884  109,936  Pcmcia.sys

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Sólo Windows XP

Este problema se corrigió por primera vez en el Service Pack 2 de Microsoft Windows XP.

Los productos de terceros mencionados en este artículo son fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.

Propiedades

Id. de artículo: 813820 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 5.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwin2000presp5fix kbwinxppresp2fix kbfix kbbug kbqfe kbddk kbprb KB813820 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 813820

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com