Article ID: 813880 - Last Review: February 20, 2007 - Revision: 3.9

Mailbox and folder sizes are not updated after a single-instance stored message is modified

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SUMMARY

The mailbox size in Exchange System Manager may be less than the total size of all the messages in the mailboxes. Because of this, mailbox quotas may not be strictly applied because the Quota Manager uses the size that is reported by ESM, and the Outlook user may have exceeded that mailbox size.

CAUSE

This problem may occur if you modify a message that shares an instance with other Exchange 2000 Server single-instance stored messages. Changes to the message that increase its size may not be reflected in other instances of that message, causing the message database and the folder where the MDB is stored to show incorrect storage values.

RESOLUTION

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282  (http://support.microsoft.com/kb/824282/ ) September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. Component:

The Global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   10-Feb-2003  19:12  6.0.6416.0  3,915,776  Cdoex.dll
   10-Feb-2003  19:05  6.0.6416.0    827,392  Davex.dll
   10-Feb-2003  19:12  6.0.6416.0  3,567,616  Excdo.dll
   10-Feb-2003  19:00  6.0.6416.0    258,048  Exmime.dll
   10-Feb-2003  19:05  6.0.6416.0  2,129,920  Exoledb.dll
   10-Feb-2003  18:57  6.0.6416.0     81,920  Exosal.dll
   10-Feb-2003  19:05  6.0.6416.0    303,104  Exprox.dll
   10-Feb-2003  18:34  6.0.6416.0  2,273,280  Mdbmsg.dll
   10-Feb-2003  18:04  6.0.6416.0     32,768  Mdbrole.dll
   10-Feb-2003  18:59  6.0.6416.0  4,620,288  Store.exe
NOTE: Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
301378  (http://support.microsoft.com/kb/301378/EN-US/ ) How to Obtain the Latest Exchange 2000 Server Service Pack

WORKAROUND

To work around this problem, run the Isinteg utility to recalculate the mailbox and folder sizes. You must perform this action periodically because the message sizes and reported database size change again when single-instance stored messages are modified.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Before you apply the hotfix that this article describes, the output from the Isinteg.exe tool may look similar to the following output:
Calc(150938) <> Prop(46871), Fixed it. 
Fix: Folder 13424 (Fid=003E-00000000741E) "Inbox": Folder property PR_MESSAGE_SIZE(0E080014): 
Calc(52784000) <> Prop(52515128), Fixed it. 
Fix: Folder 13424 (Fid=003E-00000000741E) "Inbox": Folder property PR_NORMAL_MESSAGE_SIZE(66B30014): 
Calc(52782111) <> Prop(52513239), Fixed it.

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbenv kbprb kbqfe kbfix kbexchange2000presp4fix kbbug KB813880