You receive a "Word could not re-establish a DDE connection" error message in Word

Article translations Article translations
Article ID: 813989 - View products that this article applies to.


For a Microsoft Word 2000 version of this article, see 189259.

For a Microsoft Word 97 version of this article, see 123698.

For a Microsoft Word 7.0 or earlier version of this article, see 188077.
Expand all | Collapse all

On This Page

SYMPTOMS

When you insert a database in a Microsoft Word document or attach a mail-merge main document to a data source, you may receive the following error message, where program name is the program that is associated with the data source:
Word could not re-establish a DDE connection to program name to complete the current task.

CAUSE

This issue may be caused by any of the following conditions:
  • There is a problem communicating through Dynamic Data Exchange (DDE).
  • The query or table name contains quotation marks. When you try to insert a Microsoft Access query or table whose name contains quotation marks, Word adds a second set of quotation marks around the name. Because this action returns incorrect information to Access, Access cannot locate the query or table, and then generates the error message.
  • You select a memo or picture field. If you select a memo field or picture field from an Access version 1.0 table as a sort field in a Word document, you receive the error message that is described in the "Symptoms" section of this article. Both memo and picture fields are automatically filtered out of the Sort menu when you use an Access version 1.1 table as the data source. Word cannot remove the memo or picture field names from the Sort dialog box for Access 1.0. The field types, as part of the data table file information, are not supplied by Access 1.0.
  • The Access database is opened "exclusively" by another user.

RESOLUTION

To resolve this issue, use the method that is associated with the cause.

Problem Communicating Through DDE

Select a different method for opening the data source. To do this, make sure that the Confirm conversion at open option is enabled, and then open the data source:
  1. On the Tools menu, click Options.
  2. Click the General tab.
  3. Click to select the Confirm conversion at open check box, and then click OK.
  4. Open the data source. To do so, use either of the following methods:
    • Insert a database in a Word document:
      1. On the Database toolbar, click Insert Database.

        Note To view the Database toolbar, point to Toolbars on the View menu, and then click Database.
      2. In the Database dialog box, click Get Data.
      3. In the Files of type box, click the type of data file that you have.
      4. Click your data file, and then click Open.
      5. In the Confirm Data Source dialog box, click the via DDE method that is correct for your data source, and then click OK.
      6. Click Insert Data.

        Note If Word cannot re-establish a DDE connection, try starting the database program, and then repeat the previous steps. Or, click via ODBC method in step 5.
    • Attach a data source to a mail-merge main document:
      1. Open your mail-merge main document.
      2. On the Tools menu, point to Letters and Mailings, and then click Mail Merge.
      3. In the Mail Merge task pane, click Step 3: Select Recipients, click Use an existing list, and then click Browse.
      4. In the Files of type box, click the type of data file that you have.
      5. Click your data file, and then click Open.
      6. In the Confirm Data Source dialog box, click the via DDE method that is correct for your data source, and then click OK.
      7. In the Mail Merge Recipients dialog box, click OK.

        Note If Word cannot re-establish a DDE connection, try starting the database program, and then repeat the previous steps, or click via ODBC method in step 6.

The Query or Table Name Contains Quotation Marks

To work around this issue, rename the table in Access to use apostrophe characters (') as the marker, or use the Access ODBC driver instead of DDE.

You Select a Memo or Picture Field

To prevent this error message, do not try to sort Access 1.0 data tables by using the memo field or picture field.

The Access Database Is Opened Exclusively

To make shared access to the Access database possible:
  1. In the Open Database dialog box, click to clear the Exclusive check box.
  2. Change the Default Open mode for databases to shared. To locate this option in Access 2.0, click Options on the View menu, and then click Multiuser/ODBC in the Category box. To locate this option in Access 7.0, Access 97, Access 2000, or Access 2002, click Options on the Tools menu, click the Advanced tab, and then click the Shared option.

Properties

Article ID: 813989 - Last Review: September 28, 2006 - Revision: 5.2
APPLIES TO
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Keywords: 
kberrmsg kbprb KB813989

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com