Cannot Send Recognized Input from Tablet PC to Windows 2000 with Remote Desktop

Article translations Article translations
Article ID: 814066 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to send recognized text across a Remote Desktop connection from a Windows XP Tablet PC Edition-based computer to a Windows 2000-based server by using the Writing Pad, Write Anywhere, or Speech Dictation feature of the Tablet PC Input Panel, no text is sent. However, if you use the Input Panel's onscreen keyboard, the text is sent correctly.

CAUSE

This problem is caused by the way that Unicode input is handled by Windows 2000 over a Remote Desktop session.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   31-Jan-2003  21:34  5.0.2195.6621     42,256  Basesrv.dll 
   31-Jan-2003  21:34  5.0.2195.6660    222,992  Gdi32.dll   
   31-Jan-2003  21:34  5.0.2195.6656    710,928  Kernel32.dll
   31-Jan-2003  21:34  5.0.2195.6623    333,584  Msgina.dll  
   31-Jan-2003  20:51  5.0.2195.6661     90,232  Rdpwd.sys
   19-Dec-2002  22:11  5.0.2195.6624    166,400  Sp3res.dll  
   31-Jan-2003  21:34  5.0.2195.6655    379,664  User32.dll  
   31-Jan-2003  21:34  5.0.2195.6620    388,368  Userenv.dll 
   31-Jan-2003  20:50  5.0.2195.6661  1,620,144  Win32k.sys
   16-Dec-2002  22:25  5.0.2195.6623    179,984  Winlogon.exe
   31-Jan-2003  21:34  5.0.2195.6655    243,472  Winsrv.dll  
   31-Jan-2003  20:51  5.0.2195.6661     90,200  Rdpwd.sys
   31-Jan-2003  21:34  5.0.2195.6656    710,928  Kernel32.dll
   31-Jan-2003  21:34  5.0.2195.6661  1,620,144  Win32k.sys
   31-Jan-2003  21:34  5.0.2195.6655    243,472  Winsrv.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 814066 - Last Review: February 27, 2014 - Revision: 2.7
APPLIES TO
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbtermserv kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB814066

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com