FIX: You may receive a "Cannot apply filter on one or more fields specified in the Filter property" error message when you try to use the filter by form functionality

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Article ID: 814094 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
This article applies only to a Microsoft Access project (.adp).

Moderate: Requires basic macro, coding, and interoperability skills.
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SYMPTOMS

When you try to use the Filter By Form functionality, you may receive the following error message:
Cannot apply Filter on one or more fields specified in the Filter property.

CAUSE

This problem may occur when you connect to Microsoft SQL Server with credentials that are different from the credentials of the owner of the table that you want to filter.

RESOLUTION

Service pack information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP Service Pack
Note For information about updating Access 2002 Runtime applications, click the article number below to view the article in the Microsoft Knowledge Base:
839022 How to obtain the latest Office XP Service Pack for Access 2002 Runtime

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Size        File name     
   -------------------------------------------------
   15-Feb-2003  05:03:44   1,965,648  Msaccess.msp
   15-Feb-2003  05:29:08  10,661,468  Msaccessff.msp

Note Because of file dependencies, the most recent fix that contains the previous files may also contain additional files.

After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time      Version      Size       File name     
   -----------------------------------------------------------
   14-Feb-2003  03:30:16  10.0.5011.0  5,773,896  Msaccess.exe


This hotfix is a post-Office XP Service Pack 2 (SP-2) hotfix. To install the hotfix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 OFFXP: Overview of the Office XP Service Pack 2
Additionally, you may have to install Windows Installer 2.0 to install this hotfix. For additional information about the Windows Installer requirement for post-Office XP SP-2 hotfixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Office XP Service Pack 3 and Office XP Service Pack 3 for Access 2002 Runtime.

MORE INFORMATION

If your application accesses an SQL Server-based table when you are not the table owner, and then you try to use the Filter By Form functionality, Access internally generates a WHERE clause that contains the owner.table.column syntax. However, the Microsoft Office XP Client Data Manager cannot process this syntax. Therefore, you may see the error message in the "Symptoms" section. The error message is generated when you try to apply the filter. If you try to access the table, and you are the table owner, Access uses the table.column syntax.

Steps to Reproduce the Problem

  1. Create a new domain user in the domain where the computer that is running SQL Server is located. Grant the user who you create access to the Pubs database, and then give the user the db_datareader role.
  2. Start Microsoft Access.
  3. In the New File dialog box, click Project (Existing Data).
  4. In the File Name box, type the new Access project name, and then click Create.
  5. In the Data Link Properties dialog box, type the name of the computer that is running SQL Server, click Use a specific user name and password, and then type the user credentials that you created in step 1.
  6. In the Select the database on the server box, click pubs, and then click OK.
  7. Double-click the authors (dbo) table.
  8. On the Records menu, point to Filter, and then click Filter By Form.
  9. In the state column, type CA.
  10. On the Filter menu, click Apply Filter/Sort.

    Notice that you receive the error message in the "Symptoms" section.

Properties

Article ID: 814094 - Last Review: October 26, 2013 - Revision: 6.2
APPLIES TO
  • Microsoft Access 2002 Standard Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbofficexppresp3fix KB814094

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