Outlook renders inline message information as an attachment

Article translations Article translations
Article ID: 814111 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you receive an e-mail message that was sent with an attachment embedded as content in the message body, Outlook renders the embedded file as a separate attachment.

Note: For the purposes of this article, "embedded" means that the content is intended to appear with the message text, and not as a separate attached file.

CAUSE

This issue may occur when you receive a message that uses the content-disposition=inline MIME extension in the Internet header.

When you receive a message that uses the content-disposition=inline MIME type, Outlook renders the embedded content as an attachment.

WORKAROUND

To work around this issue, open the separate file attachments in Outlook to view their contents.

STATUS

This behavior is by design.

MORE INFORMATION

Internet Request for Comments (RFC) 2183 defines the syntax and semantics of the Content-Disposition header field. This is an optional field and is valid for any MIME entity (message or body part). The following two methods are generally used to present multipart messages:
  • A main document with a list of separate file attachments.
  • A single document with the various parts expanded (displayed) inline.
The inclusion of a separate file attachment typically requires the end user to take additional action to view the attached content. With inline message components, the content appears automatically when you view the message. The Content-Disposition header provides a way for the sender to transmit this sort of presentational information; tagging each component of the message with an indication of the appropriate presentation style. Content-Disposition is an optional header field. In its absence, the mail user agent (MUA), or e-mail client, may use whatever presentation method that it deems suitable.

For additional information about the Content-Disposition header field, visit the following Network Working Group Web site:
http://www.ietf.org/rfc/rfc2183.txt

Properties

Article ID: 814111 - Last Review: February 1, 2007 - Revision: 4.3
APPLIES TO
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
Keywords: 
kbprb KB814111

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com